
 

 

 

 

 

 
 

FSD Automation Controller Family 
 

 

 

User Manual For 

  

Foard Systems Design Automation Controller Family 

 

 

 

 

 

 

 

 

 
Foard Systems Design, Inc.   

P.O. Box 51641 

Durham, NC  27717 

www.foardsystems.com 

 

 



  



 

This Manual is divided into the following sections.  Select a choice 

for more options. 
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FSD Controller Installation Guides 
 
Select the FSD Controller type below to display its installation manual. 

 

FSD Controller Installation 

 

FSD X10 Compact Controller – guide to install controller that controls X10 family devices 

 

FSD UPB Compact Controller – guide to install controller that controls UPB family devices 

 

FSD X10-UPB Compact Bridge – guide to install bridge that allows control of X10 and UPB family devices on the 

same system 

 

FSD X10-UPB-FGI Bridge Controller – guide to install bridge that allows control of X10, UPB, and FGI family 

devices on the same system 

 

FSD X10-UPB-FGI Bridge Controller Plus – guide to install bridge controller that allows control of X10, UPB, and 

FGI family devices on the same system, with time-of-day timer features 

 

 

FSD System -Installation of Device Families 

 

FSD System Installation Notes for X10 Devices – notes and background on X10 products. 

 

FSD System Installation Notes for UPB Devices – notes and background on UPB products. 

 

FSD System Installation Notes for FGI Devices – notes and background on FGI products. 

 

 

 

  



FSD X10 Compact Controller Installation Guide 
  

Overview:  The FSD Compact Controller can be configured to control systems using either X10 or UPB technology. 

  

(The configuration may be changed by software as explained in another document). 

  

For the FSD X10 Compact Controller: 

  

1. Unpack the shipping box.  It should contain: 

a. FSD X10 Compact Controller 

b. Installation disk 

c. USB cable 

d. RJ11 cable 

e. Power transformer, 9 VAC 

DO NOT plug any cables into the FSD Compact Controller at this time. 

  

2. Install programs 

a. Insert the Installation CD into the CD or DVD drive of your computer. 

b. The installer starts automatically.  If not, open Windows Explorer and select the CD or DVD 

drive.  Double-click on the install_fsd_controller application to start installing files. 

c. Click the ―Install Software‖ button to begin installation. 

d. Read the License Agreement, and click the ―I agree‖ button to continue.  Use the ―Back‖ and 

―Next‖ buttons to navigate within the installer.  
e. In the Select Installation Options screen, select the controller type. 

f. For the initial 

installation, select the 

(controller attached to 

computer) installation 

type, and set the type of 

connection port to 

either USB Port or RS-

232 Serial Port. 

g. Alternatively, if setting 

up an additional 

computer, select the 

(controller accessed via 

Internet or LAN) 

installation type, and 

read the remote access 

configuration 

instructions. 

h. Enter the installation 

root directory 

destination in the edit 

box or choose the 

directory with the 

―Browse‖ button. 

i. Verify selected options before proceeding to install. 

  

3. Connect the Controller: 

After the software installation succeeds, connect the controller cables as shown in the picture at the end of this 

section. 

a. Plug the power transformer into an electrical receptacle and insert into the controller box at the 

port marked ―AC PWR‖. 

b. To use the USB Port , connect the USB cable to the USB port on your computer and the other end 

to the port marked ―USB‖ on the FSD Compact Controller box.  Windows XP should find and 

recognize the new device. 

c. To use the RS-232 Serial Port, connect a standard ―Null Modem‖ (twisted) serial cable from the 

computer to the controller‘s serial port. 

d. Connect the provided RJ-11 cable from the FSD X10 Compact Controller port marked ―X10 

OUT‖ to a TW-523, PSC-05, PL-513, or similar X10 interface module.  USE THE CABLE 



SUPPLIED WITH THE KIT.  Do NOT use regular telephone cable.  
 

 
  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

  

 

 

 

 

4. Naming System Devices 

a. From the bin folder in the installation directory you‘ve specified, double-click on ―Autostart‖. 

b. For Windows XP users, a dialog box may appear querying whether the firewall should continue 

blocking the application.  Unblock the Router application.  Close all open FSD software 

applications and restart the Autostart application. 

c. The ―FGI Devices‖ dialog appears (initial configuration only). 

i. Double click on the entry whose Type Name is ―FSD Controller‖. 

ii. Enter a Device Name and Device Location. 

iii. Click ―OK‖. 

iv. Click ―OK‖ in the FGI Devices dialog. 

  



 

 

 

 

 

  

  

  

  

 

 

 

 

 

 

 

 

 

 

 

 

d. From the ―Timers, Etc.‖ dialog insert and name an X10 Interface (TW523) device. 
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e. From the ―X10 Devices‖ dialog insert, name, and set the address for one or more X10 devices. 

f. From the ―Timers, Etc.‖ dialog insert and name any timer virtual devices desired. 

g. Additional X10 Devices can be added by: 

i. From the Automator View menu select ―FSD Namer‖ and choose ―X10 Devices‖ to enter 

X10 devices. 

ii. Click ―Insert‖ button. 

iii. Select a X10 Device Type from the droplist. 

iv. Enter a X10 Device Name and Location. 

v. Choose the X10 controller on your system from the droplist. 

vi. Enter a House Code and Unit Code from their respective droplists. 

vii. Click ―OK‖ 

viii. Repeat steps 4g(ii) through 4g(vii) for each X10 device to enter. 

ix. Click ―OK‖ in X10 Device List. 

x. Dialog appears to either load configuration, now or later.  Load Configuration after all 

X10 devices on the system are entered.  When finished inserting devices, under the File 

menu choose ―Load Configuration‖. 

h.  Similarly, additional Timers and Variables can be added from Automator :: View  FSD 

Namer. 



  

5. Help 

Additional tutorials and documents that describe device setup, configuration, and device use are available under 

the Help menu in FSD Automator, and from the HELP menu for each FSD application to access its user 

manual. 

  

6. Operation 

For normal operation, start the software by running Autostart from the ―bin‖ folder in the directory you 

specified during installation.  Autostart setting options are found in Automator Options menu, by selecting ―Set 

Autostart Options‖. 

  

7. Troubleshooting 

Please refer to the “FSD Controller Troubleshooting Guide”, located in the Help menu in FSD Automator 

―View Configuration Guides‖. 

  

  



FSD UPB Compact Controller Installation Guide 
  

Overview:  The FSD Compact Controller can be configured to control systems using either X10 or UPB technology. 

  

(The configuration may be changed by software as explained in another document). 

  

For the FSD UPB Compact Controller: 

  

  

1. Unpack the shipping box.  It should contain: 

a. FSD Compact Controller 

b. Installation disk 

c. USB cable 

d. Power transformer, 9 VAC 

DO NOT plug any cables into the FSD Compact Controller at this time. 

  

2. Install programs 

a. Insert the Installation CD into the CD or DVD drive of your computer. 

b. The installer starts automatically.  If not, open Windows Explorer and select the CD or DVD 

drive.  Double-click on the install_fsd_controller application to start installing files. 

c. Click the ―Install Software‖ button to begin installation. 

d. Read the License Agreement, and click the ―I agree‖ button to continue.  Use the ―Back‖ and 

―Next‖ buttons to navigate within the installer. 

e. For the initial installation, select the (controller attached to computer) installation type, and set the 

type of connection port to USB 

Port.  
 f. Alternatively, if setting up an 

additional computer, select the 

(controller accessed via 

Internet or LAN) installation 

type, and read the remote 

access configuration 

instructions. 

h. Enter the installation root 

directory destination in the edit 

box or choose using the 

―Browse‖ button 

i. Verify selected options before 

proceeding to install. 

  

3. Connect the Controller: 

After the software installation succeeds, 

connect the controller cables as shown in the 

picture at the end of this section. 

a. Plug the power transformer into 

an electrical receptacle and insert into the controller box at the port marked ―AC PWR‖. 

b. Connect the USB cable to the USB port on your computer and the other end to the port marked 

―USB‖ on the FSD Compact Controller box.  Windows XP should find and recognize the new 

device. 

c. Connect the UPB Interface serial cable to the FSD UPB Compact Controller serial port. 

  

 



 
  

4. Naming System Devices 

a. From the bin folder in the installation directory you‘ve specified, double-click on ―Autostart‖. 

b. For Windows XP users, a dialog box appears querying whether the firewall should continue 

blocking the application.  Unblock the Router application.  Close all open FSD software 

applications and restart the Autostart application. 

c. The ―FGI Devices‖ dialog appears (initial configuration only). 

i. Double click on the entry whose Type Name is ―FSD Controller‖. 

ii. Enter a Device Name and Device Location. 

iii. Click ―OK‖. 

iv. Click ―OK‖ in the FGI Devices dialog. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

d. From the ―RS-232/485 Devices‖ dialog insert and name a UPB Interface (PIM) device.  Set your 

Network and Network Password values that you used in the PCS Upstart UPB configuration 

utility to configure your UPB devices. 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

e. From the ―UPB Devices‖ dialog insert, name, and set the address for one or more UPB devices. 

f. From the ―Timers, Etc.‖ dialog insert and name any timer virtual devices desired. 

g. Additional UPB Devices can be added later by: 

i. From the View menu select ―FSD Namer‖ and choose ―UPB Devices‖ to enter UPB 

devices. 

ii. Click ―Insert‖ button. 

iii. Select a UPB Device Type from the droplist. 

iv. Enter a UPB Device Name and Location. 

v. Choose the UPB controller on your system from the droplist. 

vi. Enter a Network ID and Unit ID from their respective droplists.  (If the ID values are 

unknown, from the View menu choose ―UPB Installer Tools‖ and ―UPB Upstart‖.  If 

path to Upstart.exe is not configured, in Automator, under the Options menu, choose Set 

Automator Options.  At the bottom of the dialog enter the path to Upstart.exe, if known. 

(Consult your UPB manuals for instructions for UPB Upstart.) 

vii. Click ―OK‖. 

viii. Repeat steps 4g(ii) through 4g(vii) for each UPB device to enter. 

ix. Click ―OK‖ in UPB Device List. 

x. Dialog appears to either load configuration, now or later.  Load Configuration after all 

UPB devices on system are entered.  When finished inserting devices, under the File 

menu choose ―Load Configuration‖. 

h. Similarly, additional Timers and Variables can be added from Automator :: View  FSD 

Namer. 

  

5. Help 

Additional tutorials and documents that describe device setup, configuration, and device use are available under 

the Help menu in FSD Automator, and from the HELP menu for each FSD application to access its user 

manual. 

  

6. Operation 

For normal operation, start the software by running Autostart from the ―bin‖ folder in the directory you 

specified during installation.  Autostart setting options are found in Automator Options menu, by selecting ―Set 

Autostart Options‖. 

  

7. Troubleshooting 

Please refer to the “FSD Controller Troubleshooting Guide”, located in the Help menu in FSD Automator ―View 

Configuration Guides‖. 

  



FSD X10 – UPB Compact Bridge Installation Guide 
  

For the FSD X10-UPB Compact Bridge 

  

1. Unpack the shipping box.  It should contain: 

a. FSD Compact Bridge 

b. Installation disk 

c. RJ-11 cable 

d. Power transformer, 9 VAC 

DO NOT plug any cables into the FSD Compact Bridge at this time. 

  

2. Install programs 

a. Insert the Installation CD into the CD or DVD drive of your computer. 

b. The installer starts automatically.  If not, open Windows Explorer and select the CD or DVD 

drive.  Double-click on the install_fsd_controller application to start installing files. 

c. Click the ―Install Software‖ button to begin installation. 

d. Read the License Agreement, and click the ―I agree‖ button to continue.  Use the ―Back‖ and 

―Next‖ buttons to navigate within the installer. 

e. For the initial installation, select the (controller attached to computer) installation type, and set the 

type of connection port to RS-232 

Serial Port.  
f. Alternatively, if setting up an 

additional computer, select the 

(controller accessed via Internet or 

LAN) installation type, and read the 

remote access configuration 

instructions. 

g. Enter the installation root directory 

destination in the edit box or choose a 

directory with the ―Browse‖ button. 

h. Verify selected options before 

proceeding to install. 

  

  

  

  

  

3. Connect the FSD Bridge Controller: 

After the software installation succeeds, connect the controller cables as shown in the picture at the end of this 

installation guide. 

a. Plug the power transformer into an electrical receptacle and insert into the controller box at the 

port marked ―AC PWR‖. 

b. Connect either a standard Null Modem (twisted) cable to your computer and the other end to the 

port marked ―Serial‖ on the FSD X10-UPB Compact Bridge.  CAUTION:  If your computer does 

not have a serial port, some third party USB to serial conversion cables do not properly configure 

to the proper pins. 

c. After device configuration (see section 4, naming the system), disconnect the null modem cable 

from the computer and the FSD X10-UPB Compact Bridge, and connect a serial cable (straight 

cable, UPB Interface) from the FSD X10-UPB Compact Bridge serial port to the UPB Power Line 

Interface Module.  Note that the same serial cable cannot be used for both connections without 

also using a null modem adapter. 

d. Connect the provided RJ-11 cable from the FSD X10-UPB Compact Bridge port marked ―X10 

OUT‖ to a TW-523, PSC-05, PL-513, or similar X10 interface module.  USE THE CABLE 

SUPPLIED WITH THE KIT.  Do NOT use regular telephone cable. 

e. Optionally, connect an RJ-11 cable from the FSD X10-UPB Compact Bridge port marked ―X10 IN‖ 

to the X10 powerline interface output port of a legacy X10 controller.  Use the RJ11 cable which 

would otherwise connect the legacy controller to a TW-523, PSC-05, PL-513, or similar X10 

interface module. 

  

  

  

  



  

  

  

  

  

  

  

  

  

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Naming System Devices 

a. From the bin folder in the installation directory you‘ve specified, double-click on ―Autostart‖. 

b. For Windows XP users, a dialog box may appear querying whether the firewall should continue 

blocking the application.  Unblock the Router application.  Close all open FSD software 

applications and restart the Autostart application. 

c. The ―FGI Devices‖ dialog appears (initial configuration only). 

i. Double click on the entry whose Type Name is ―FSD Controller‖. 

ii. Enter a Device Name and Device Location. 

iii. Click ―OK‖. 

iv. Click ―OK‖ in the FGI Devices dialog. 

NOTE:  If you plan to simply bridge UPB and X10 commands for simple on/off and dimming with 

lighting, you might want to use FSD Super Bridge or Super Fine Bridge.  See  Configure X10-

UPB Bridge.  If so, you can skip parts ―e‖ and ―g‖ below and follow instructions in the above 

link.  

d. From the ―Timers, Etc.‖ dialog, click ―Insert‖ and name an X10 Interface (TW523) device. 

e. From the ―X10 Devices‖ dialog , click ―Insert‖ , name, and set the address for one or more X10 

devices. 

  

Example_Scenarios/Configure%20X10-UPB%20Bridge.pdf
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f. From the ―RS-232/485 Devices‖ dialog, click ―Insert‖ and name a UPB Interface (PIM) device.  Set 

your Network and Network Password values that you used in the PCS Upstart UPB configuration 

utility to configure your UPB devices.  
 

 

 

 

 

 

 

 

 

 

 

g. From the ―UPB Devices‖ dialog, click ―Insert‖ , name, and set the address for one or more UPB 

devices. 

h. From the ―Timers, Etc.‖ dialog, click ―Insert‖ and name any Super Bridge and/or Button Control 

virtual devices desired. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

i. Additional UPB Devices can be added later by: 

i. From the View menu select ―FSD Namer‖ and choose ―UPB Devices‖ to enter UPB de        

vices. 

ii. Click ―Insert‖ button. 

iii. Select a UPB Device Type from the droplist. 

iv. Enter a UPB Device Name and Location. 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

v. Choose the UPB controller on your system from the droplist. 

vi. Enter a Network ID and Unit ID from their respective droplists.  (If the ID values are 

unknown, from the View menu choose ―UPB Installer Tools‖ and ―UPB Upstart‖.  If the 

path to Upstart.exe is not configured, in Automator, under the Options menu, choose Set 

Automator Options.  At the bottom of the dialog enter the path to Upstart.exe, if known. 

(Consult your UPB manuals for instructions for UPB Upstart.)) 

vii. Click ―OK‖. 

viii. Repeat steps 4i(ii) through 4i(vii) for each UPB device to enter. 

ix. Click ―OK‖ in UPB Device List. 

x. Dialog appears to either load configuration, now or later.  Load Configuration after all 

UPB devices on system are entered.  When finished inserting devices, under the File 

menu choose ―Load Configuration‖. 

j. Similarly, additional X10 devices can be added later from Automator:: View  FSD Namer. 

k. Similarly, additional Timers and Variables can be added from Automator :: View 

Namer. 

  

5. Help 

Additional tutorials and documents that describe device setup, configuration, and device use are available under 

the Help menu in FSD Automator, and from the HELP menu for each FSD application to access its user 

manual. 

  

6. Operation 

For normal operation, start the software by running Autostart from the ―bin‖ folder in the directory you 

specified during installation.  Autostart setting options are found in Automator Options menu, by selecting ―Set 

Autostart Options‖. 

  

7. Troubleshooting 

Please refer to the “FSD Controller Troubleshooting Guide”, located in the Help menu in FSD Automator 

―View Configuration Guides‖. 

  

 

  

  

 

  

  

FSD X10 – UPB - FGI Bridge Controller Installation Guide 
  

For the FSD X10-UPB-FGI Bridge Controller: 

  

  

1. Unpack the shipping box.  It should contain: 

a. FSD Bridge Controller 



b. Installation disk 

c. USB cable 

d. RJ-11 Cable 

e. Power transformer, 14 VAC 

DO NOT plug any cables into the FSD Bridge Controller at this time. 

  

2. Install programs 

a. Insert the Installation CD into the CD or DVD drive of your computer. 

b. The installer starts automatically.  If not, open Windows Explorer and select the CD or DVD 

drive.  Double-click on the install_fsd_controller application to start installing files. 

c. Click the ―Install Software‖ button to begin installation. 

d. Read the License Agreement, and click the ―I agree‖ button to continue.  Use the ―Back‖ and 

―Next->‖ buttons to navigate within the installer. 

e. For the initial installation, select the (controller attached to computer) installation type, and set the 

type of connection port to USB Port. 

 f. Alternatively, if setting up an additional computer, select the (controller accessed via Internet or 

LAN) installation type, and read the remote access configuration instructions. 

g. Enter the installation root directory destination in the edit box or choose using the ―Browse‖ 

button 

h. Verify selected options before proceeding to install. 

  

3. Connect the FSD Controller 

After the software installation succeeds, connect the controller cables as shown in the picture at the end of this 

section. 

a. Plug the power transformer into an electrical receptacle and insert into the controller box at the 

port marked ―AC PWR‖. 

b. Connect the USB cable to the USB port on your computer and the other end to the port marked 

―USB‖ on the FSD Compact Controller box.  Windows XP should find and recognize the new 

device. 

c. Connect the UPB Interface serial cable to the FSD UPB Compact Controller serial port. 

d. Connect the provided RJ-11 cable from the FSD X10UPB-FGI Bridge Controller port marked 

―X10 OUT‖ to a TW-523, PSC-05, PL-513, or similar X10 interface module. 

e. Optionally, connect an RJ-11 cable from the FSD X10-UPB-FGI Bridge Controller port marked 

―X10 IN‖ to the X10 powerline interface output port of a legacy X10 controller.  Use the RJ11 

cable which would otherwise connect the legacy controller to a TW-523, PSC-05, PL-513, or 

similar X10 interface module. 

f. Connect any FGI hardwired device to the Bridge Controller‘s FGI port.  This port is designated as a 

daisy-chain out (DO) port.  FGI devices may be daisy-chained to connect to the controller.  

Additionally, multiple FGI devices may be connected in a branched tree configuration, with each 

FGI device‘s daisy-chain in (DI) port connected to the controller‘s FGI DO port or to either the 

DO1 or DO2 port on another FGI device.  Tree branching can also be accomplished by connecting 

to one of the nine DO ports on the FGI Hub device. 

  

 

  

  

  

  

  



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Naming System Devices 

a. From the bin folder in the installation directory you‘ve specified, double-click on ―Autostart‖. 

b. For Windows XP users, a dialog box may appear querying whether the firewall should continue 

blocking the application.  Unblock the Router application.  Close all open FSD software 

applications and restart the Autostart application. 

c. The ―FGI Devices‖ dialog appears (initial configuration only). 

i. Double click on the entry whose Type Name is ―FSD Controller‖. 

ii. Enter a Device Name and Device Location. 

iii. Click ―OK‖. 

iv. Similarly, enter device names and locations for all hardwired FGI devices detected by the 

controller.  The controller automatically finds and identifies the device type of all 

connected FGI devices.  Double-click on the FGI devices displayed, enter a Device Name 

and Device Location, and click ―OK‖. 

v. When completed, click ―OK‖ in the FGI Devices dialog. 

NOTE:  If you plan to simply bridge UPB and X10 commands for simple on/off and dimming with 

lighting, you might want to use FSD Super Bridge or Super Fine Bridge.  See  Configure X10-

UPB-FGI Bridge.  If so, you can skip parts ―e‖ and ―g‖ below and follow instructions in the above 

link. 

  

d. From the ―Timers, Etc.‖ dialog insert and name an X10 Interface (TW523) device. 

e. From the ―X10 Devices‖ dialog insert, name, and set the address for one or more X10 devices. 

f. From the ―RS-232/485 Devices‖ dialog insert and name a UPB Interface (PIM) device.  Set your 

Network and Network Password values that you used in the PCS Upstart UPB configuration 

utility to configure your UPB devices. 

g. From the ―UPB Devices‖ dialog insert, name, and set the address for one or more UPB devices. 

h. From the ―Timers, Etc.‖ dialog insert and name any Super Bridge and/or Button Control virtual 

devices desired. 

i. Additional UPB Devices can be added later by:: 

i. From the View menu select ―FSD Namer‖ and choose ―UPB Devices‖ to enter UPB 

Example_Scenarios/Configure%20X10-UPB-FGI%20Bridge.pdf
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devices. 

ii. Click ―Insert‖ button. 

iii. Select a UPB Device Type from the droplist. 

iv. Enter a UPB Device Name and Location. 

v. Choose the UPB controller on your system from the droplist. 

vi. Enter a Network ID and Unit ID from their respective droplists.  (If the ID values are 

unknown, from the View menu choose ―UPB Installer Tools‖ and ―UPB Upstart‖.  If 

path to Upstart.exe is not configured, in Automator, under the Options menu, choose Set 

Automator Options.  At the bottom of the dialog enter the path to Upstart.exe, if known. 

(Consult your UPB manuals for instructions for UPB Upstart.) 

vii. Click ―OK‖. 

viii. Repeat steps 4i(ii) through 4i(vii) for each UPB device to enter. 

ix. Click ―OK‖ in UPB Device List. 

x. Dialog appears to either load configuration, now or later.  Load Configuration after all 

UPB devices on system are entered.  When finished inserting devices, under the File 

menu choose ―Load Configuration‖. 

j. Similarly, additional X10 devices can be added later from Automator:: View -> Namer. 

k. Similarly, additional Timers, Etc. family devices (Super Bridge and Button Control) and Variables 

can be added from Automator :: View  Namer 

  

  

5. Help 

Additional tutorials and documents that describe device setup, configuration, and device use are available under 

the Help menu in FSD Automator, and from the HELP menu for each FSD application to access its user 

manual. 

  

6. Operation 

For normal operation, start the software by running Autostart from the ―bin‖ folder in the directory you 

specified during installation.  Autostart setting options are found in Automator Options menu, by selecting ―Set 

Autostart Options‖. 

  

7. Troubleshooting 

Please refer to the “FSD Controller Troubleshooting Guide”, located in the Help menu in FSD Automator 

―View Configuration Guides‖. 

  

8. FGI Devices 

  

For information about FGI Devices, including FGI device types supported by the FSD X10-UPB-FGI Bridge 

Controller, see the ―FSD System Installation Notes for FGI Devices”, located in the Help menu in FSD 

Automator ―View Configuration Guides‖ .   

  



 FSD X10 – UPB - FGI Bridge Controller Plus Installation Guide 
  

For the FSD X10-UPB-FGI Bridge Controller Plus: 

  

  

1. Unpack the shipping box.  It should contain: 

a. FSD X10/UPB/FGI Bridge Controller Plus 

b. Installation disk 

c. USB cable 

d. RJ-11 Cable 

e. Power transformer, 14 VAC 

DO NOT plug any cables into the FSD Bridge Controller at this time. 

  

2. Install programs 

a. Insert the Installation CD into the CD or DVD drive of your computer. 

b. The installer starts automatically.  If not, open Windows Explorer and select the CD or DVD 

drive.  Double-click on the install_fsd_controller application to start installing files. 

c. Click the ―Install Software‖ button to begin installation. 

d. Read the License Agreement, and click the ―I agree‖ button to continue.  Use the ―Back‖ and 

―Next->‖ buttons to navigate within the installer. 

e. For the initial installation, select the 

(controller attached to computer) 

installation type, and set the type of 

connection port to USB Port. 

 f. Alternatively, if setting up an additional 

computer, select the (controller 

accessed via Internet or LAN) 

installation type, and read the remote 

access configuration instructions. 

g. Enter the installation root directory 

destination in the edit box or choose a 

directory with the ―Browse‖ button. 

h. Verify selected options before proceeding 

to install.  Click ―Next‖. 

i. The next dialog box asks if you wish to 

install a driver to that allows 

communication between the computer‘s 

USB port to the Controller.  Click 

―Install‖. 

j. After successful installation, a dialog appears with buttons to 

 ―View Installation Guide for Next Steps‖.  Asks whether or not to install Adobe Reader and 

opens to this document. 

 ―Start FSD Automator Now‖.  Choose only if the following section is completed. 

 ―Exit‖.  Exits installation application. 

  

  

  

3. Connect the FSD Bridge Controller 

After the software installation succeeds, connect the controller cables as shown in the picture at the end of this 

section. 

a. Plug the power transformer into an electrical receptacle and insert into the controller box at the 

port marked ―AC PWR‖. 

b. Connect the USB cable to the USB port on your computer and the other end to the port marked 

―USB‖ on the FSD X10-UPB-FGI Bridge Controller box.  Windows XP should find and 

recognize the new device. 

c. Connect the UPB Interface serial cable to the FSD X10-UPB-FGI Bridge Controller Plus serial 

port and the UPB Power Line Interface. 

d. Connect the provided RJ-11 cable from the FSD X10-UPB-FGI Bridge Controller port marked 

―X10 OUT‖ to a TW-523, PSC-05, PL-513, or similar X10 interface module.  USE THE CABLE 

SUPPLIED WITH THE KIT.  Do NOT use regular telephone cable. 

e. Optionally, connect an RJ-11 cable from the FSD X10-UPB-FGI Bridge Controller port marked 



―X10 IN‖ to the X10 powerline interface output port of a legacy X10 controller.  Use the RJ11 

cable which would otherwise connect the legacy controller to a TW-523, PSC-05, PL-513, or 

similar X10 interface module. 

f. Connect any FGI hardwired device to the Bridge Controller‘s FGI port.  This port is designated as a 

daisy-chain out (DO) port.  FGI devices may be daisy-chained to connect to the controller.  

Additionally, multiple FGI devices may be connected in a branched tree configuration, with each 

FGI device‘s daisy-chain in (DI) port connected to the controller‘s FGI DO port or to either the 

DO1 or DO2 port on another FGI device.  Tree branching can also be accomplished by connecting 

to one of the nine DO ports on the FGI Hub device.  
  

 

  

  

 

 

 

 

 

 

 

 

 

 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



4. Naming System Devices 

a. From the bin folder in the installation directory you‘ve specified, double-click on ―Autostart‖. 

b. For Windows XP users, a dialog box may appear querying whether the firewall should continue 

blocking the application.  Unblock the Router application.  Close all open FSD software 

applications and restart the Autostart application. 

c. Use the Set Location and Time dialog to your geographic location, necessary for proper calculation 

of dawn and dusk times.  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE:  If you plan to simply bridge UPB and X10 commands for simple on/off and dimming with 

lighting, you might want to use FSD Super Bridge or Super Fine Bridge.  See  Configure X10-

UPB-FGI Bridge Plus.  If so, you can skip parts ―f‖ and ―h‖ below and follow instructions in the 

above link. 

  

d. The ―FGI Devices‖ dialog appears (initial configuration only). 

i. Double click on the entry whose Type Name is ―FSD Controller‖. 

ii. Enter a Device Name and Device Location. 

iii. Click ―OK‖. 

iv. Similarly, enter device names and locations for all hardwired FGI devices detected by the 

controller.  The controller automatically finds and identifies the device type of all 

connected FGI devices.  Double-click on the FGI devices displayed, enter a Device Name 

and Device Location, and click ―OK‖. 

v. When completed, click ―OK‖ in the FGI Devices dialog. 

  

  

 

 

 

 

Example_Scenarios/Configure%20X10-UPB-FGI%20Bridge%20Plus.pdf
Example_Scenarios/Configure%20X10-UPB-FGI%20Bridge%20Plus.pdf


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

e. From the ―Timers, Etc.‖ dialog, choose ―Insert‖ and name an X10 Interface (TW523) device. 

  

  

f. From the ―X10 Devices‖ dialog choose ―Insert‖, name, and set the address for one or more X10 

devices. 

g. From the ―RS-232/485 Devices‖ dialog choose ―Insert‖ and name a UPB Interface (PIM) device.  

Set your Network and Network Password values that you used in the PCS Upstart UPB 

configuration utility to configure your UPB devices.  
  

  

  

  

  

  

  

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

h. From the ―UPB Devices‖ dialog choose ―Insert‖, name, and set the address for one or more UPB 

devices. 

i. From the ―Timers, Etc.‖ dialog choose ―Insert‖ and name any Super Bridge and/or Button Control 

virtual devices desired. 

j. Additional UPB Devices can be added later by:: 

i. From the View menu select ―FSD Namer‖ and choose ―UPB Devices‖ to enter UPB 

devices. 

ii. Click ―Insert‖ button. 

iii. Select a UPB Device Type from the droplist. 

iv. Enter a UPB Device Name and Location. 

v. Choose the UPB controller on your system from the droplist. 

vi. Enter a Network ID and Unit ID from their respective droplists.  (If the ID values are 

unknown, from the View menu choose ―UPB Installer Tools‖ and ―UPB Upstart‖.  If 

path to Upstart.exe is not configured, in Automator, under the Options menu, choose Set 

Automator Options.  At the bottom of the dialog enter the path to Upstart.exe, if known. 

(Consult your UPB manuals for instructions for UPB Upstart.) 

vii. Click ―OK‖. 

viii. Repeat steps 4i(ii) through 4i(vii) for each UPB device to enter. 

ix. Click ―OK‖ in UPB Device List. 

x. Dialog appears to either load configuration, now or later.  Load Configuration after all 

UPB devices on system are entered.  When finished inserting devices, under the File 

menu choose ―Load Configuration‖. 

k. Similarly, additional X10 devices can be added later from Automator:: View -> FSD Namer. 

l. Similarly, additional Timers, Etc. family devices (Time of Day Event, Super Bridge, and Button 

Control) and Variables can be added from Automator :: View  FSD Namer. 

  

  

5. Help 

Additional tutorials and documents that describe device setup, configuration, and device use are available under 

the Help menu in FSD Automator, and from the HELP menu for each FSD application to access its user 

manual. 

  

  

6. Operation 

For normal operation, start the software by running Autostart from the ―bin‖ folder in the directory you 

specified during installation.  Autostart setting options are found in Automator Options menu, by selecting ―Set 

Autostart Options‖. 

  

7. Troubleshooting 

Please refer to the “FSD Controller Troubleshooting Guide”, located in the Help menu in FSD Automator 

―View Configuration Guides‖. 

  

8. FGI Devices 

  



For information about FGI Devices, including FGI device types supported by the FSD X10-UPB-FGI Bridge 

Controller, see the ―FSD System Installation Notes for FGI Devices”, located in the Help menu in FSD 

Automator ―View Configuration Guides‖ .   

  

  



 FSD System Installation Notes for X10 Devices 

  

X10 is a power line control technology, which has been in use for over 25 years.  X10 devices 

are readily available, easy to use when they work, and many are inexpensive.  Ensuring X10 

signal integrity in an installation is important to satisfactory performance, as is discussed below. 

  

Most X10 devices are ―One-Way‖ devices, either transmitters or receivers.   Therefore, a 

controller or other device cannot know if a device, such as a wall-mounted light dimmer switch, 

is manually turned ON or OFF.  Some X10 devices are capable of ―Two-Way‖ communications.  

These devices are more expensive, so often not selected.  Inexpensive X10 devices generally 

support only a minimal command set, while some X10 devices also support features such as 

scene control via X10 Extended Commands.  Note that the interpretation of X10 Extended 

Commands is inconsistent across manufacturers, so when used, the variant of X10 Extended 

Commands must also be specified. 

  

FSD Controllers connect to X10 devices through an X10 power line interface module, such as a 

TW523, PSC05, or PL513.  Some FSD Controllers may also connect via a CM11A device. 

  

FSD Bridge devices can also emulate a TW523, PSC05, or PL513 device connected to a legacy 

controller, enabling the legacy controller to communicate with UPB and FGI hardwired devices, 

as though they were X10 devices. 

  

To configure the FSD Controller for use with a TW523, PSC05, or PL513 interface, from the 

FSD Automator main menu, select View  FSD Namer  Timers, Etc., then from FSD Namer, 

insert an X10 Interface (TW523) device.  This device is also used to configure the controller for 

X10 interface emulation.  Interface options are specified in the device configuration dialog for 

the X10 Interface device.  The TW523 and PSC05 are the recommended X10 interfaces for 

general controller use.  The PL513 interface is transmit only, hence if used external X10 signals 

cannot reach the FSD Controller. 

  

If supported by the FSD Controller model, the user can configure the FSD Controller to use an 

CM11A interface.  From the FSD Automator main menu, select View  FSD Namer  

RS232/485 Devices, then in FSD Namer, insert an X10 Interface (CM11A) device.  Note that the 

CM11A may be the best option for some X10 logging purposes, since it can receive X10 

Extended Commands, while the TW523 cannot.  However, the CM11A is not recommended for 

general control purposes, as it can introduce undesired delays between the X10 signals and the 

FSD Controller. 

  

Most X10 devices are easily configured by setting house code and unit code values on 

thumbwheel switches.  Some devices are configured by pushing a button, or simply applying 

power, followed by using another source to send an X10 command with the address you wish to 

set the device to. 

  

For individual control, each X10 device should be defined for the FSD Controller using FSD 

Namer  X10 Devices.  Alternatively, groups of up to sixteen X10 device addresses can be 

linked through a Super Bridge device (defined in FSD Namer  Timers, Etc.), as might be done 

to configure an FSD Bridge controller. 

  

Linking X10 Devices with Operations: 

  

Since most X10 devices do not report their states, the FSD Controller and other X10 devices may 

not always  know for certain the state of an X10 device.  Therefore, if one needs to turn ON an 



X10 device, an X10 ON command should be sent regardless of the state the controller thinks the 

X10 device is in.  Similarly, a received X10 OFF command for a device should be processed to 

cause configured OFF transition actions, even if the controller‘s last knowledge if the device 

state indicates that the device is already OFF. 

  

This is accomplished by linking control operations with the Momentary ON and Momentary 

OFF elements for a switch, lamp, or appliance device, instead of the device‘s On/Off State 

element, which indicates the last known state of the device.  To interconnect two devices‘ 

Momentary On elements, along with their Momentary Off elements, add a 

SET_MOMENTARY_PAIR operation to the Momentary ON elements for the devices; the 

Momentary OFF elements are implicitly linked together.  The SET_MOMENTARY_PAIR 

operation is often the easiest option to interconnect a switch with a lamp or appliance module.  

The SET_TO_VALUE operation may link operations to individual Momentary ON or OFF 

elements for maximum flexibility and asymmetrical operations; for example, a switch might be 

configured to turn ON lights in the downstairs hallway, and to turn OFF all downstairs light. 

  

X10 Installer Tools: 

  

The FSD Controller software includes utilities to aid in installation.  Tools are included to 

monitor and log X10 packets sent and received, to display X10 addresses in use, and to send 

arbitrary X10 commands and extended commands to test an installation.  Tools are accessed 

from the FSD Automator main menu, by selecting View  X10 Installer Tools  (X10 Logger, 

X10 Mapper, or X10 Tester). 

  

Signal Integrity Issues: 

  

For many single family residences, X10 signals may need assistance communicating between 

devices attached on opposite legs of the 230 volt split-phase line.  For smaller houses, installing a 

relatively low cost X10 signal coupler across the 230 volt line may suffice.  For larger homes, or 

to eliminate guesswork and improve the X10 signal levels throughout any size home, install an 

X10 repeater across the two phases. 

  

For locations with three phase power, found in many commercial settings, a three-phase X10 

repeater must be installed to communicate across the phases. 

  

X10 signals may be absorbed by surge protectors, reducing signal levels and preventing reliable 

communication.  Some brands of surge protectors are friendlier to X10 signals than others.  X10 

signal analyzers are available to help determine whether the signal level is sufficient at 

troublesome locations. 

  

X10 communication may also be hampered by interference from other noisy power line devices, 

such as a fan or light dimmer.  X10 line filtering devices are available to help isolate offending 

devices from the power line. 

  

X10 signals could reach a neighboring house, if connected to the same line transformer.  If so, an 

X10 blocking coupler can be installed at the power feed point to one or both houses to eliminate 

house-to-house interference.  Alternatively, neighbors might simply agree to use distinct sets of 

house codes for their X10 devices. 

  

Device Specific Notes: 

  

The X10 small transceiver (RTM75) is an RF receiver that can control X10 devices on up to 16 



addresses on one house code.  The module also has a switched outlet controlled from unit code 1 

on the RF transmitter.  Note that the module has no X10 receive capability, so the switched 

outlet cannot be controlled via X10 power line commands from other X10 devices or an X10 

controller. 

  

The large X10 transceiver (RR501) is similar to the small transceiver, but has an X10 signal 

receiver.  Thus, the switched outlet can be controlled via X10 power line signals from an X10 

controller or other X10 device. 

  

Manufacturer’s web site: 

  

www.x10.com/support            X10.com 

  

  

  
  

  



FSD System Installation Notes for UPB Devices 
  

Universal Powerline Bus (UPB) is a power line control technology developed by Powerline 

Control Systems, Inc. (PCS).  UPB provides highly reliable communications, and all UPB 

devices are capable of ―Two-Way‖ communications.  UPB devices support direct control, and 

scene-like control via UPB ―Link‖ commands. 

  

FSD Controllers interface to UPB devices through an RS-232 serial port version of a UPB 

Powerline Interface Module.  Both PIM devices from PCS and from Simply Automated, Inc. are 

supported.  To configure the FSD Controller to use either PIM, from the FSD Automator main 

menu, select View  FSD Namer  RS232/485, then from FSD Namer, insert a UPB Interface 

device.  Set the Network ID and password to match UPB devices configured using the PCS 

UPStart utility. 

  

UPB devices are initially configured with the PCS UPStart utility, available as a free download 

from the PCS web site (listed below).  Using UPStart, add each device to the network with an 

assigned Unit ID.  Devices with self-contained switches, such as wall-mounted light dimmer 

switches, should be configured to transmit local switch changes to the controller, in addition to 

performing their self-contained function. 

  

See the PCS documentation for details on using the UPStart utility, and for general information 

about UPB devices and technology. 

  

The PCS UPStart utility uses a UPB PIM device to communicate with the installed UPB devices.  

A single PIM may be shared between the PCS UPStart utility and most FSD Controller models, 

without disconnecting and reconnecting cables to alternate between the two software 

applications.  To configure FSD Automator for PCS Upstart access, select Options  Configure 

Automator and enter the PCS UPStart directory path in the configuration dialog.  To access PCS 

UPStart, select View  UPB Installer Tools  PCS UPStart; this shuts down FSD Automator 

and leaves the FSD Controller in a serial pass-through mode, bridging the UPB PIM to the PCS 

UPStart utility through the same USB or RS-232 port used by FSD Automator. 

  

For individual control, each UPB device should be defined for the FSD Controller using FSD 

Namer  UPB Devices.  Alternatively, groups of up to 16 UPB device addresses can be linked 

through a Super Bridge device (defined in FSD Namer  Timers, Etc.), as done to configure an 

FSD Bridge controller. 

  

UPB Installer Tools: 

  

The FSD Controller software includes utilities to aid installation.  Tools are included to monitor 

and log UPB packets sent and received, to display UPB addresses in use, and to send arbitrary 

UPB direct commands and link commands to test an installation.  These are accessed from the 

FSD Automator main menu, by selecting View  UPB Installer Tools  (UPB Logger, UPB 

Mapper, or UPB Tester). 

  

Note that similar capabilities are also available within the PCS UPStart utility.  If the PCS 

UPStart utility shares the same PIM with the FSD Controller, the PCS logging, monitoring, and 

testing capabilities are available while PCS UPStart is running, and the FSD UPB Installer Tools 

are available during FSD Controller run-time operation. 

  

Signal Integrity Issues: 

  



For most single family residences, UPB works reliably with no special installation concerns.  

However, installing a fairly low cost UPB signal coupler across the opposite legs of the 230 volt 

line is recommended to ensure signal quality across phases. 

  

For locations with three phase power, as found in many commercial settings, a three-phase UPB 

repeater must be installed to communicate across the phases. 

  

Manufacturer’s web site: 

  

www.pulseworx.com            Powerline Control Systems, Inc. 

  

  

  

  
  

  



FSD System Installation Notes for FGI Devices 

  

FGI Network Devices: 
 FGI networking technology provides an easy-to-use means to 

interconnect a heterogeneous mix of hard-wired remote 

sensor and control devices.  The FGI interface logic has plug-

and-play style self-identification and built-in network 

management capabilities.  FGI network devices are connected 

to an FSD Controller with RS485 port through an arbitrarily 

wired branched daisy chain tree, typically with a two-device 

fan-out after each device.  Device power is provided via the 

network wiring, except for devices that need large amounts of 

power.  Devices may be distributed throughout a building, 

placed conveniently close to the measured or controlled 

device locations.  FGI network devices have self-

identification and addressing features for plug-and-play-like system configuration, and automatically know 

where they connected in the wiring tree, simplifying initial installation, configuration, and future system 

expansion. 

FGI devices supported by the FSD X10-UPB-FGI Bridge Controller include:   

  

FGI Temperature and Humidity Sensors 
  

Temperature sensor devices are available with or without humidity sensing.  Each 

sensor    device also includes one additional input, which may be a switch level 

detector, a switch transition detector, or an analog input for interfacing industry 

standard 4 to 20 milliamp sensors. 

  

FGI Temperature and Humidity Sensors: 

FG-014300 FGI Temperature Sensor, Switch Input 

FG-024300 FGI Temperature Sensor, Transition Input 

FG-004300 FGI Temperature Sensor, 4-20 ma Analog Input 

TBD FGI Temperature Sensor, Over/Under Temperature Alarm 

    

FG-014000-10 FGI Temperature & Humidity Sensor, Switch Input, +/- 3%RH 

FG-024000-10 FGI Temperature & Humidity Sensor, Transition Input, +/- 3%RH 

FG-004000-10 FGI Temperature & Humidity Sensor, 4-20 ma Analog Input, +/- 3%RH 

    

FG-014000-11 FGI Temperature & Humidity Sensor, Switch Input, +/- 2%RH 

FG-024000-11 FGI Temperature & Humidity Sensor, Transition Input, +/- 2%RH 

FG-004000-11 FGI Temperature & Humidity Sensor, 4-20 ma Analog Input, +/- 2%RH 

  

 FGI Quad Input / Quad Output Devices 

  

The Quad I/O devices have four switch inputs, each with level and transition detection, and four 

non-isolated output drivers configured to drive LEDs, external relays or solenoids, or digital 

signal inputs on another device. 



  

  

FGI Quad Input / Quad Output Devices 

FG-032020-06-330 FGI Quad Input / Quad LED Drive Output, 330 Ohms 

FG-032020-00 FGI Quad Input / Quad Relay and Solenoid Driver Output 

FG-032020-01 FGI Quad Input / Quad Dual Latching Relay Driver Output 

FG-032020- FGI Quad Input / Quad Digital Output 

  

  

FGI Octal Input / Quad Relay Output Devices 
  

Relay Output devices have eight switch inputs plus four sets of 

DPDT relay  outputs.  Options include latching versus non-latching 

relays, and RJ-45 or screw terminal FGI network connectors.   

  

FGI Octal Input / Quad Relay Output Devices 

  
FG-032061 FGI Octal Input / Quad Relay Output, Latching 

FG-032060 FGI Octal Input / Quad Relay Output, Non-Latching 

 

 FGI Sixteen Security Sensor Input Devices 

  

Sixteen Security Sensor devices each have inputs for use with 1 

K-ohm loaded switches to detect wiring shorts and opens.  All 

inputs detect current level and open/short status.  Optional 

include transition detection support on zero, four, eight, or 

sixteen inputs.  Available with RJ-45 or screw terminal FGI 

network connectors. 

  

  

FGI Sixteen Security Sensor Input Devices 

 
FG-05600C FGI Sixteen Security Input Sensor, Level Detection Inputs 

FG-056009 FGI Sixteen Security Input Sensor, 4 Transition Inputs 

FG-056008 FGI Sixteen Security Input Sensor, 8 Transition Inputs 

FG-05600D FGI Sixteen Security Input Sensor, 16 Transition Inputs 

 

  

 FGI Nine Port Wiring Hub Device 

  

A nine-way FGI network wiring hub can be used to divide the FGI network into 

nine branches.  Hubs may be daisy chained to provide higher fan-out.  

Additional device power can be injected at the hubs to drive large numbers of 

FGI devices if needed. 

  

  

FGI Nine Port Wiring Hub Devices 



FG-072001-00 FGI Nine Port Standard Hub 

FG-072001-80 FGI Nine Port AC Power Hub 

 

FGI Wiring Method Adapters 
  

Adapters are available to convert the FGI 

network wiring style between RJ-45 Cat-5 

type cabling and 4-wire (two twisted pair) 

screw terminal wiring.  Output side 

converters provide dual RJ-45 connectors for 

a two-way fan-out to downstream devices. 

  

  

FGI Wiring Method Adapters 
FS-1100001 FGI Adapter, RJ-45 to FGI DI Terminals 

FS-1100002 FGI Adapter, Single FGI DO Terminals to RJ-45 

FS-1100003 FGI Adapter, Dual FGI DO Terminals to Dual RJ-45 (bare) 

 

  

  

 FGI Device Wiring Specifications 

  

A) Cable Type: 

  

FGI devices are networked with a 4-wire signal bus and are wired in a branched daisy chain 

arrangement.   Many devices are designed to be interconnected using standard CAT-5 cabling with RJ-

45 connectors, for convenience and commonality with other wiring.  Other devices are designed to 

connect with a 4-wire cable using screw terminals, and some are available with a choice of either 

interconnection option.  Both options use the same signaling on the wires, and can be used together by 

connecting them with a simple wiring adapter. 

  

WARNING: The signals on the FGI CAT-5 cables are NOT compatible with computer networks, and 

should never be connected to a computer network port, a computer data networking hub, or any other 

device not specifically identified as an FGI compatible controller or device. 

  

Many FGI devices use standard CAT-5 cabling to interconnect sensors and control devices throughout 

the building.  FGI devices use standard RJ-45 crimp-on connectors at the cable ends, 8-pin equivalents 

of standard telephone-style RJ-11 connectors, with the cables wired straight-through as is commonly 

used for network cables.  Note that when attaching connectors to the cables on-site the order of 

attaching the wires to the connectors is important, as described below (most standard pre-assembled 

network cables are connected in the proper order, and can be used with FGI devices). 

  

With the CAT-5 cable option, FGI devices use four of the wires for the distributed sensor and control 

networking.  In some FGI device configurations the other two wire pairs are used as additional 

communication or signaling channels or to supply additional power to high power devices, so should 

not be used for unrelated purposes. 

  

For the 4 wire cables to interconnect with screw-terminal equipped FGI devices, most unshielded dual 

twisted pair cables are acceptable options.  The FGI interface design is extremely noise-immune and 

uses moderate data speeds.  

  

B)  RJ-45 Connector Wiring 

  

As per standard RJ-45 Cat 5 connector wiring, T568B wiring:  



  
 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

 

C) Wiring Topology 

The FGI data bus uses a branched daisy-chain low voltage wiring topology.  Each device connects to 

its nearest neighbor in whatever order is convenient.  Two-way branching is supported by most FGI 

devices.  The resulting topology is typically a tree structure, with an arbitrary number of devices daisy-

chained along any branch (up to the maximum depth limit).  At the root of the tree is an FSD 

Controller with an FGI interface.  In larger system installations, often a nine-way branching FGI hub 

device may also be located near the controller, or in a centralized location and connected to the 

controller near the root of the FGI device tree. 

  

Since each FGI sensor or control device needs only to connect to its nearest neighbor, typical 

connecting wires are relatively short and easy to run.  Thus, bulky and complex home-run wiring 

bundles are avoided. 

  

The order and structure of the FGI device interconnections are fairly unimportant and are automatically 

determined by the FSD Controller.  Thus, quantities, types, and placement of FGI devices can be 

selected without extensive concern over the wiring structure.  Additional FGI sensors and control 

devices can be easily added to the system at any time after the initial installation. 

  

Note that many FGI devices, such as FGI temperature sensor devices, have ―extra‖ switch input 

connections available.  Therefore, additional switches may be added to a FSD / FGI system with little 

extra cost beyond the cost of installing the switch itself (i.e. without paying for an additional FGI 

device).  For example, (1) a window or door-mounted magnetic reed switch, motion detector sensor, or 

an under-carpet pressure sensor pad can be connected to a nearby FGI temperature sensor, thus 

providing an extra security and/or occupancy sensor, or (2) an extra standard wall switch can be 

connected to the low voltage switch input to add an inexpensive remote switch for a multi-way control 

of a light.  Taking maximum advantage of these extra ―free‖ inputs increases the rewards of owning an 

FSD / FGI home automation system with very little additional cost. 

  

D) Depth of Modules on a "Tree": 

  

As a rule of thumb, the FGI device wiring tree should be configured so each device does not exceed 

the recommended depth limit of 16 devices from the root of the tree.  This is a conservative estimate; 

longer branches may work fine.  There are two issues involved: 

  

First, the requirement to power most of the FGI devices via the device network cable.  The power 

needed greatly depends on the device types installed.  Certain device types, such as a relay module, use 

substantially more power than others (some devices have the option to be locally powered).  

Depending on particular device types and the configuration, a depth of 32 devices (maximum 

supported by software design) electrically performs without problems. 

  

Second, configure the system in a way to reduce the impact of any failure.  While FGI devices are 

unlikely to fail, a device failure or wiring problem might cause other modules on a branch to be 

unreachable.  In a "bushy" topology with short branches, few modules are affected.  In contrast , a 

slender tree with long branches design might affect more devices. 

Pin # Color 

1 White/Orange 

2 Orange 

3 White/Green 

4 Blue 

5 White/Blue 

6 Green 

7 White/Brown 

8 Brown 



  

E)  Voltage Level Options 

  

FGI devices designed for residential and light commercial applications use 5 volt power and data 

signal levels.  Supply current on the Cat 5 cables is kept below 500 milliamps, and current on the data 

wires is kept below 25 milliamps.  Supply current through screw-terminal cables may be greater, if 

required. 

  

Certain special purpose FGI devices require more power .  The extra power may be supplied using the 

additional wire pairs in the Cat 5 cable.  The maximum secondary voltage used by any FGI device 

supplied via the Cat 5 cable is 24 VAC. 

  

FGI devices designed for industrial and harsh environment applications use 24 volt power and signal 

levels for greater power available to devices and for increased interference immunity.  Most FGI 

devices designed for 24 volt operation have the option to operate at 12 volt.  An industrial version of 

the FSD Controller supports both 24 volt and 12 volt industrial FGI devices. 

  



 

 

FSD Configuration Guides  
Select the FSD Configuration guide below to display its manual.  

 

FSD Guide to Understanding Devices and Elements – an FSD configured system can be comprised 

of a variety of devices. For the FSD Controller to operate the system, the user creates interactions 

between the devices by associating device elements together by way of operations. This guide is an 

introduction to understanding devices, their elements and operations.  

 

FSD Operation Configuration Guide – Operations are used to associate Device Elements with one 

another. This guide explains the different operations possible and how to associate them with device 

elements.  

 

FSD Timers, Etc. Configuration Guide – This guide describes the different timers and virtual devices 

in this device family. The guide describes each timer‘s purpose and how to use them.  

 

FSD Macro Developers Guide – The user can customize the FSD Controller by writing macros to 

program customized behaviors. The guide describes the two types of macros that can be written and 

the different functions available.  

 

FSD Designer Configuration Guide – Describes using FSD Designer to create floor layouts 

resembling the user‘s building. The layouts can be used to place devices and run the system using the 

graphical interface. See the tutorial for FSD Designer for further details.  

 

FSD Logger Configuration Guide – This guide outlines the logging capabilities of the FSD controller 

family. The logger is used to record how the system is operating in order for the user to troubleshoot 

behavior abnormalities and verify that the system operates as configured.  

 

FSD Additional Configuration Topics – Contains miscellaneous tips and topics to consider to 

configure an FSD Controller.  

 

FSD Remote Access Configuration Guide – Discusses how to configure host and remote access 

computers in order to communicate from a remote site to a computer connected to the FSD 

Controller.  

 

FSD Third Party Application Interface Guide – Describes steps for a third party application to 

communicate with the FSD Controller.  

 

FSD Multiple Controller Configuration Guide – Describes steps to configure multiple FSD 

controllers on the same computer.  

 

FSD Controller Troubleshooting Guide – Listed are answers and solutions to frequently asked 

questions. Information is listed to report problems and to contact technical support. 

  



FSD Guide to Understanding Devices and Elements 
  

FSD Controllers are configured by assembling a set of devices and creating interactions between devices.  The 

interactions are created by using operations to connect elements of one device to another.  This guide explains the 

concepts of devices, their elements, operations, and how they are used to configure an FSD Controller automation 

system. 

  

Note: FSD Controller models differ in capabilities.  Device types supported are controller model dependent.. 

  

Device Families: 

  

Devices are grouped as families, generally by the type of communications protocol used by the controller to 

communicate with the device.  FGI devices exchange state data and commands via the FGI hardwired protocol, X10 

devices communicate via the X10 powerline carrier protocol, UPB devices communicate via the UPB powerline 

carrier protocol, Z-Wave devices communicate wirelessly via the Z-Wave RF standard, and so forth. 

  

Please note that the controller communicates with several device families through a special protocol interface 

device.  The interface to/from the controller differs from the family‘s innate communications protocol.  For example, 

the UPB powerline interface module, the INSTEON interface module, and the X10 CM11A interface communicate 

with the controller via RS-232.  These interface controller devices are found within the RS-485/RS-232 device 

family, rather than within the UPB, INSTEON, or X10 family as one might assume.  Similarly, the X10 TW523 and 

X10 PL513 modules communicate through specialized controller hardware, so are found within the Timers, Etc. 

device family.  Z-Wave interface devices are found in either the Timers, Etc. device family or the FGI device 

family, depending on the specific FSD controller used.  FSD Controllers are members of the FGI device family, 

because some FSD Controller types are designed to interconnect and communicate hierarchically via the FGI 

interface. 

  

Three special device families are supported by FSD controllers: the Macro device family, the Timer, Etc. device 

family, and the Variable device family.  These device families comprise software based devices, which 

communicate within the controller internally, without external protocol.  The Timers, Etc. device family also 

includes devices that are software drivers for specialized controller hardware features, such as the Real Time Clock, 

the interface to the X10 TW-523 module, and the direct relay output signals available on certain FSD Controllers. 

  

Macro device types, and how they differ from Direct Macros, are discussed separately in the FSD Macro 

Developer‘s Guide. 

  

Variables hold temporary or constant values used for controlling, configuring, or debugging other devices and their 

interactions with other system devices.  Boolean variables (sometimes called ―Flags‖) hold TRUE-FALSE values.  

Other types of variables can be used to hold more complex values, such as a temperature or humidity threshold 

value. 

  

Timer, Etc. devices include: (1) time oriented devices, such as timeout delay devices, time-of-day triggered devices, 

and fade-rate control devices;  (2) controller-hardware driver devices, as discussed above; and (3) devices that 

interconnect and adopt the behaviors of other families through device configuration options, but are not directly 

associated with any other family.  The last group includes the Button Control and Super Bridge devices.  The Button 

Controls (1) can be configured to send and/or receive device communications directly via selected protocols such as 

X10 or UPB and (2) can invoke Direct Macros triggered either by user interaction or by state changes in other 

devices.  Super Bridge devices can bridge ranges of addresses across protocol families to seamlessly implement 

multi-protocol installations, such as a house with a combination of X10 and UPB devices.  For more details on 

Timer, Etc. devices see the FSD Timers, Etc. Configuration Guide. 

  

Device Types versus Devices: 

  

A ―Device Type‖ specifies the characteristics of a type and possibly model of device, such as an X10 Lamp module.  

All individual devices having the same part number behave identically.   

  

A ―Device‖ is an individual unit of a particular Device Type.  For example, ―Mary‘s Lamp‖ may be an instance of 

an X10 Lamp module and ―Living Room Lamp‖ may be another X10 Lamp Module of the same Device Type 

within the same house.  Each has the same control properties, but may be set to different control states. 

  

Elements: 

  



Individual state values associated with devices are referred to as ―Elements‖.  A device may have a single or 

multiple element state(s).  An example of a single element device is a typical Appliance Module with an On/Off 

state that can be set and possibly read, with no other control information.  A two-element device example is a typical 

Lamp Module, which has an On/Off state and a Dim Level state.  Another two-element device example is an X10 

motion detector device.  It uses one X10 address to signal when motion is detected or a time-out interval passes 

since the last time motion was detected, and uses another X10 address to signal whether the general light level is 

above or below a threshold (intended to be used as a crude Dusk/Dawn indication).  A temperature plus humidity 

sensor is another example of a multiple element device. 

  

Device elements may be used to send state information to a device (e.g. to control a simple Appliance Module), to 

receive state information from a device (e.g. to read a temperature / humidity sensor device), or to send and receive 

states bidirectionally (e.g. to set and verify the On/Off control state of a ―Two-Way‖ X10 Appliance Module).  

These are referred to as ―To‖ elements, ―From‖ elements, and ―To/From‖ elements. 

  

Device elements, that are available for use, are predefined based on the type of device (or in the case of Macro 

Device Types, predefined by the user or system installer).  Individual elements (1) may be enabled and named for 

each individual device, and (2) can be set to initial states upon controller restart. 

  

Element states can typically be viewed, and possibly set, from the device‘s associated Device Dialog display. 

  

Through the use of FSD Logger, the states and state changes of selected individual device elements may be logged 

to a data file for use by another program or for historical analysis.  For details on state logging options see the FSD 

Logger Configuration Guide. 

  

Operations: 

  

States of device elements are interconnected with operations to associate devices with one another.  For example, an 

X10 switch ―From‖ element may be connected to a UPB Appliance Module‘s ―To‖ element, using a ―Set To Value‖ 

operation, to enable the X10 switch to control the UPB Appliance Module.  Available operations and their use are 

discussed further in the FSD Operation Configuration Guide. 

  

Adding, Modifying, Listing, and Viewing Devices: 

  

Devices are added and modified with the FSD Namer utility, accessed by selecting View FSD Namer  

(device family) from the FSD Automator main menu.  If FSD Viewer is active, but FSD Automator is not visible, 

select View-> FSD Automator from the FSD Viewer system menu (accessed by clicking on the icon on the left end 

of FSD Viewer‘s title bar). 

  

When FSD Namer is activated, it displays a list of currently defined devices for the specified device family.  

Depending upon the device family, devices can be added or deleted from the configuration, assigned device names 

and addresses, and individual element options can be set for the device. 

  

Device and Device Type information can be viewed and/or printed by using FSD Lister, activated by selecting View 

 FSD Lister -> (device family) from FSD Automator‘s main menu.  When FSD Lister is initially activated from 

FSD Automator‘s View menu, it shows detailed device information for the selected device family.  Selecting the 

―T‖ or ―D‖ button on the tool bar changes how the active device family‘s device type information is displayed, 

organized by either the device type number or the device type description. 

  

  



FSD Operation Configuration Guide 
  

  

Operations associate Device Elements with each other using selected association properties.  Operations define 

simple behaviors, such as a switch assigned to turn a light on and off.  More complex operations and groups of 

operations establish increased interdependent behaviors.  One could define logical combination of multiple inputs to 

trigger an output device response.  For example, turning on an air conditioner if either the temperature or the 

humidity exceeds their set-point value, but only if doors to the outside are closed. 

  

Assigning Operations: 

  

To add or edit operations affecting a device‘s elements, select Configure Operations from the device‘s Device 

Dialog system menu.  To display the device‘s Device Dialog, click on a linked device icon on a floor or device 

layout within Viewer, or from FSD Automator‘s main menu by selecting Display  <device family> (then select 

device name). 

  

Alternatively, from FSD Automator‘s main menu start FSD Operator directly by selecting Operations <device 

family> (then select device name). 

  

Either method starts FSD Operator, displayed with tabs for each enabled element on the device.  If an element is 

enabled for ―To/From‖ bidirectional usage, a separate tab is shown for each direction. 

  

Note that tabs are shown for enabled elements and for the its enabled direction(s).  If an expected tab is not shown 

for an element known to be available to the corresponding device type, or not shown for an expected ―To/From‖ 

direction, close FSD Operator and start FSD Namer from the FSD Automator View menu.  Choose the device from 

the device family list.  Ensure that the elements are properly enabled.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

For the currently selected tab, FSD Operator displays a list of operation assignments that affect or are affected by the 

element and data direction shown on the tab label.  Note that operation take their input data from ―From‖ elements, 

and apply their output data to ―To‖ elements.  Also note that an operation assignment may be added, viewed, edited, 

and/or deleted from any ―From‖ element or ―To element associated with the operation; for example, one can view a 

switch element to see all the lights it controls, and one can view a light element to see all the switches that control 

the light. 

  

  

To add a new operation assignment, click the ―Add‖ button, then choose the desired operation to add from the 

selection box.  To view or change the settings for an existing operation, double-click on the operation list entry. 

  

  

Operations available depend on the selected element‘s data type, and on the model of FSD Controller in use.  

Possible operations available to choose from include: 

  

    SET_TO_VALUE 

    SET_MOMENTARY_PAIR 

    TOGGLE_VALUE 



    INCREMENT_VALUE  

    DECREMENT_VALUE 

    ADD_OR_SUBTRACT_VALUE 

    COMPARE_VALUE 

    LOGICAL_NOT 

    LOGICAL_AND 

    LOGICAL_OR 

    LOGICAL_NAND 

    LOGICAL_NOR 

    LOGICAL_XOR 

    GATED_SET_TO_VALUE 

    GATED_SET_TO_CONSTANT 

    CONVERT_VALUE 

    SCALE_VALUE 

    PID_CONTROL 

  

Please note that some operations cannot be universally coupled to all elements.  Use toggle, value, and logical 

operations with elements of BOOLEAN data type.  Use increment, decrement, add, subtract, and scale value with 

numeric type elements.  In contrast the set to value operation is an example of an operation that can be used with 

numerous element data types.  A type cast operator is available to convert data types, when needed. 

  

Examples: 

  

As an example, to control an UPB device with an X10 tabletop ―mini-controller‖, connect the  ―Momentary On‖ and 

―Momentary Off‖ elements to the UPB device‘s ―On/Off Setting‖ element using SET_TO_VALUE operations.  The 

―On‖ operation is set to apply its output when TRUE, and the ―Off‖ operation configured with its output inverted 

and applied when FALSE.  

  

A simpler, improved implementation is connecting the ―mini-controller‖ switch ―Momentary On‖ to the UPB 

Devices ―Momentary On‖ with a SET_MOMENTARY_PAIR operation.  This operation implicitly connects the 

―Momentary Off‖ elements of the two devices.  Thus, the control connects with a single operation.  Furthermore, 

controlling the UPB device through its momentary elements sends a UPB command each time the X-10 switch is 

pressed.  In the previous example the UPB command is only sent when the UPB device‘s ―On/Off Setting‖ element 

changes value. 

  

The SET_MOMENTARY_PAIR operation can also connect a non-momentary BOOLEAN state ―From‖ element 

with a pair of momentary ―To‖ elements, when momentary ―From‖ elements are not available.  In this 

configuration, the ―Momentary On‖ ―To‖ element is pulsed whenever the ―From‖ element state transitions to TRUE 

(HIGH), and the ―Momentary Off‖ ―To‖ element is pulsed whenever the ―From‖ element transitions to FALSE 

(LOW). 

  

As a rule-of-thumb, if available, use a momentary-pair to momentary-pair link to interconnect devices.  As a second 

choice, connect a non-momentary ―From‖ element to a momentary ―To‖ element pair.  If there are no momentary 

―To‖ elements, connect the non-momentary state values.  With a simple configuration, the connection options may 

appear to give the same results.  However, as a system grows with multiple ―From‖ devices controlling the ―To‖ 

device, if one uses the momentary connection approach instead, performance and reliability are improved.  

  

This example of operations uses TOGGLE_VALUE.  In this case mechanical rocker switches are wired to digital 

inputs on a single multi-input, low-voltage, hardwired interface device to control a few lights via X10 modules.  If a 

single rocker switch controls a single light, a SET_TO_VALUE operation can link the element wired to the switch 

with the X10 device controlling the lamp; in this case the UP position can always turn the light ON, and the DOWN 

position can always turn the light OFF.  If several switches control the same light, use the TOGGLE_VALUE 

operation to control the X10 device.  Now the light can be controlled by flipping any of the switches to its opposite 

position, regardless of the positions of the other switches assigned to the light. 

  

In another example, a system has (1) two or three rotary encoders connected to low voltage hard-wired rotary 

encoder input devices and (2) push-button shaft switches connected to the extra digital inputs on the rotary encoder 

devices.  Use ADD_OR_SUBTRACT_VALUE operations to link all encoder value change elements to the dimmer 

level element on an X10 or UPB lamp module.  The push button input elements could be connected to the On/Off 

State lamp module element with a TOGGLE_VALUE operation.  With this set-up one can toggle the light on or off 

by pushing the knob on any of the encoders and can control the level of illumination by turning any of the encoders.  

(Continuous encoders with no end stops should be used for this configuration).  Additionally, the ―speed‖ of the 



dimmer knobs can be adjusted by using the SCALE_VALUE operations. 

  

Occasionally, one may want to connect two elements of different data types.  For example, the Fade Timer device 

outputs a USHORT fade value, so it may be used in many applications beyond the presumed light dimmer fade 

application.  A lamp device‘s dimmer element is a UCHAR value, specifying a percent level from 0 to 100.  

Therefore, to use the Fade Timer output level element to control the lamp device dimmer setting, the USHORT 

―From‖ value must be linked to the UCHAR ―To‖ level.  To convert data type connect the elements with a 

CONVERT_VALUE operation. 

  

Configuring Operations: 

  

When adding or editing operations, a configuration dialog box for the selected operation type appears.  Fields 

provide for selecting the ―To‖ and/or ―From‖ device elements to be used by the operation, and additional control 

parameters as appropriate for the operation and element types. 

  

For operations which associate a single ―From‖ element to a ―To‖ element, the configuration dialog allows selecting 

the complement ―To‖ or ―From‖ element.  For example, with a switch device to add an operation to control a light, 

select the tab for the switch ―From‖ element, then press the ―Add‖ button to add a new operation.  After selecting a 

SET_TO_VALUE operation type, in the operation dialog select a ―To‖ element on the light.  Similarly, if one 

configures operations for the light, the operation dialog allows entry of a ―From‖ element from the switch. 

  

For operation types that associate two ―From‖ elements with a single ―To‖ element, such as the binary logical 

operation types, the operation configuration dialog displays two device element selection groups.  If the operation is 

added or edited for a ―To‖ element, the left side element selection group is for the operation‘s ―From‖ element, and  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

if the operation is added or edited for a ―From‖ element, the left side element selection group is for the operation‘s 

―To‖ element, similar to the behavior of the single ―From‖ element operation type dialogs.  In either case, the right 

side element selection group provides for the selection of the other ―From‖ element used by the operation. 

  

Some operations have additional parameters such as a constant which can be set from the operation configuration 

dialog. 

 

Configure each operation to be active under various circumstances:  in all operation modes, in selected operation 

modes, in certain combinations of operation modes, or to disable in all operation modes.  For example, one might 

configure three operations for a motion detector element to turn on a light to full intensity in ―Awake‖ mode, to turn 

on a light to a 30 percent dim level in ―Asleep‖ mode, and to activate the security system in ―Away‖ mode.  For 

more details on defining, setting, and using operation modes, see the discussion of operation modes in the FSD 

Timers, Etc. Configuration Guide. 

  

For BOOLEAN element types, the operation can be configured to invert the ―From‖ element(s) (e.g. true value 

viewed as false, or its converse) before the basic operation is calculated, and/or to invert the ―To‖ results of the 

operation. 

  

There are additional output options to control when the operation calculation result is applied to the associated ―To‖ 



element.  ―Apply Always‖ always applies the result, while ―Apply Never‖ never applies the result.  If ―Apply On 

Input Change‖ is selected, the operation result is applied to the ―To‖ element.  For instance whenever any ―From‖ 

element associated with the operation has a value change the ―To‖ element is conditionally set to the operation 

result.  Similarly, if the ―Apply On Output Change‖ option is selected, the associated ―To‖ element is conditionally 

set to the operation result whenever the operation result differs from the previously calculated result. 

  

For BOOLEAN operation results, an additional condition determining whether the ―To‖ element is set to the 

operation result is whether it matches the ―Apply on Output TRUE‖ or ―Apply on Output FALSE‖ selections.  For 

example, configure an FSD Controller with an Timer type operating mode device and the switch element is 

connected to the Sleep operating mode.  If the condition ―Apply on Output TRUE‖ is met, this allows a ―Sleep‖ 

operation mode element state to be configured to turn all lights OFF at bedtime, without affecting the states of the 

lights when in the ―Awake‖ mode. 

  

Using Variables with Operations: 

  

User-defined Variable devices (BOOLEAN element type variables are sometimes called flags) can simplify 

operation assignments, by consolidating multiple ―From‖ elements to be applied to multiple ―To‖ elements.  For 

example, a house has each upstairs bedroom equipped with a switch that when signaling ―OFF‖ turns OFF all 

downstairs lights, and switching ―ON‖ turns ON lights in the downstairs foyer, hall, and kitchen for a midnight 

snack run.  Assigning individual operations directly between each switch to each affected light is possible, but 

cumbersome.  In a simpler approach each switch is assigned a BOOLEAN variable for ON and another for OFF.  

Then assign these two BOOLEAN variables to operations that control the three lights.  

  

Use the MOMENTARY_PAIR Variable device type as the preferred base type for intermediate devices, thus 

consolidating elements for devices having momentary element On/Off pairs.  If desired, a single non-paired 

BOOLEAN element can also be configured as a momentary element (configured from FSD Namer). 

  

Use Variable devices to link multiple operations between other device elements.  For example, to turn on a light if 

either state A or state B is TRUE, while state C is also TRUE, a logical OR operation can be used to combine A and 

B, followed by a logical AND operation to combine the result of the first operation with C.  However, operations 

connect elements to elements, not elements to operations, so an element is needed to hold the result of the A and B 

operation.  A variable with a ―To/From‖ BOOLEAN element can be defined and used to hold the intermediate 

result.  Note that the result of this intermediate operation can be viewed and changed from the user interface by 

displaying the variable‘s device dialog. 

  

  



 FSD Timers, Etc. Configuration Guide 
  

Guide to Configuring FSD Timers and other Virtual Devices 

  

FSD Timers, Etc. Overview 
  

The Timers, Etc. device family is a collection of devices implemented as firmware, and in some cases specialized 

hardware in the FSD Controller.   The Timers, Etc. family provides a variety of electronic timers for time based 

control of connected devices:  There are two timer categories:  Elapsed Time Timers, and Time-of-Day Timers.  

Also in the Timers, Etc. family are other virtual devices used to control devices.   

  

Elapsed Time Timers include:  Retriggerable Timer, Alarm Timer, Fade Timer.   

Time-of-Day Timers include: Real Time Clock, Time of Day Event, Holiday Schedule, Alarm Clock.   

Other Timers, Etc. devices include: Operating Mode, 8-Button Control, 16-Button Control, Super Bridge, X10 

Interface (TW523), and Z-Wave Interface. 

  

The timer devices available are FSD Controller model dependent.  Most controller models are equipped with all 

Elapsed Time Timers.  The Time-of-Day timers are available on all controller models, except the Bridge controllers, 

which do not support Real-Time Clock hardware.  Installation of the other timers depends on the function of a 

particular controller model.  For example, (1) Super Bridge devices are available on controller models supporting 

two or more HA protocols; (2) the X10 Interface device is only installed on controller models supporting X10, and 

(3) the Z-Wave Interface device is only installed on controller models that include internal Z-Wave support. 

  

Timers are implemented by FSD controller firmware, so timers operate independently from and do not depend on 

software attached to the host computer.  Similar to other devices, Timer, Etc. devices have ―To‖, ―From‖, and 

―To/From‖ elements, which can interconnect with other devices to control and/or be controlled by external events.  

Timers, Etc. devices have user interface device dialogs, so the user can interact with timer operation, when the host 

computer is connected. 

  

Elapsed Time Timers 
  

Retriggerable Timer 
  

This timer type allows the user to program a triggerable event.  This event starts a specified time after the trigger, is 

active for a specified time, and inactive for a specified time.  A input to this timer can be connected to trigger an 

action programmed by this timer.   

  

Configurable options on the Retriggerable Timer includes Blink mode, retriggerability, and setting time 

accumulation from repeated trigger events. 

  

To view the operation of this timer, the timer device dialog shows the state of the Timer output, the time remaining 

for the specific state (delay, on, or 

refractory period), and the states of the 

Trigger Input, Trigger Enable (both can 

be set by clicking its button) and the 

Pause Time elements.  With the Trigger 

Enable in the TRUE state, the user can 

click on the Trigger Input when 

displayed FALSE to trigger an event. 

  

  

Alarm Timer 
  

This device uses an alarm to notify when an alarm 

event occurs.  The user can configure an initial 

delay before activation and stagger alarm responses 

by specifying when the first, second and third alarm 

alert outputs occur.  

  

The user can also configure the alarm device to send 

a notification message to the host computer, when 



an alarm is triggered.  See the section on ―Using Alarm Notifications‖ below for additional details on using 

Notification Messages. 

  

On the alarm timer, the user can configure: the delay of the trigger, the duration of the alarm, the delay time between 

the first and second alarm alert, and the delay between the second and third alarm. 

  

The Alarm Timer device dialog display shows the current alarm state if the appropriate box is checked.  Buttons are 

available to trigger the alarm, enable the alarm, or deactivate the alarm.  Deactivating the alarm can be password 

protected. 

  

Fade Timer 

  

A Fade Timer controls a device so it can be turned on or off in a gradual fashion.  If desired a holding level can be 

programmed before the end fade level is reached.   

  

Typical use is to implement slow bright / dim fade behavior for a light dimmer switch or module, if the device does 

not support internal fade time control.   The Fade Timer can also implement a gradual change in any other analog 

control value, for example slowly raising the temperature of a building heated by a heat pump to a target 

temperature to avoid using the emergency heat function (uses more electricity). 

  

When triggered the fade timer device 

controls the change in power level for the 

device from a start percentage level (0—

100%), to a hold level, to an end fade level.  

Each of these levels has a specific time 

period assigned.  
  

The Fade Timer dialog displays the state of 

the fade timer, the different settings, buttons 

to enable the trigger, set the trigger state, and 

turn the pause time on or off. 

  

  

Time-of-Day Timers 
  

Real Time Clock 

  

The Real Time Clock timer device is an 

interface to the controller‘s real time clock.  

It allows other devices on the system to 

control or be controller by time states using 

operation connections with the device‘s 

―To‖ and ―From‖ elements.   

  

The Real Time Clock timer device dialog 

displays the current time setting for the FSD 

Controller.  Clicking on the ―Set‖ button 

displays a dialog box to set the date and time for the controller.  (Note that an alternative method for automatically 

keeping the controller‘s time set correctly is to enable FSD Router as the time master.  From the FSD Automator 

main menu, select Option -> Configure Router Options (also see FSD Router manual), and set the checkbox for 

―Time Synch Source‖, which periodically synchronizes the FSD Controller Date/Time setting with the computer‘s 

date/clock values.) 

  

The dialog also displays the element states for the different dawn/dusk states (discussed in a following section) and 

the ―To‖ element (Input) states for Time Set, Hour, and Minute.  These cannot be changed directly from the device 

dialog interface, since the dawn/dusk states are derived from the current time settings.  In addition,  the ―Set‖ button 

provides a more convenient method of setting the time from a GUI interface than the button-oriented time setting 

elements. 

  

Time of Day Event 
  



The Time of Day Event timer generates time-of-day based ―From‖ element states, which can be connected via 

operations to devices to trigger actions at predefined times.  For example, program the event timer  to turn the porch 

light ON from dusk until 11:00 PM every night.  

  

One can configure the Time of Day Event timer for events to occur at specified start and stop times, or to occur 

randomly for a specified range of minutes and turned off for a specified range of minutes during a specified time 

period set. 

  

The event can be configured to occur on 

specified days of the week, optionally 

only on specified days of the year 

designated as a ―Holiday‖, ―Special Day 

1‖, ―Special Day 2‖, or ―Special Day 3‖.  

(See following section on ―Holiday 

Schedule‖.) 

  

By using Operating Modes, the user can 

make the event timer active depending 

on specified Operating Mode conditions.  

For example, randomized control of the living room light would probably only be enabled for an ―Away‖ mode, and 

inactive in ―At Home‖ mode.  For further discussion of Operating Mode options, see the section ―Using Operating 

Modes‖ below. 

  

The Time of Day Event timer device dialog shows the user whether the current event state is True or False (on or 

off), whether the event is enabled today, and whether the event is enabled in the current operating mode.  Event 

times can be configured through the ―Configure Event Timer‖ in the Event Timer‘s device dialog‘s system menu.   

  

Alarm Clock  
  

The Alarm Clock timer mimics a traditional alarm clock, but with additional features.  One can configure an Alarm 

Clock timer device to activate an 

alarm for a specific clock time or time 

relative to specific sunrise or sunset 

event, for specified days of the week, 

or be conditionally dependent on 

whether the day has been designated 

as a ―Holiday‖, ―Special Day 1‖, 

―Special Day 2‖, or ―Special Day 3‖.  

The alarm clock device can control 

three separately timed actions, 

connected by operations to the alarm 

clock device‘s ―From‖ elements, with 

the second and third alarm times 

relative to the first and second alarm 

clock output.   

  

―Hitting‖ the snooze button (―To‖ element) inactivates the alarm state for a specified period, then reactivates the 

alarm, as would the ―Snooze‖ button on a traditional alarm clock.  The ―Deactivate‖ element turns off the alarm 

clock at least for the day (optionally the alarm clock can be set to reactivate during the day).   

  

The Alarm Clock device dialog display shows the current alarm clock trigger state and alarm output states.  Buttons 

are available to trigger the alarm, 

enable the alarm, start a snooze 

period, or deactivate the alarm. 

  

Holiday Schedule 

  

The Holiday Schedule timer 

device controls date designations, 

and controls other devices based 

on date designations.  The device 

uses values connected by 



operations linked to its device elements.  The Holiday Schedule device dialog box allows the user to designate 

scheduled dates.  More than one Holiday Schedule devices can be configured into a system (for example separate 

calendars for Holidays and each category of Special Days).  
  

Some timer device family members can be configured to be active or disabled on dates designated as a Holiday, 

Special Day 1, Special Day 2, or Special Day 3.  For these devices, the connection to the date designations is 

internal and automatic, and no explicit element operations are needed.  Other devices can be controlled by date by 

linking them to the Holiday Schedule device elements, and if desired, a device can set a holiday or special state; for 

example, an X10 switch can activate Holiday mode operation for the day, without editing the calendar schedule. 

  

To set a date to be a holiday or special event, click the ―Insert‖ button on a Holiday Schedule device dialog.  An Edit 

Holiday dialog box appears.  Set the start and stop date for the time period, ensure that the Enable Date checkbox is 

selected, enter a name for the event, and select the check boxes if this event is annual and designated Holiday, 

Special Day 1, Special Day 2, and/or Special Day 3.  Other options are whether one wants to cancel all scheduled 

events for the specified time period, or to disable all alarm clocks on those days.  Click ―OK‖ and the entered event 

is displayed in the list box.  Double clicking on a listed event allows editing.  To delete, select an event in the list 

box and click the ―Delete‖. 

  

To quickly assign today‘s date as a special event click the ―Today is Special‖ button.  Note: after today‘s date is 

assigned as a special date and enabled, the button changes to ―Today is NOT Special‖.  Clicking this button displays 

the event assigned with the ―Today is Special‖ button. 

  

To assign tomorrow‘s date as a special event click the ―Tomorrow is Special‖ button. 

  

Non-Time Based Timers, Etc. Devices 
  

8 Button Control 

16 Button Control 
  

When 8-Button or 16– Button Control devices are installed, it is possible for 

other devices on the FSD Controller to send arbitrary X10, UPB, or other 

protocol commands.  One simply sets a device element state via a normal 

operation, such as SET_TO_VALUE.  For example, a Button Control device 

could be configured to send X10 extended commands to set ―Scenes‖ when 

receiving inputs from a hardwired switch or a low cost X10 switch console.  

The ―Buttons‖ on the button control devices can be configured to invoke 

direct macros after receiving  ―To‖ element values.   

  

Buttons can be individually configured to operate as momentary, push-ON 

push-OFF , or as button pairs when one button sets an ON state, and the other 

sets an OFF state.  ON and OFF responses can also be independently 

configured. 

  

Both button control device types are identical, except for the 

maximum number of buttons controlled.   

  

The Button Control device dialog can be configured as an 8 

button user interface on a connected computer.  16 button 

control user interfaces also include a selector to switch between 

button ranges.  Buttons may be labeled as desired, and disabled 

if not in use.  This allows direct user 

operation of the 8 or 16 buttons functions; 

for example, it could be configured as a 

―Scene‖ controller from the desktop, or as a 

console for triggering user defined macros. 

  

Super Bridge 

  

A Super Bridge device can bridge 

commands from one device family to a 

different device family.  Groups of device 



addresses can be bridged with minimal configuration effort.  Thus, a variety of devices, each using different 

communication protocols, can communicate with one another.  The FSD Controller translates the commands from 

one device family to another device family.  Conceptually, view a Super Bridge device as a group of four X10, 

UPB, and/or hardwired four address switch devices glued together with a 16-Button Control device.  16 operations 

bridge their ―From‖ and ―To‖ elements.  Additionally, the Super Bridge can also bridge fade levels for dimmers.  

For example , an existing X10 based system can be upgraded by installing UPB devices.  The X10 and UPB devices 

can control each other through Super Bridge devices. 

  

Use operations to connect the input and output sides of the bridge with their complement ―To‖ and ―From‖ elements 

on devices.  To view the interactions, use FSD Logger to log a report to the PC host. 

  

The Super Bridge device dialogs display switches that can control and indicate the state of each switc h.  In addition 

there are slider controls to control bridged devices with dimmer capabilities. 

  

To configure a Super Bridge device, select ―Configure Device‖ from its device dialog, or from FSD Automator, use 

the Configure  —> Timers, Etc. menu and choose an instance of Super Bridge (previously created using View —> 

FSD Namer —> Timers, Etc.).  The Configure Super Bridge dialog displays a list box displaying address groups 

within Bridge Group Configuration.  Double-clicking on an address group line in the list box displays the Edit 

Bridge Group dialog box to edit bridge behavior for a block of four sequential input and output addresses.  
  

For each section use the drop lists to choose the device family, X10 variation if applicable, and device family 

controller (on FSD Controller models supporting more than one).  Depending on the device family, enter other 

appropriate information required for the device family in the displayed drop lists and radio button selections.  In the 

Input Settings section, choose the device family and address information for the devices that send signals to the FSD 

Controller.  For X10 devices that use extended 

command, also enter the protocol variation to use 

based on the X10 device models.  For devices to 

receive the bridged signals from the FSD Controller, 

enter configuration data in the Output Settings 

section.  For each section the first address entered is 

the base address.  The next three devices use the next 

three addresses in sequence.   

  

For subsequent address groups in the Bridge Group 

Configuration, double click on the address group 

entry in the list box.  If the same device families 

from the previous line are used for input and output 

to the controller with consecutive addresses used, 

select the Inherit Settings checkbox.  If the output 

device group has dimmer capabilities, check the 

―Enable Dimmer Operation‖ checkbox to enable 

bridging dimmer values through the Super Bridge.   

  

  

  

Operating Mode  
  

The Operating Mode device type enables devices 

to interact with the FSD Controller‘s Operating 

Mode state.  Thus, a device can change the current 

Operating Mode state by connecting a device 

element with an operation by way of an Operating 

Mode device.  For example, one can configure a 

bedside X10 switch to place a house into an 

―Asleep‖ (operating) mode.  Direct control of 

device states can be accomplished by changing 

operating modes using the operation connections 

on the devices elements. 

  

An Operating Mode device dialog displays the currently enabled operating modes assigned to the different operation 

mode groups.  The current operating mode is changed using the Operating Mode device dialog.  

  



All operations, and some Timers, Etc. devices can be enabled depending on the current operating mode state.  This 

is one approach to configure complex conditional system behaviors.  See the section ―Using Operating Modes‖ 

below for a further discussion of operating modes and operating mode groups. 

  

  

X10 Interface (TW523) 

  

The X10 Interface (TW523) device type implements an X10 

protocol controller device.  This device communicates with X10 

family devices via an X10 power line interface module (TW523, 

PSC05, or PL513) connected to the FSD Controller‘s X10 OUT 

port.  In Compact Bridges and Bridge Controllers supporting X10, 

the X10 Interface (TW523) device also supports communications 

with a legacy X10 controller by emulating a TW523 or PL513 device on the X10 IN port.  

  

The X10 Interface (TW523) device type is in the Timers, Etc. family because it connects to specialized TW523 

interfacing circuitry in the FSD Controller  and does not communicate with the power line interface module of the 

primary interface protocol families.  In contrast, the X10 Interface (CM11A) device type, if supported by the FSD 

Controller model, is a member of the RS232/485 device family, since it communicates with the FSD Controller via 

an RS-232 port.  Only one TW523 X10 Interface device is supported per FSD Controller. 

  

The type of power line interface module used should be set with the device dialog‘s Configure Device option dialog, 

and /or the type of interface module emulation to be supported on the X10 IN port, if applicable.  The X10 OUT 

power line interface module selection and X10 IN emulation port selection need not match.  Additional 

configuration options include enabling automatically repeating X10 commands if controller-implemented 

redundancy is desired. 

  

Note that the two-way power line interface models TW523, PSC05, and compatible variations from other 

manufacturers are all equivalent from the perspective of the X10 Interface protocol controller device.  The TW523 

modules can receive X10 commands from other X10 devices, but cannot receive X10 Extended commands; 

nonetheless a TW523 or similar interface is generally recommended for use with an FSD Controller or Bridge. The 

PL513 is a lower cost, transmit only device, which cannot receive X10 commands from other devices.  The CM11A 

interface can receive X10 Extended commands, but has performance limitations that make it unsuitable for many 

controller applications beyond X10 protocol packet logging. 

Timers, Etc. Device Family Related Topics 
  

Using Dawn/Dusk Relative Times 

  

FSD Controllers, with real time clock capability, can control devices based on time relative to dusk or dawn.   

  

Dusk and dawn times depend on geographic location, so before using dusk/dawn relative times define the controller 

location.  Set location from the FSD Automator main menu Options —> Set Location and Time.  Use the Set 

Location and Time Display dialog to input location and time information for dawn and dusk calculations.  In the 

USA, set the location by either selecting a nearby city on the drop lists or selecting a zip code.  Alternatively, enter 

the location‘s latitude and longitude.  Verify or set the time zone, and choose whether or not to enable Daylight 

Savings Time. 

  

Several dawn and dusk time definitions are available as timer trigger reference times: 

  

Dawn Definitions 

 Sun Rise – when the sun is halfway above the horizon. 

 Civil Dawn – when there is sufficient sunlight to be able to read print. 

 Nautical Dawn – when the sky is too bright to use the major stars to navigate. 

 Astronomical Dawn – when the sky no longer is the darkest. 

  

Dusk Definitions 

 Sun Set – when the sun is halfway below the horizon. 

 Civil Dusk – when there is insufficient sunlight to be able to read print. 

 Nautical Dusk – when one can use the major stars for celestial navigation. 



 Astronomical Dusk – when the sky becomes its darkest. 

  

The Real Time Clock device provides ―From‖ elements indicating the current dusk/dawn states, which can be 

connected via operations to ―To‖ elements in other devices.  Also, on the Real Time Clock device dialog, 

checkboxes labeled Sun Rise, Civil Dawn, Nautical Dawn, and Astronomical Dawn indicate the current dusk dawn 

state: 

  

 as a check is displayed in the checkbox, the particular dawn definition has been reached. 

 as a check is removed from the checkbox, the complementary dusk definition has been reached. 

  

Time-of-Day Event Timer devices can start or end events based on times relative to the dawn or dusk times.  

Relative time offsets are relative to midnight (12:00 AM).  There is no offset of the time event at midnight.  To set a 

trigger time for a few minutes before the selected Dawn /Dusk time, set the time to 11:?? PM.  Similarly, to set a 

trigger time for a few minutes after the selected Dawn / Dusk time, set the time to 12:?? AM.  

  

For example, in the time of day event‘s Configure 

Event dialog on the right, the reference start time 

of Civil Dawn and the reference stop time of Sun 

Set are modified with relative time offsets.  The 

―Relative‖ buttons to the right of the Start and 

Stop times are set enabling relative time 

offsetting.  The start time is set to trigger 15 

minutes after Civil Dawn, with the relative time 

set as 12:15 AM.  The stop time is set to 15 minute before Sun Set, with the relative time set as 11:45 PM. 

  

  

  

Using Operating Modes 
  

Use Operating Modes to configure the FSD Controller based automation system.  Depending on the Operating 

Modes set, the controller receives different input and it changes the controlled device‘s behavior.  For example, the 

user can configure a motion sensor in the house to trigger different responses depending on whether the automation 

system expects the house to be occupied.  In ―Away‖ and ―On Vacation‖ operating modes, the house is unoccupied.  

When motion is sensed, it triggers the alarm and notifies the security service.  In ―At Home—awake‖ mode, the 

system might be configured to turn a light on when motion is detected after dusk.  Additionally, if the system is also 

in ―At home—asleep‖ mode, when motion is detected, 

the lights are turned on using fade timing, slowly 

bringing the lights to a low intensity level. 

  

Using Operating Mode Groups provides another level of 

configuration control.  An Operating Mode Group 

combines a selected number of operating modes.  Thus, 

an Operating Mode Group provides a convenient way to 

configure the FSD Controller.   In this way various 

devices can automatically adapt to changes in 

circumstances prescribed in the Operating Mode group.  

For example, one might want the system to act differently 

depending on whether school is in session. 

  

Operating Modes and Operating Mode Groups are 

defined and enabled using FSD Namer.  From the FSD 

Automator main menu, select View —> FSD Namer —> 

Operating Mode to display a dialog for editing Operating 

Mode Groups and Operating Modes.  Double-clicking on 

an Operating Mode or Operating Mode Group entry 

allows the user to assign a name and set enabling.  For 

Operating Modes, group membership can be assigned.  

For Operating Mode Groups, the user assigns a style.  

The ―Radio Button‖ style acts like old-fashioned radio 

buttons where selecting any mode in the group desel ects 

all others in the same group (mutually exclusive); the ―Independent‖ style allows the modes in the group to be set or 

cleared independently; ―All TRUE‖ assigns all modes in the group as true; and ―All FALSE‖ assigns all modes in 



the group as false. 

  

Operating Mode default setting and controller reboot 

condition are set in the Configure Device dialog for the 

FSD Controller. 

  

The current operating mode(s) can be set from another 

device such as a switch input device. An Operating Mode 

device must be defined within FSD Namer, in the 

Timers, Etc. family.  A ―From‖ element from the source 

device can then be linked to the desired Operating Mode ―To‖ element via a configured operation. 

  

To view or set the current operating mode from the operator 

interface, view the device dialog for a defined Operating 

Mode device.  Alternatively, from FSD Automator, under the 

Options menu choose ―Set Operating Modes‖.  This displays 

the operating modes that are enabled and to which group 

each belongs.  Note that the dialogs for these two methods 

look similar, but behave differently.  Double-clicking on an 

operating mode on the list activates the operating mode.  

Under the enabled column the operating mode will be 

marked with an ―R‖, ―I‖, ―T‖, or ―F‖, which indicates the 

operating mode group‘s style (Radio button, Independent, all 

TRUE, or all FALSE, respectively).  When using the device 

dialog, the mode(s) are set immediately, and the box dialog remains open to view changes from other sources such 

as a linked switch.  When using ―Set Operating Modes‖ the display is static and changes take effect only after the 

dialog is closed. 

  

All operation types linking device elements, such as SET_TO_VALUE, can be conditionally enabled based on the 

current operating mode(s) set.  Certain timer device types, including the Alarm, Alarm Clock, and Time-of-Day 

Event types, can also be conditionally enabled, dependent on current operating mode(s).  Examples include:  

configuring (1) an Alarm device to be enabled only in the ―Away‖ and ―On Vacation‖ modes or (2) an Alarm Clock 

to be enabled only in the ―At home—asleep‖ mode and with school in session. 

  

To configure the Operating Mode options for an operation, edit the operation properties by selecting ―Configure 

Operations‖ from either the ―From‖ or the ―To‖ device, select the corresponding element tab, and select the 

operation from the displayed list.  To configure the Operating Mode options for a Timers, Etc. device, select 

―Configure Device‖ from its device dialog‘s system menu.  In either configuration dialog, there will be a group of 

controls such as the partial dialog box shown nearby, with the particular listed options derived from the enabled 

operating modes and operating mode groups previously defined within FSD Namer. 

  

Select the ―All Modes‖ radio button to enable the 

operation or timer in all operating modes.  Select 

―Any Mode‖ to enable any number of operating 

modes checked as enabled.  Select ―Multi-Mode‖ 

when a combination of operating modes, modes 

selected from different operating mode groups, 

defines the controller‘s actions.  For example in the 

dialog above, one can choose ―At home—asleep‖ 

from group 1 and ―School‘s in Session‖ from 

group 2 to determine the timing of lights that go on 

and starting of the coffee maker in the morning 

consistent with school in session.  Select ―None 

(Disabled)‖ to disable the operation or timer 

device at all times.  
  

If ―Any Mode‖ or ―Multi-Mode‖ is selected, click 

on operating modes listed to the right to select 

operating modes for which the operation or timer 

device is enabled.  An ‗X‘ in the ―En‖ column 

indicates the operating mode is selected.  The 

―Grp‖ column shows the operating mode group 



number for the listed operation. 

  

Using Alarm Notifications 
  

Notifications initiate an action on the host computer or a connected remote computer, in response to an event or 

condition detected by the FSD controller.  For example, a 

message could be displayed on the computer screen if a 

security sensor is activated or if a monitored control system 

parameter exceeds a limit value. 

  

To use alarm notifications, set the following when configuring 

an alarm timer: enable the notification trigger checkbox, enter 

a notification code, and enter notification text.  The alarm is 

triggerable.   

  

Notifications from Alarm Devices are supported by FSD 

Automator and the Alarm device dialog.  If the associated 

Alarm device dialog is active, the notification packet is sent to 

the dialog.  If the dialog is inactive, the dialog is started 

automatically from Automator to process the notification.  

(Note: Automator must be active for the packet to be handled 

in this fashion). 

  

The Alarm device dialog handles the notification in 

accordance to the options selected in the ―Configure Notify‖ 

dialog (accessed from the Alarm Timer device dialog‘s system 

menu).  A message window may be displayed for viewing, 

and/or a user-specified notification handler application can be started to take further action. 

  

Alternatively, alarm Device notifications can alternatively be processed by a user-developed or third party provided 

custom notification service.  This FSD Router client application is developed by following the guidelines provided 

in the FSD Third Party Application Interface documentation. 

  

This notification handling functions similarly to the macro notification provided by Macro Devices, which is based 

on user-defined Macro Device Types. 

  

  

  

Generic Timers, Etc. Device Set-Up Procedure 
  

1. To generate an instance of an FSD Timers, Etc. device, in FSD Automator from the main menu select View ->Fsd 

Namer->Timers, Etc.   

2. A ―Timer List‖ dialog box appears.  Click the ―Insert‖ button.  The ―Edit Timer‖ dialog box is displayed.  Select a 

timer type from the Timer Type drop list.  Click ―OK‖. 

3. From the Display menu in FSD Automator, choose the ―Timers, etc.‖ selection.  In the dialog box displayed, 

choose the Device Type and the Device Name of the timer just created from their respective drop lists.  The 

current state of the timer is displayed.  Each timer type may have a slightly different display list and pattern.   

4. Display the system menu of the displayed device dialog by clicking on the icon on the left end of the title bar, or 

by right-clicking anywhere on the title bar, shows a menu allowing the user to: 

 Configure Display -- user can change icon displayed on this dialog box. 

 Configure Event Times -- user programs the timer from this dialog box. 

 Configure Device -- user programs Input and Output Settings for device. 



 Configure Operations -- user connects to the 

device controlled by this timer.    

5. Select Configure Operations to show an Operation 

dialog.  One can define operations linking the 

elements of the device to elements of other devices, 

as discussed in the ―FSD Operation Configuration 

Guide‖. 

 Choose the element type from the tabbed indices,   

 Click on the ―Add‖ button, select the type of 

operation from the drop list in the Operation 

dialog box,  

 In the Device Element Operation dialog, choose 

the Device Family, Device Type, Device 

Name, and Device Element for the device to 

link to the timer device element.  NOTE: The 

appearance of the Device Element Operation 

box, and options available within the box, 

depends on the operation selected.  ALSO 

NOTE:  the other device(s) to be linked must 

already be defined through FSD Namer.   

 Set other variables as desired. 

 Click ―OK‖. 

 

6. Either click the ―Load‖ button on the tabbed element 

Operation dialog box or select ―Load 

Configuration‖ on the File menu in FSD 

Automator to load the configuration to the 

controller. 

  

Refer to the manual on a specific Timers, Etc. device type for detailed configuration and operating instructions. 

  

  

  



FSD Macro Developer’s Guide 
  

Direct Macros vs Macro Device Types 

  

The FSD Controller family and the FSD Creator macro design utility provide two approaches to implement high 

capability custom macros.  Direct Macros are single-instance macros that link directly to device elements.  It 

provides a relatively simple approach to generate customized control sequences.  Macro Device Types are custom 

designed virtual device types.  Use FSD Namer to add multiple macro devices as instances of the macro device type.   

  

Macro Devices, based on Macro Device Types can be displayed as Device Dialogs.  Element values can be 

monitored and modified from the screen display, and the macro device elements can be interconnected with other 

device elements by way of operations.  Use Configure Operations similarly to nonvirtual devices.  Macro Device 

Types provide an elegant means to implement multiple instances of a custom behavior, and are well suited to export 

into a shareable macro library and import into other controllers. 

  

Creating Direct Macros and Macro Device Types  
  

To create a new macro, select View  FSD Creator from the FSD Automator main menu.  In FSD Creator, select 

whether to work with Direct Macros or 

Macro Device Types, then press the 

Insert button (Fig. 1).  In the macro 

editing dialog (Fig. 2), enter a name for 

the macro.  The macro can be left 

disabled until finished and ready to test.  

If Autostart is checked, the Direct 

Macro or all FSD Namer defined macro 

devices, based on the Macro Device 

Type, start automatically on controller 

restart.  Otherwise, the macro runs when 

explicitly invoked or in response to a 

Start Trigger event. 

  

Proceed to fill the body of the macro 

with macro items by selecting Insert 

from the macro editing dialog.  If no 

item is selected, new items are inserted at the end of the list.  If an item is selected, new items are inserted prior to 

the selected item.  Deselect items by clicking in the area at the end of the displayed list.  Reorder item sequence by 

selecting an item and moving it up or down in the list with the buttons provided below.  Double click an item to edit 

it. 

  

Macro Items 

  

When inserting or editing macro items, a dialog 

box is displayed to select a function to be 

performed by the macro item, to enable or disable 

the individual item, and to enter a comment.  The 

comment is displayed in the macro listing to 

enhance maintainability of the macro.  Depending 

on the type of macro function, different fields are 

displayed.  Figure 3 shows an example of a macro 

edit box, in this case for X10 function. 

  

 

 

 

Macro functions available depends on the FSD 

Controller model and may include: 

  

    COMMENT 

    LABEL 

    ELEMENT 

    REGISTER 



    PAUSE 

    SUSPEND 

    MOVE 

    COMPLEMENT 

    AND 

    OR 

    NAND 

    NOR 

    XOR 

    ADD 

    SUBTRACT 

    MULTIPLY 

    DIVIDE 

    COMPARE 

    JUMP 

    FADE 

    EXECUTE 

    NOTIFY 

    DEBUG 

    WARNING 

    ERROR 

  

    X10_COMMAND 

    ZWAVE_COMMAND 

    UPB_COMMAND 

    RS485_COMMAND 

    INSTEON_COMMAND 

  

This rich set of macro functions allows easy implementation of both simple and relatively complex macros.  Macros 

can be functionally similar to small programs and written with variables, conditional jumps, subroutines, and 

message communication with the host computer. 

  

Comments and Label Commands 

  

    COMMENT 

    LABEL 

  

Use comments to add documentation to the left column of the macro listing.  All items allow adding comments to 

the right column of the listing. 

  

Labels mark positions in the macro so that jumps and triggers know where to transfer execution control.  Labels are 

not case sensitive. 

  

Two special labels, ―START‖ and ―FINISH‖, are target addresses for the Start Trigger and Finish Trigger elements 

(discussed below).  If not defined within the macro item list, ―START‖ defaults to the first macro item, and 

―FINISH‖ defaults to the end of the macro after the last listed macro item. 

  

Element Commands 

  

    ELEMENT 

  

ELEMENT macro items are local element reference names that associate to device element specifications.  

Elements are implemented differently within Direct Macros and Macro Device Types; this distinction is the primary 

difference between the two macro definition categories. 

  

Within a Direct Macro definition, the ELEMENT item is associated with a previously defined device element on 

another device; for example, it may be set to the ―On/Off State‖ element of an X10 Lamp Module device.   

  

Within a Macro Device Type definition, the ELEMENT command is an element for any Macro Device created by 

FSD Namer and has its base type defined as a Macro Device Type (except for Map type element definitions).  This 

defined element can link the Macro Device with other devices using operations, such as SET_TO_VALUE.   

  



Elements designated as Start Trigger, Finish Trigger, and Resume Trigger have pre-defined behaviors.  The Start 

Trigger begins execution at the ―START‖ label position, or at the beginning of the macro if the start position is not 

labeled.  The Finish Trigger jumps the execution to the ―FINISH‖ label position, or to end the macro execution if the 

finish position is not labeled.  The Resume Trigger resumes macro execution if previously suspended by a PAUSE 

or SUSPEND command. 

  

For Direct Macros, the Trigger elements are BOOLEAN edge triggered inputs.  The macro is triggered by 

transitions to TRUE, or FALSE if the input is set as inverted. 

  

For Macro Device Types, the Trigger elements are momentary BOOLEAN ―To‖ data elements for macro devices 

based on the type definition.  These Trigger elements can be linked to other devices through operations, and viewed 

and set at run time from the Macro Device Dialogs, available in the user interface. 

  

Map elements are named substitutes for device element specifications.  If there are several references to the same 

device element, using a map element can simplify macro construction, increase readability of the macro definition, 

and aids redirecting the macro to a different device. 

  

I/O elements (for Macro Device Types only) are the ―To‖, ―From‖, and ―To/From‖ data elements for macro devices, 

based on the type definition.  Macro device I/O elements are linked to other devices through operations, and viewed 

and set at run time from the Macro Device Dialogs, available in the user interface. 

  

Register Commands 

  

    REGISTER 

Registers are named variables that may be used to store macro data values temporarily and may be used to 

communicate values between macros and between invocations of a macro.  All registers are implemented as static 

variables.   

  

Local Registers are named values that can be used (1) within a direct macro or (2) within a single macro device 

derived from a macro device type.  If different macros use a local register of the same name or if different macro 

device instances are created from the same macro device type, then different memory for the local registers are used. 

  

Global registers are named values that are shared among all direct macros and macro devices.  They can refer to a 

global register by using the same name.  A common memory location stores the data associated with the global 

register name, so all macros see the same value. 

  

Execution Suspension Commands 

  

    PAUSE 

    SUSPEND 

  

The PAUSE command suspends execution of the macro until a specified length of time elapses or a Resume Trigger 

event occurs.  The paused macro execution then resumes.   

  

The SUSPEND command stops execution of the macro until a Resume Trigger event occurs and the macro 

execution proceeds. 

  

Data Manipulation Commands 

  

    MOVE 

    COMPLEMENT 

    AND 

    OR 

    NAND 

    NOR 

    XOR 

    ADD 

    SUBTRACT 

    MULTIPLY 

    DIVIDE 

    COMPARE 

  



Data manipulation commands perform logical and mathematic operations on pairs of values.  The single input 

commands take a value from the first specified location and move the value or its complement into the other 

specified location.  The two input commands combine the values from both locations, placing the result (except for a 

COMPARE result) into the second location.   

  

Value locations are typically named elements, registers, or directly specified device element locations.  The data 

manipulation commands expect at least one of the values held in a Local or Global Register.  Only one location can 

be a named element or a device element specification. 

  

The MOVE command moves a value from a register to/from a named element, another register, or a specified 

device element location.  The COMPLEMENT command is similar to MOVE, but inverts the TRUE / FALSE 

condition of a BOOLEAN value, or performs a one‘s complement of a numeric value. 

  

The AND, OR, NAND, NOR, and XOR commands perform their named logical operation upon BOOLEAN values, 

and replaces one of the values with the result.  More complex logical relationships can be constructed by combining 

these commands and storing intermediate results in Registers. 

  

The ADD, SUBTRACT, MULTIPLY, and DIVIDE commands perform their mathematical operations upon 

numeric values, replacing one of the values with the result. 

  

The COMPARE command tests the two value locations against each other and sets internal result flags to indicate 

their equality and relative size relationships.  Result flags can be tested by a JUMP command (see below) to 

determine if a conditional JUMP is executed. 

  

Fade Command 

  

    FADE 

  

The FADE command typically implements a lighting fade to a specified bright or dim level over a specified period 

of time.  Any dimmable device, such as a basic low-cost X10 lamp module, can be gradually faded with the FADE 

command.  Some devices implement automatic fades within the dimmer control device, and hence do not need 

controller timed fades.   

  

Control Flow Modification Commands 

  

    JUMP 

    EXECUTE 

  

The JUMP command changes the order of macro item execution.  When encountered, if conditions are met, macro 

execution continues with the macro item following the matching LABEL command.   

  

Conditional jumps occur only if the condition matches the results of the another condition determining command.  

Typically, this is a COMPARE command.   An example of a conditional jump is testing for a divide-by-zero error 

condition after a DIVIDE command. 

  

An unconditional JUMP might be used to execute a macro loop continuously until a Finish Trigger event occurs.  

  

The EXECUTE command starts or stops the execution of a child direct macro started or spawned from an initially 

running macro (parent).  The parent macro may be either a direct macro or a macro device.  Options allow the initial 

parent macro to suspend execution until the named child macro has completed (akin to a subroutine or function call), 

or to continue executing concurrently with the child macro (akin to spawning a new process).  If desired, the 

EXECUTE command supports initial parallel execution with later synchronization between the two macros.  Parent 

macros can pass parameters to and can share data with their child macros through the use of Global Registers. 

  

Notification Command Group 

  

    NOTIFY 

    DEBUG 

    WARNING 

    ERROR 

  



The notification command group sends information to applications on the host computer to communicate conditions 

within the macro.   

  

The DEBUG command sends text messages showing execution points, register values, and element values.  Text 

messages can be viewed on the FSD Router or FSD Automator view window.  DEBUG commands are typically 

used to verify intended functioning during macro design. 

  

The WARNING and ERROR commands send text messages to FSD Automator, which cause Warning or Error 

message windows to appear and warn of an exceptional condition.  One example is sending a WARNING if a macro 

monitoring an air pressure sensor device detects a drop in air flow.  The warning would suggest servicing the 

HVAC, in particular examining the air filter. 

  

The NOTIFY command sends a message to the host computer, causing display of a notification message box or 

execution of a custom notification handler program on the host.  See the Using Notifications section below for 

additional discussion. 

  

Sending External Protocol Commands 

  

    X10_COMMAND 

    ZWAVE_COMMAND 

    UPB_COMMAND 

    RS485_COMMAND 

    INSTEON_COMMAND 

  

The protocol commands send device family-specific native commands to its devices.  Note:  The device family must 

be supported by the model of FSD Controller in use and an appropriate protocol interface controller device must be 

configured on the system. 

  

When a protocol command is selected, a dialog box is displayed with options appropriate for the selected protocol.  

For example: 

 X10  

 Different manufacturers of X10 devices specify their own syntax for extended commands and are thus 

incompatible standards.   

 the FSD Controller supports the appropriate extended commands and sends them so that ―scene‖ and 

―Group‖ commands may be used. 

 UPB 

 both direct and link commands are supported 

  

  

Concurrent Macro Execution 

  

Macros can execute concurrently with each other, while the FSD controller continues its functions.  

  

Single instances of different Direct Macros can run concurrently.  Multiple, simultaneous execution of the same 

Direct Macro is not supported.  Attempts to execute or start trigger a running Direct Macro are ignored. 

  

Single instances of Macro Devices can run concurrently, even if based upon the same Macro Device Type.  

Multiple, simultaneous execution of the same Macro Device is not supported. 

  

Exporting and Importing Macros 

  

Direct Macros may be exported and imported with care.  After importing a Direct Macro, reconnect any device 

elements specified in the macro.  Reset any explicit device addressing, such as by an X10 or UPB direct command, 

to the correct addresses for the new configuration. 

  

Macro Device Types are better suited for exporting and importing macro designs, if written for portability.  If all 

element linkages are implemented as ELEMENT macro items, rather than directly referencing elements on other 

devices, then they can be connected to elements on the imported system with Operations, without changing the 

macro device type implementation.  Similarly, for portability, implement commands to devices such as X10 or UPB 

devices as controlling elements linked to those devices, rather than using direct protocol commands. 

  

Using Notifications 



  

Notifications initiate actions on the host computer or a connected remote computer, in response to an event or 

condition detected by the FSD controller.  For example, a message could be displayed on the computer screen if the 

doorbell is rung or if the clothes dryer has finished. 

  

NOTIFY macro functions may be inserted in Direct Macro and Macro Device Type definitions.  When encountered 

at run time the FSD Controller sends an ST_NOTIFY_PKT packet containing the specified notification code and 

selected additional data or text string. 

  

Macro Device Notifications: 

  

Notifications from Macro Devices are supported by FSD Automator and the Macro device dialog.  If the 

associated Macro device dialog is active, the notification packet is sent to the dialog.  If the dialog is not active, 

the dialog is started automatically from Automator to process the notification.  (Note:  Automator must be active 

for the packet to be handled in this fashion). 

  

The Macro device dialog handles the notification in accordance to the options selected in the ―Configure Notify‖ 

dialog (accessed from the device dialog‘s system menu).  A message window may be displayed for viewing, 

and/or a user-specified notification handler application can be started to take further action  

  

Macro Device notifications can alternatively be processed by a user-developed or third party provided custom 

notification service.  This application is a FSD Router client , developed following the guidelines provided in the 

FSD Third Party Application Interface documentation. 

  

This notification handling functions similarly to the alarm notification capability provided by the Alarm Timer 

device type. 

  

Direct Macro Notifications: 

  

Notifications from Direct Macros are not supported by FSD Automator; however, notification packets are sent 

from the FSD Controller to FSD Router.  The notifications can be processed by a user-developed or third party 

provided custom notification service.  This application is a FSD Router client application, developed following 

the guidelines provided in the FSD Third Party Application Interface documentation. 

  

  



FSD Designer Configuration Guide 
  

Use FSD Designer to plan floor layouts, to add ―smart‖ devices, and ,if desired, to create and add furniture and 

appliances to your layout.  The different floors can be combines to create a building layout. 

  

If the devices are added to the system and configured (using FSD Automator), double clicking on the device icon 

you‘ve added to the floor plan.  In the Device Item Properties dialog box, select the device family, device type and 

name of the device to connect the configured device to the icon.  In FSD Viewer, double-clicking on the icon 

displays the device‘s dialog box. 

  

For more detailed instructions see the tutorial for FSD Designer by choosing View Tutorials under the Help Menu in 

FSD Automator.  In the tutorial click on FSD Graphical Interface Designer. 

  



FSD Logger Configuration Guide 
  

The FSD Controller software provides two approaches to log or record events occurring on the system.  First, FSD 

Logger records device element states.  Second, the logger utilities, under the Installer Tools menu, record protocol 

packets.  More about protocol packet logging is discussed at the end of this document.  These tools can be used 

independently.   

  

Device Element State Logging: 

  

Device element state logging records the state(s) of device elements periodically and/or when the state changes.  The 

FSD Logger provides extensive logging configuration options to customize data logging. 

  

An example of element state logging is a system monitoring and recording temperature and humidity over time at 

various locations throughout a building (e.g. museum).  The user can set an FSD Controller options to send a 

notification when conditions exceed a specified range. 

  

To start the logger,  in FSD Automator, select View  FSD Logger. 

  

From the FSD Logger main menu, define or modify the logging behavior by selecting Log  Define Log File 

Properties.  Alternatively, click on the ‗D‘ button on the Logger toolbar. 

  

The log file name list box displays currently defined log file base names.  FSD Logger can generate multiple log 

files, each logging different data.  These files can be used for different purposes. 

  

To define a new log file definition, press the ―Add Log File Definition‖ button.  To edit an existing log file, double 

click its list entry.  
  

From the log file definition dialog, enter a base name 

for the log file.  Each file generated is automatically 

combined with a creation date and append number.  

Select the checkboxes whether to ―Enable Log File‖ 

and/or ―Enable Log File at Startup‖.   

  

Select a storage location for the file.  If desired, select 

another location for a redundantly generated backup 

file (possibly a different disk or storage on a 

networked computer).  The default location is 

<controller root>\data. 

  

Select the Log Duration to specify how long to log 

before starting a new file.  The date for a monthly file 

is designated as the first day of the current month.  The 

date for the weekly file is set as the Sunday of the 

current week.  Also select the maximum file size.  

When the maximum is reached, a new log file starts.   

  

Log files have Write with Read access.  These files can 

be (1) used to communicate device element state data 

to custom user applications as they are generated, (2) viewed by an 

application such as Excel, or (3) backed up at any time.   

  

Select the format for the log files.  Log files can be written (1) in a 

documented binary data format, which minimizes file size and 

increases processing efficiency, or (2) in a comma delimited format, 

which enables easy import of data into off-the-shelf applications.   

  

Use filters to specify what data to log.  Add a filter by pressing the 

―Add Filter Definition‖ button, modify an existing filter by double-

clicking its entry in the filter list.  
  

In the Edit Filter Options dialog, specify which device families, device 

types, and/or devices to log.  If a single device type or specific device 



is selected, also select which elements to log. 

  

Under Set Log Interval, specify whether to log element state values under the following conditions: (1) every report 

that occurs, (2) at set intervals (periodically, seconds or minutes), and/or (3) only when changes occur. 

  

Note the interdependence between the device‘s element state reporting configuration and the specified logging 

control configuration.  The device‘s reporting configuration specifies how frequent device element state data packets 

are sent from the controller to FSD Logger (and other listening applications).  The logger filter specifies which 

element state data packets to log.  Thus, filtering can reduce the number of reports logged, but not increase it.  

Device configuration dictates the maximum logging, even if the filter specifies a greater frequency. 

  

Also note that (1) one can individually enable or disable log files and filters, and (2) both a log file and at least one 

filter must be enabled before data can be logged. 

  

For the logger to record the element state data to log file(s), FSD Logger must be running and data logging 

activated.  For casual and diagnostic logging, manually starting FSD Logger may be adequate and preferred.  Start 

logging manually by selecting Log  Enable All Logs or pressing the ‗A‘ button on FSD Logger‘s toolbar. 

  

Alternatively, FSD Logger can be started whenever the user starts the computer.  Place FSD Autostart in the 

Windows startup application list, and select ―Automatically Start FSD Logger‖ in the Autostart Options dialog 

(accessed from FSD Automator‘s main menu Options  Set Autostart Options).  When set, FSD Logger starts as a 

service at boot-up.  If you do not want logging displayed on screen, set FSD Logger to run invisibly.  Using 

Automatic start-up and invisible running of FSD Logger is ideal when the logging PC doesn‘t require a user login. 

  

To enable element state logging, whether or not a user is logged on, set FSD Logger to operate as a Windows 

service.  To configure, select ―Start Logger as a Service‖ on the Autostart Options dialog in FSD Automator.  Note 

that when FSD Logger is started as a service, FSD Router is also started as a service.  FSD Router routes the state 

data packets from the FSD Controller to the FSD Logger application.  When deselecting FSD Logger to start as a 

service, also deselect FSD Router to start as a service, if preferred. 

  

When manually starting FSD Logger (FSD Logger not running as service), if FSD Automator is not running, FSD 

Logger starts FSD Automator invisibly to validate current device configuration.  If FSD Automator detects a 

configuration change, it becomes visible and requests attention. 

  

Device element state data can be logged onto FLASH memory on ―larger‖ FSD Controllers.  Thus, data logging 

continues without interruption if (1) the controller‘s host computer is disconnected or turned off, or (2) when the 

FSD Logger program or its logging function is stopped.  If FLASH logging is enabled, device element data logs to a 

circular queue within the controller‘s FLASH memory.  When FSD Logger is started, or when a stopped log file is 

started, FSD Logger retrieves the historical FLASH log data beginning from the last time FSD Logger was active 

until the present.  FSD Logger proceeds to log the current device element data reports.  Data are retained in the 

circular queue until overlapped, in the event data logged is checked from a second computer. 

  

Installer Tools Protocol Packet Logging: 

  

From the FSD Automator main menu, select the Tools  X10 Installer Tools  FSD X10 Logger to start a utility 

that logs X10 protocol packet.  This utility decodes X10 packets, from both the FSD Controller and the power line 

(via a TW523 or PSC05 interface), and displayed them onscreen.  If selected, packets are recorded to a packet log 

file.  If the FSD Controller is an X10 Bridge model, X10 packets can be logged by attaching a legacy controller to 

the ―X10 IN‖ input.  FSD X10 Logger supports run time packet logging simultaneous with other FSD Controller 

functions. 

  

If the FSD Controller is an advanced model, X10 packets can also be logged from an CM11A interface.  However, 

the CM11A interface introduces considerable time delays, which may be acceptable for a logging application, but 

undesirable for device control.  Note that unlike the CM11A, the TW523 / PSC05 interfaces do not receive X10 

extended commands.   

  

Similar to the X10 logging utility,  there is an UPB logging utility.  From the FSD Automator main menu, select 

Tools  UPB Installer Tools  FSD UPB Logger to start a utility that logs UPB protocol packets.  This utility 

decodes UPB packets from the FSD Controller and the UPB power line interface module and logs them onscreen 

and, if enabled, to a packet log file.  FSD UPB Logger supports run time packet logging simultaneous with other 

FSD Controller functions. 

  



Note that the PCS Upstart utility also logs UPB packets.  From FSD Automator choose Tools  UPB Installer Tools 

 PCS Upstart.  In this situation, (1) the FSD Controller shifts to an RS-232 packet pass-through mode, (2) FSD 

Automator and all associated FSD applications shut down , and (3) the PCS Upstart utility starts.  This allows the 

PCS Upstart utility to use the same UPB powerline interface module as the FSD Controller, without disconnecting 

and reconnecting cables.  However, it does not allow simultaneous use of the PCS Upstart utility and FSD 

Controller run-time functions.  To log run-time data using the UPB Upstart utility, connect a second UPB powerline 

interface module to the PC for dedicated use by PCS Upstart. 

  

For additional information, see the FSD Logger reference manual.  Access the manual from the Help menu in FSD 

Automator; choose View Reference Manuals then FSD Logger from the displayed list. 

  

  

  



FSD Additional Configuration Topics 

 
Checking for Updates: 

Before updating, please remember to back up your FSD Controller installation files. !!! 

To check for software and documentation updates, select Options _ Check For Updates from the 

Automator main menu, or from the Viewer system menu. 

Select the level of update desired, and press OK. The update will proceed automatically. If given a notice 

that FSD Upclient cannot update an open utility, close that utility and continue. 

Check For Updates will automatically update the FSD Controller firmware if needed, and possibly the 

firmware in supported attached devices, in addition to updating the PC based software and documentation 

files. 

 

Update level options: 

Update Current Version – to maintain a satisfactorily stable installation with no significant changes, select 

this option. ―If it ain‘t broke, don‘t fix it.‖ 

Update to Latest Version – obtain the latest released version to benefit from feature improvements and 

support for new devices. Select a Stable Days option appropriate for your own trade off between wanting 

to update versus wanting to let others find any problems in the release. Before configuring a new 

installation, updating to the latest released version is recommended. 

Beta Version – test release of features targeted for the next official release, so early adopters can fiddle with 

the code and participate in finding any bugs and undocumented features. Beta releases will attempt to 

automatically update user data from earlier versions, but the user should be certain to back up his previous 

installation prior to updating. Not recommended for use in third party installations or by the faint of heart. 

Alpha Version – test release for preliminary evaluation of new version features. Alpha releases may not 

always attempt to automatically update data from earlier versions, so previous configuration data may be 

lost. Not recommended for use in real installations. 

 

Controlling Devices with SEND_DE 

The SEND_DE utility can be used to control a device or trigger a macro from a desktop icon, without 

having to start the whole FSD Automator or FSD Viewer environment. It may also be used within a batch 

file for aggregating several commands. 

SEND_DE is appropriate for use on remote computers, in addition to the controller host computer. If the 

system is configured for directory lookup of the controller‘s TCP/IP address, SEND_DE can take 

advantage of this service. 

SEND_DE provides a simple control interface method for using FSD Controller capabilities from within a 

custom third party application. Simply spawning SEND_DE with appropriate parameters will set device 

element values in the controller. 

SEND_DE is started with parameters as follows: 

SEND_DE SET <device_name_id> <element_number> <element_type> <element_value>\ 

The device name ID is passed in as a capitalized HEX value, matching the name_id for the device to be 

controlled. Other values are passed as decimal values. 

One way to find the device name ID value, and appropriate element number and element type, is to view 

the device information with View _ Lister _ <device family> from the FSD Automator main menu. 

To create a desktop icon to use SEND_DE, point at the desktop, right click, select New _ Shortcut, then 

select Browse and find <fsd_root>\BIN\send_de.exe. 

After the icon is on the desktop, right click and select Properties, then at the end of the line with the 

send_de.exe path, enter ―/k= SET <name_id> <other pameters>‖. 

 

Additional FSD Controller Installation: 

More than one FSD Controller or Bridge can be operated and/or configured from a computer. This might 

be done for one person to maintain controllers at more than one location from a laptop computer or a 

remote location, or to operate more than one specialized controller from the same host computer at one 

location. 

Each FSD Controller installation has its own copy of the FSD executable files, so different controllers 

using different versions of the FSD software may be used from the same computer. This allows using the 

latest greatest version for configuring a new installation, while maintaining existing stable installations 

without updating them. Therefore, if one wants to update all installations, each must be updated 

independently. 

 

Installing Additional Controller from an Install Disk: 

To install an additional controller from an FSD Controller Installation disk, run the install program again 



specifying a different installation root directory than used for an existing FSD Controller installation. 

When prompted, have the installation program check for the latest updates via the Internet. 

 

Installing Additional Controller from the Existing Installation: 

If the host computer already has one or more FSD Controller or Bridge product(s) installed, start by 

copying the previous FSD software installation in its entirety to a folder with a different root name (for 

example, assume the new application root to be <fsd_new>). 

Delete all xxx.CFG files from <fsd_new>\BIN. 

Delete all files in <fsd_new>\DATA. 

 

Multi-site Remote Operation Configuration: 

From the FSD Automator main menu, select Options _ Set Automator Options, and enter the Controller 

Name ID from the additional remote FSD Controller. Configure the connection address directory lookup 

or IP address as appropriate. 

The Router Port value must match the Router Port assignment on the controller host computer. 

The Server Port value on the remote computer can be the default or any other value, if only one of the 

installed configurations will be connected at a time. For simultaneous remote access, the Server Port value 

will need to be different for each remote installation instance. 

 

Simultaneous Host Operation Configuration: 

For each FSD Controller installation, from the FSD Automator main menu, select Options _ Set Router 

Options, and select the Comm Port to use with the associated controller. Deselect the Comm Port 

autosearch option. 

From the FSD Automator main menu, select Options _ Set Automator Options, and select the local 

machine option if needed. 

For simultaneous operation, the Router Port and Server Port values must be different for each FSD 

Controller installation instance. To enable remote access to multiple controllers, the Router Port and 

associated Synchronization Port need to be unblocked for each controller (see the “FSD Remote Access 

 

Configuration Guide”). 

Automatically starting FSD Router and / or FSD Logger as services is not currently supported for more 

than one hosted FSD Controller. Please check with FSD for assistance if this is required. 

Procedure to Convert Controller Type: 

The current model FSD X10 Compact Controller and FSD UPB Compact Controller use the same 

controller hardware, so may be converted from one to the other by the user via a software configuration 

procedure. To maintain installations to evaluate both types of controllers, an additional installation with a 

different root folder should be made for the second FSD Compact Controller configuration. 

To convert an FSD X10 Compact Controller to an FSD UPB Compact Controller, or vice versa, first start 

Router from <fsd_root>\BIN\ROUTER.EXE, then start <fsd_root>\BIN\LOADER.EXE. From FSD 

Loader‘s menu, select Options _ Set Controller Configuration. Using the drop-down selection within the 

dialog, select either FSD X10 Compact Controller or FSD UPB Compact Controller. 

Follow the Additional Controller Installation instructions above to create a new folder tree for the different 

controller type. Alternatively, delete the <fsd_root>\BIN\*.CFG files and all the files in the 

<fsd_root>\DATA folder. 

WARNING: Selecting a controller type which does not match the hardware capabilities will lead to 

unsatifying results! 

Start Automator. Automator will reload the controller firmware automatically to match the new controller 

type selection. 

  



FSD Remote Access Configuration Guide 
 
FSD controller software, and third party custom software, can access FSD controllers 
via a LAN, Wireless LAN, or the Internet using the TCP/IP protocol.  The programming 
model used for remote access is based on having the FSD software running on a host 
computer connected directly to the FSD controller, and also installed on each additional 
computer accessing the system remotely. Components of the host based FSD software 
route packets between the remote computers and the FSD controller, and also 
synchronize configuration data among the computers. This approach provides close to 
full functionality for high performance remote monitoring, control, and configuration of 
the system.  By contrast, a browser based approach might typically provide a more 
limited, lower performance solution, with the advantage of not requiring FSD software to 
be installed on the remote computers.  The host computer must be a Windows XP (any 
variation) or Windows 2000 machine connected to the LAN or Internet, but does not 
need to be a LAN server or to run Internet server software. For Internet access, a high 
speed always-on connection is desirable so the controller may be dependably accessed 
while away, but the software can work with standard dial-up service. A static IP address 
is nice but not required; the FSD software includes a feature for automatically finding 
connection addresses via an Internet based directory service. Configuring remote 
access involves a number of steps at the host computer and the remote client 
computer. 
 
Warning: Optimally configuring a system for remote access may require Host 
Computer Configuration: 
1) If running in floor plan Viewer mode, select “View FSD Automator” from Viewer’s 
system menu (accessed by clicking the icon on the left end of Viewer’s title bar). 
2) From the Automator menu, select Options _ Configure Router Options 
3) Router will become visible, with an active dialog box for selecting serial port options. 
Click on the CANCEL button to close the dialog box. 
4) From the Router menu, select Options _ Select Access Options 
5) Select desired access privilege levels for LAN and Intenet access, enable appropriate 
password requirements, and set passwords. Passwords set at the Router level are used 
by 
all enabled access levels for LAN and Internet access. 
6) Close Router, then restart Automator (using Autostart); make Automator visible as in 
step 1 above if needed. 
7) If the host computer has an always-on connection to the Internet: From the 
Automator menu, select Options _ Select Autostart Options, and enable “Start Router 
as 
a Service”. With this selection, Router will be automatically started whenever the 
computer reboots, so the controller can be accessed remotely without having to first log 
on to the host computer and manually start Automator. 
8) Note that when configured for remote access, some invisible components of the FSD 
Automator software system will continue to run after Automator is closed with a normal 
exit, so that the system may still be accessed remotely. To shut down all components of 
the system, from the Automator menu select File _ Shutdown Server. 
9) Note that if Router has been started as a service as in step 7 above, it cannot be 
accessed from the Automator menu as in step 2 above. To change remote access 
options, shutdown the server as in step 8 above, then restart Automator (using 
Autostart). Then with Automator visible, proceed with Options _ Configure Router 
Options. 



10) If directory lookup services will be used for finding TCP/IP addresses, to prepare for 
configuring the remote computers the FSD controller “name_id” must be found. One 
way to find this is from the Automator menu select Options _ Configure Automator 
Options and observer the Controller Name ID field. Alternatively, select View _ Lister _ 
FGI Devices, find the controller in the device listing, and copy down the “name_id” from 
the displayed information. 
11) Note that for remote access, any firewall services on the host computer and 
possibly on one’s Internet router will need to have Router and Syserver access 
unblocked. By default, FSD Router is set to use TCP/IP port 7100, and FSD Syserver is 
set to use TCP/IP port 7110; these port numbers can be changed from the Router menu 
Options _ Configure Router Options. 
12) Note that if a Host computer is to be configured to allow access to more than one 
connected FSD controller, additional measures must be taken. Do a Check for Updates 
from Automator Options or the Viewer system menu, and then view this guide from the 
installation root\manuals directory for additional instructions, or contact FSD for further 
instructions. 
 
Remote Access Computer Configuration: 
1) Start the FSD software with Autostart; if needed make Automator visible as above. 
The software can be expected to fail to find a Router connection. 
2) From Automator, select Options _ Configure Automator Options. 
3) For using directory services, enter the FSD controller “name_id”, and select “find 
address automatically”. Both the host computer and the remote client computer must 
have Internet access for directory services to work. 
4) Alternatively, static LAN and/or Internet addresses may be manually entered, and the 
appropriate access type enabled. 
5) Close the dialog and restart the application. 
6) If the remote client computer has a firewall installed that blocks outgoing accesses, 
configure the firewall to allow communications as in step 11 of the Host computer setup 
instructions. 
7) Note that if a remote client computer is to be configured to access more than one 
FSD 
controller, the software should be installed with a separate installation root directory for 
each controller accessed. 

  



FSD Third Party Application Interface 
The FSD /FGI automation controller and software system are designed to facilitate third 

party and custom application integration. FSD provides these applications with a means 

to receive sensor data from and send device control data to the automation controller and 

its controller devices via standard TCP/IP packets, so the custom applications can easily 

interface with the real world from the local host computer, across a network, and/or via 

the Internet. 

When interfacing with the FSD / FGI system, the custom application first establishes a 

connection with the FSD Router, and then proceeds with a packet conversation with the 

FSD / FGI Automation Controller. 

Custom Application to FSD Router Conversation: 

On Custom Application Start-Up: 

1) Establish a TCP/IP socket connection with FSD Router, port ID as set on the FSD 

Router options dialog (the default port used is 7100). 

2) FSD Router will then control the packet conversation until the connection permissions 

are established, including a password exchange if FSD Router is configured to require a 

password for system access. 

In the packet protocol, participating applications use packet source and destination 

connection IDs to control packet routing to the appropriate recipients. Custom 

applications should base their application connection IDs on the value: 

#define CUSTOM_APPLICATION_BASE_ID 0x22F00000 

Commercial third party applications may use other base IDs assigned by FSD. 

Additionally, applications may send and receive broadcast packets addressed to all 

interested recipients, where the destination connection ID is set to 0xFFFFFFFF. 

Packet definitions, along with other useful structure definitions are provided in the files 

PUBLIC_PACKET.LC and PUBLIC_NAME.LC. These files should be included in the 

custom application‘s STDAFX.H or otherwise included where used by the application. 

PUBLIC_NAME.LC has structure definitions which can be used by the custom 

application to interpret device and device type name files, to associate device name IDs 

with user-defined alphanumeric device names. 

Note that additional private packet types are used by the system for setup and 

configuration purposes. Custom and third party applications should ignore all such 

unrecognized packets. 

3) After establishing a socket connection with FSD Router, the custom application 

should receive an ST_CONNECTION_INFO packet from FSD Router. 

From the FSD Router ST_CONNECTION_INFO packet, the custom application should 

save the router‘s connection ID for use whenever packets are addressed to the router. 

The custom application should also use the connection index value from the packet to 

construct its own connection ID value. 

The max_packet_size value sent from the Router should be used to limit the maximum 

packet size sent from the custom application. 

The request_reply field in the received ST_CONNECTION_INFO packet indicates 

whether the originating application expects the sending application to reciprocate by 

sending an ST_CONNECTION_INFO packet back to the originator. The 

ST_CONNECTION_INFO packet from FSD Router will always have request_reply set 

TRUE, and the ST_CONNECTION_INFO response packet send from the custom 

application to FSD Router should set request_reply to FALSE. 

The following code snippet is provided to show how to interpret the 

ST_CONNECTION_INFO packet received from FSD Router: 

// process ST_CONNECTION_INFO packet from ROUTER app 
switch (((FSD_PKT_HEADER *) m_packet_received)->packet_type) 



{ 
case FP_STATUS_REPORT: 
switch (((FP_STATUS_PKT *) m_packet_received)->status_type) 
{ 
case ST_CONNECTION_INFO: 
// save the connection ID for FSD Router 
m_fsd_router_connection_id = 
((FSD_PKT_HEADER *) m_packet_received)->source_id; 
// construct the connection ID for the Custom Application 
m_custom_application_connection_index = 
((ST_CONNECTION_INFO_PKT *) m_packet_received)- 
>connection_index; 
m_custom_application_connection_id = 
(CUSTOM_APPLICATION_BASE_ID + 
m_custom_application_connection_index); 
4) The custom application should send an ST_CONNECTION_INFO response packet to 

FSD Router. Again, a code snippet: 

// send custom application’s connection info to FSD Router 
send_connection_info_packet (fsd_router_connection_id, FALSE); 
VOID send_connection_info_packet (ULONG destination_id, UCHAR 
reply_state) 
{ 
ST_CONNECTION_INFO_PKT *connection_packet_p; 
FSD_PKT_HEADER *packet_header_p; 
connection_packet_p = (ST_CONNECTION_INFO_PKT *) packet_buffer; 
packet_header_p = (FSD_PKT_HEADER *) packet_buffer; 
// set the packet header info 
packet_header_p->synch = FP_SYNCH; 
packet_header_p->destination_id = destination_id; 
packet_header_p->source_id = m_custom_application_connection_id; 
packet_header_p->packet_type = FP_STATUS_REPORT; 
packet_header_p->packet_size = (USHORT) sizeof 
(ST_CONNECTION_INFO_PKT); 
packet_header_p->sequence_number = // rolling number, 1 - 255, back to 1 
// set the status type value in the packet 
connection_packet_p->status_type = ST_CONNECTION_INFO; 
connection_packet_p->request_reply = reply_state; 
strcpy (connection_packet_p->sw_application_name, 
"custom_application"); 
connection_packet_p->sw_version = 0x0001; 
connection_packet_p->hw_type = 0x0000; // Windows PC 
connection_packet_p->hw_configuration = 0x0000; 
connection_packet_p->hw_version = 0x0000; 
connection_packet_p->packet_data_version = PACKET_DATA_VERSION; 
connection_packet_p->max_packet_size = MAX_BYTES_IN_PACKET; 
connection_packet_p->connection_index = 
m_custom_application_connection_index; 
connection_packet_p->data_size = 
(sizeof (ST_CONNECTION_INFO_PKT) - (sizeof (FP_STATUS_PKT) - 1)); 
// add crc_16 
set_packet_crc_16 (packet_buffer, packet_header_p->packet_size); 
// send the packet 



send_fsd_packet (packet_buffer); 
} // end send_connection_info_packet 
VOID C_CRC::flash_crc_16_accumulate (USHORT *crc_16_value_p, UCHAR 
in_byte) 
{ 
#define CRC_CCITT 0x1021 
USHORT data; 
USHORT index; 
USHORT crc_16_value; 
/** figure next CRC interim value */ 
data = (USHORT) (((USHORT) in_byte) << 8); 
crc_16_value = *crc_16_value_p; 
for (index = 8; index > 0; index--) 
{ 
if ((data ^ crc_16_value) & 0x8000) 
{ 
crc_16_value = (USHORT) ((crc_16_value << 1) ^ CRC_CCITT); 
} else 
{ 
crc_16_value <<= 1; 
} 
data <<= 1; 
} 
*crc_16_value_p = crc_16_value; 
} //-* end C_CRC::flash_crc_16_accumulate *-// 
VOID C_CRC::set_packet_crc_16 (UCHAR fsd_packet[], USHORT packet_size) 
{ 
/* crc16 of packet */ 
USHORT packet_index; 
USHORT crc_16_value; 
// initialize the crc_16 value 
crc_16_value = 0xFFFF; 
// calculate the crc_16 value for the packet 
for (packet_index = 0; packet_index < (packet_size - 2); packet_index++) 
{ 
flash_crc_16_accumulate (&crc_16_value, fsd_packet[packet_index]); 
} 
// store the crc_16 value in the packet 
*((USHORT *) &fsd_packet[packet_index]) = crc_16_value; 
} //-* end C_CRC::set_packet_crc_16 *-// 
5) If FSD Router options are set to NOT require password authentication, proceed to step 

7. 

If password authentication IS enabled in FSD Router setup options, the custom 

application will next receive a password request packet: 

case FP_STATUS_QUERY: 

switch (((FP_STATUS_PKT *) m_packet_received)->status_type) 

{ 

case ST_AUTHENTICATE: 

switch 

(((ST_AUTHENTICATE_PKT *) m_packet_received)- 

>authenticate_type) 

{ 



case STD_PW_REQUEST: 

6) If the custom application received a password request packet from FSD Router, the 

custom application must send a valid response packet. 

// send a response packet as defined in PUBLIC_PACKET.LC 

send_password_info_packet (); 

7) The custom application will receive a Password acknowledgement packet from FSD 

Router. If all is well, the status data value will be STD_PW_OK, and the custom 

application can proceed with establishing a conversation with the FSD / FGI Controller 

as shown in step 8. Otherwise, additional attempts at password authentication must be 

made. 

case FP_STATUS_REPORT: 
switch (((FP_STATUS_PKT *) m_packet_received)->status_type) 
{ 
case ST_AUTHENTICATE: 
switch (((ST_AUTHENTICATE_PKT *) m_packet_received)- 
>authenticate_type) 
{ 
case STD_PW_OK: 
// password is OK, proceed with CONTROLLER conversation 
-- OR -- 
case STD_PW_LOCKOUT: 
// bad password, connection dropped by server 
case STD_PW_GLOBAL_LOCKOUT: 
// bad password received by FSD Router 
// from another app, retry password later 
Custom Application to FSD / FGI Controller Conversation: 

8) The custom application has now successfully established and authenticated a 

connection with FSD Router. The custom application can now proceed with establishing 

a packet conversation with the FSD / FGI Controller. 

The custom application will send the controller a ST_CONNECTION_INFO packet, 

using the following controller ID value, with the request_reply field set TRUE so that the 

controller will reciprocate. 

#define FGI_CONTROLLER_BASE_ID 0x20000000 

send_connection_info_packet (FGI_CONTROLLER_BASE_ID, TRUE); 

9) The custom application will receive an ST_CONNECTION_INFO packet from the 

FSD / FGI Controller. As above, the custom application should extract the 

max_packet_size value from the controller‘s ST_CONNECTION_INFO packet and use 

it to limit the size of packets sent to the controller. 

case FP_STATUS_REPORT: 
switch (((FP_TEST_TYPE_RESPONSE_PKT *)m_packet_received)- 
>status_type) 
{ 
case ST_CONNECTION_INFO: 
10) The custom application will receive DEVICE_ELEMENT data packets from the 

FSD / FGI Controller, containing element state data from the devices on the system. 

case FP_DATA: 
switch (((FP_DATA_PKT *) m_packet_received)->data_type) 
{ 
case DT_NAMED_DEVICE_ELEMENT_DATA: 
case DT_DEVICE_ELEMENT_DATA: 
11) The custom application may send DEVICE_ELEMENT data packets to the FSD / 

FGI Controller, containing element state data to control the output states of the devices. 



Other Custom Application to/from Controller Conversation: 

12) If the custom application is up and running with a valid FSD Router connection prior 

to the FSD / FGI Controller power-up, or after the FSD / FGI Controller has been reset, 

the custom application will receive an STD_SLAVE_RESTARTED report telling the 

custom application that the controller has been restarted. 

Whenever an STD_SLAVE_RESTARTED packet is received, the custom application 

should reestablish a controller connection by sending a new ST_CONNECTION_INFO 

packet to the FSD / FGI Controller as in STEP 8 above. 

// Received From Controller after power-up or reset: 
case FP_STATUS_REPORT: 
status_type: ST_SLAVE_STATUS 
status_data_type: STD_SLAVE_RESTARTED 
13) The custom application may send an ST_REPORT_ELEMENT_STATES_PKT to 

request an immediate report of a device's status data. If the device family, device index, 

and element index are all set to 0xFF and 0xFFFF, all enabled element states of all 

devices present will be reported. 

14) The custom application may send an ST_OPERATION_MODE_PKT to set the 

operating mode of the FSD / FGI Controller. 

15) If configured, the custom application will receive an 

ST_NOTIFY_ALARM_TRIGGER_PKT 

when a configured alarm event has occurred. 

16) A note on packet sequence number usage: 

For packets issued spontaneously by an application, such as 

DEVICE_ELEMENT_DATA packets and STATUS_QUERY packets, the application 

should maintain and use an outgoing packet sequence number. For each packet sent, the 

sequence number should be incremented in sequence from 1 through 255, returning to 1 

as the next value following 255. 

STATUS_REPONSE packets must have the sequence number set to the sequence 

number of the STATUS_QUERY packet to which the response is being sent. 

Applications compare the response sequence number to the request sequence number to 

verify the received answer is matched to the appropriate question, maintaining 

appropriate synchronization between the application and the controller. 

17) Miscellaneous notes: 

All multi-byte numbers are stored in LITTLE ENDIAN (Intel style) form, with the least 

significant bytes in the numbers coming first, i.e. at lower addresses, than the most 

significant bytes. 

All packet and structure definitions are in PACKED form, with no pad bytes inserted 

within the structure (sometimes done automatically by a compiler for data alignment 

convenience). For the Microsoft VC++ compiler, use the ―Zp1‖ compile option. This is 

also referred to as ―1-byte-alignment‖ mode. 

Time values follow the Microsoft definition of time (__time64_t values), representing 

seconds past a particular reference time. 

Text string values in packets are in ASCII (single byte per char) and should include a 

0x00 termination character (C-style strings). The associated data_size value in 

FP_TEXT_PKT packets includes the 0x00 termination character. 

Note that many structures are defined as having a variable size array within the structure. 

In these cases, arrays are declared with an array size of 1, and are preceded by a 

number_of_entries variable specifying the actual number of array records present. The 

actual number of entries may be any value from 0 to a maximum dependent on the data 

represented. The actual size of the structure, and hence the position of the CRC_16 value 

at the end of the structure, will thus be dependent on the number of entries present. All 

packets have a standard header with a valid packet_size value indicating the actual size of 



the packet structure including any variable length data. 

Also note that for structures defined with more than one variable size array, or with 

nested variable size array, the position of array entries must always be explicitly 

calculated relative to the position of the first array entry, and the array entries cannot be 

accessed simply by indexing the array. As a particular example, the 

FP_NAMED_DEVICE_ELEMENT_DATA_PKT must be linearly ―walked through‖, 

calculating the device and element data positions for each device in the packet. 

A variety of CRC calculation methods are in common use, with sample implementation 

code freely available from many sources. Not all of these methods produce the same 

resulting values. To ensure consistent results, use the sample CRC_16 calculation code 

provided or code that produces equivalent results.  



 Multiple Controller Configuration Guide 
 

Multiple FSD Controllers can be connected to and controlled by the same computer.  However, 

this requires careful configuration to prevent interference with one another.  Successful 

configuration includes the following steps: 

1)  Install the FSD software for each controller in separate folders.  For example: 

 
2) With only one controller connected, start Router from the controller‘s associated bin 

folder, for example \fsd\j1708_tester\bin\router.exe  

From the Menu bar choose Options  Set Serial Port Options, select 

the appropriate COMM port option, and disable Auto-Search.  Click 

OK and restart Router.  Router should successfully connect to the 

controller. 

NOTE: the COMM port selected must be within the range of COM1 

through COM9.  If Router fails to find a controller, check the 

assigned comm. port value using Windows Device Manager 

(accessed in the Control Panel->System->Hardware->Device 

Manager).  Click on the Ports category 

to see which COM is associated with 

the CP210x USB to UART Bridge 

Controller.  If a COM port is out of 

range, double click on this port listing 

in Device Manager to open the 

properties dialog, select Port Settings, 

then click on Advanced to change the 

assigned port.  Port values may be 

listed as used – it is OK to reuse these 

port settings as long as the assigned 

devices are not connected to the 

computer simultaneously. 

 

 

 

 

3) From the menu bar select Options  

Set Router Options, and enter unique 

TCP/IP port values for the two port 

options.  (only one controller can use 

 



the default port values of 7100 and 7110) 

 

 

 

 

 

 

 

 

 

 

4) If the controller uses Automator, start Automator, from the menu bar select OptionsSet 

Automator Options, then enter a unique Server TCP/IP port value (only one controller 

can use the default Server TCP/IP port value of 7200).  

5) Close Router.  For each additional controller repeat steps 2 through 4.  Each time use the 

unique bin folder for the installed controller.  Also set unique COM port and TCP/IP port 

values for each controller.  

6) All controllers can now be connected to the computer, with its associated FSD automation 

software running simultaneously.  

  

  



FSD Controller Troubleshooting Guide  
Problem: Controller cannot open communications port.  
If using an USB port, determine the Comm Port assigned to the FSD Controller  

1. Under the Start Menu, depending on the version and presentation of Windows, choose ―Control Panel‖ or 

―Settings → Control Panel‖.  

2. Choose ―System‖ either:  

a. Directly in classic view, or  

b. Choose ―Performance and Maintenance‖ category followed by selecting ―System‖.  

3. Click on the ―Hardware‖ tab and choose the ―Device Manager‖ Button.  

4. Devices on the computer appear on a tree list.  

 

a. Double click on the ―Ports‖ line to display comm. port assignments.  

b. Note the comm. port number for the Silicon Labs CP210x USB to UART Bridge device. If the Comm port 

number is greater than 9 (nine), double click on the CP210x device, select ―Port Settings‖, click on ―Advanced‖, and 

select a lower port number. If there is no listing for CP210x USB to Serial, install the driver. In the directory where 

you installed the FSD soft-ware, in the \drivers\usb\WIN directory run Preinstall.exe.  

c. Close ―Device Manager‖ and ―System Properties‖ windows.  

5. Click ―OK‖.  

6. Select the Automator application screen.  

7. From the ―Options‖ menu select ―Set Router Options‖.  

8. From the ―Comm. Port‖ droplist select the comm. port number determined above.  

9. Click ―OK‖.  

10. Click ―OK‖ to the box stating to restart the router application to reset.  

 

Problem : Buttons and lines in dialog boxes do not line up  
This problem occurs when using Windows Vista Operating System. To remedy the problem:  

1. Right-click the mouse on the desktop and choose ―Personalize‖.  

2. Click the ―Adjust font size ― shield in the left side of dialog.  

3. Choose ―Default‖ for the display font size (96 DPI).  

  



FSD Controller Reference Manuals  

 
Select the FSD application below to display its reference manual.  

 

FSD Controller Operation  

 

FSD Autostart - opens critical applications used to configure the system. 

  

FSD Automator - an integrating tool to configure the devices on the system.  

 

FSD Viewer - displays the layouts produced in FSD Designer.  

 

FSD Logger - records conversation between controller and devices in a text file.  

 

FSD Upclient – used to update FSD Controller software via the internet.  

 

FSD Router - a server application to route communications among serial ports and TCP/IP addresses.  

 

FSD Device Dialogs – links to a page listing manuals for device dialogs.  

 

FSD Operation Designing Tools  

 

FSD Lister - displays a list of devices in the entire system  

 

FSD Creator - create Direct Macros and Macro Device Types to produce customized programming 

on the system.  

 

FSD Namer - assign name, location, and other identification to configure the system.  

 

FSD Designer - a multifunctional tool used to construct floor layouts of the building for placement of 

devices and furniture.  

 

FSD Operator - configures the various operations of the devices on the system.  

 

FSD Builder - builds the image of the data set for loading into the controller.  

 

FSD Loader - loads a FSD formatted file to the FSD Controller or other FSD devices attached to the 

system.  

 

FSD X10 Installation Tools  

 

FSD X10 Logger - records conversation between controller and X10 devices into a text file.  

 

FSD X10 Mapper - displays defined and detected X10 devices on the system.  



 

FSD X10 Tester – this utility sends various commands to a specified X10 device.  

 

FSD UPB Installation Tools  

 

FSD UPB Logger - records conversation between controller and UPB devices into a text file.  

 

FSD UPB Mapper - displays defined and detected UPB devices on the system.  

 

FSD UPB Tester – this utility sends various commands to a specified UPB device.  

  



FSD Autostart 
  

Overview FSD Automator 
FSD Autostart opens applications needed to configure the system.  It launches FSD Router, FSD Synchronization 

Server, FSD Logger, FSD Automator, and FSD Viewer. 

  

  

FSD Autostart 
FSD Autostart opens critical applications used to configure the system.  It launches FSD Router, FSD Automator, 

FSD Synchronization Server, and FSD Viewer.  Depending on the options set in FSD Automator, FSD Autostart 

will automatically start FSD Automator, either in the background or displayed on screen, and also will 

automatically start FSD Viewer. 

  

Other options set in FSD Automator, allows FSD Autostart to start automatically FSD Logger, either in the 

background or with screen displayed. 

  

Another option is to Start Router as a Service, which will automatically start FSD Router when the computer is 

turned on. 

  

If desired, the user can set another option to open automatically an application of choice.  Check the checkbox to 

enable starting a custom application automatically.  In the edit boxes enter the application name, the application 

parameters, and the application ID name. 

  

  

  

  

  

  

  

  



FSD Automator 
  

Overview FSD Automator 
FSD Automator is an executive program that accesses various programs used to configure devices on the system 

and to run the FSD Controller.  Within Automator the user (1) opens FSD Namer to define a device to add into the 

system, (2) configures the various devices on the system, and (3) sets the operations for the devices.  To view how 

the system is configured, use FSD Lister to display the devices and their settings on the system.  Automator can 

also display the current state of a selected device.  Use FSD Designer to draw customized floor layouts of the 

house in order to construct a graphical interface, which can be used in FSD Viewer to configure and control 

devices. 

  

  

FSD Automator Menu Layout 
Under the File menu, the user can Open, Save, Load, and Print  configuration files.   

  

Shutdown Server—stops the controller operating as a server.  
Exit—closes the FSD Automator application 

  

  

   

  

Under the View menu, the user sets the system by using: 

FSD Lister to display system-wide device placement and configuration.  
FSD Namer to assign devices to the system. 

FSD Creator to assign names to devices. 

FSD Designer to place devices in user-created floor layouts. 

FSD Viewer to configure and control devices using a graphical interface. 

FSD Logger to log data of system operation. 

  

 Selecting Toolbar displays the FSD Automator toolbar. 

 Selecting Status Bar displays the Windows status bar. 

  

  

  

  

  

Under the Display menu, the user can display devices entered in FSD Namer.  Select the device family, then 

choose the desired device in the resultant dialog box.  The dialog displayed shows its operational state and allows 

the user to control the device from the dialog box. 

  

  

Under the Configure menu, the user can choose a specific device to configure its reporting output and any specific 

functions (e.g. timers). 

  

  

Under the Operation menu, the user can choose a specific device to display its element types mode and choose 

operations to connect elements between devices. 

  

  

Under the Tools menu, the user chooses particular options to assist installation of X10, UPB, and Insteon device 

product lines: 

Mapper – to map devices on system 

Logger – to configure data logging 

Tester – to test function of devices on the system 

 Test Remote Access—to test communications to remote controller 

  Under the Options menu, the user chooses particular options for:  
 FSD Automator 

 FSD Autostart 

 FSD Router 

  

 Set location and time zone  



 Set Operation Modes 

 Report All States - the controller reports all current input 

and output states for all devices 

 Set Access Levels - password protected access settings to 

either monitor, control, or configure the system. 

 Check for software updates via the internet. 

  

  

Under the Help menu, the user can choose to view Tutorials, Installation 

Guides, Configuration Guides, Reference Manuals, Example Scenarios (to 

configure system), and Product Specifications. 

  

   

  

  

  

  

FSD Automator 
The File menu displays the following commands: 

  

  

Open Pop-up menu options open an existing system configuration or top level layout data set. 

Save Saves the current system data set using the same data set name. 

Save As Saves the current system data set to a specified data set name.  
Load Configuration Loads changes in configuration to the controller. 

Print Preview Displays the data set on the screen as it would appear printed.  

Print Prints a system data set.   

  

Shutdown Server Closes controller as a server. 

Shutdown Client Closes connection to remote client. 

Exit FSD Automator Closes FSD Automator program. 

  

The View menu displays the following commands: 

  

FSD Lister Invokes FSD Lister to view device listings, device wiring tree 

configuration, and device type information.   

  

Current FSD Configuration - Invokes the FSD Lister utility to view the current system 

device configuration and supported device type information. 

  

Saved FSD Configuration - Invokes the FSD Lister utility to view the saved system 

device configuration in the currently open data set, saved device wiring 

tree configuration, and supported device type information. 

  

X10 Devices – Invokes the FSD Viewer Utility to display the X10 devices on the 

system. 

  

Z-Wave Devices – Invokes the FSD Viewer Utility to display the Z-wave devices on 

the system. 

  

UPB Devices – Invokes the FSD Viewer Utility to display the UPB devices on the 

system. 

  

RS435/232 Devices – Invokes the FSD Viewer Utility to display the RS435/232 devices on the system. 

  

Insteon Devices – Invokes the FSD Viewer Utility to display the Insteon devices on the system. 

  

ALC Devices – Invokes the FSD Viewer Utility to display the ALC devices on the system. 

  

ZigBee Devices – Invokes the FSD Viewer Utility to display the ZigBee devices on the system. 

  

LON Devices – Invokes the FSD Viewer Utility to display the LON devices on the system. 



  

Macro Devices - Invokes the FSD Viewer Utility to display the macro devices on the system. 

  

Timers - Invokes the FSD Viewer Utility to display the timers on the system. 

  

Variables - Invokes the FSD Viewer Utility to display the variable data on the system. 

  

Operations - Invokes the FSD Viewer Utility to display operations on the system. 

  

Operational Mode - Invokes the FSD Viewer Utility to display the operational modes on the system. 

  

FSD Namer Invokes FSD Namer to assign user defined names to individual devices for X10 Devices, Z-

Wave Devices, UPB Devices, RS435/232 Devices, Insteon Devices, ALC Devices, ZigBee 

Devices, LON Devices, Macro Devices, Timers, Operations, and Operational Modes.   

FSD Creator Invokes FSD Creator to assign user defined names to individual devices.   

FSD Designer Opens FSD Designer program for customized creation of device icons, furniture, appliance, 

and floor plans. 

FSD Automator Enables / Disables FSD Automator visibility state upon FSD Automator startup, so the FSD 

Automator screen can be hidden from the user when the FSD Viewer graphical user 

interface is displayed. 

FSD Viewer Enables / Disables FSD Viewer to start automatically when FSD Automator starts, to view 

a graphical user interface to configure and control devices placed in the system..   

FSD Logger Invokes FSD Logger to edit logging options and enable data logging.   

Toolbar Shows or hides the toolbar. 

Status Bar Shows or hides the status bar. 

  

  

The Display menu displays the following commands to choose selection dialogs for: 

FGI Devices   ALC Devices 

X10 Devices   ZigBee Devices 

Z-Wave Devices   LON Devices 

UPB Devices   Macro Devices 

RS435/232 Devices   Timers 

Insteon Devices   Variables 

  

 Select the device type and the device name to 

display the state of the device.  
 

 
 

  

Click ―OK‖ to display the device and control 

functions. 

  

The Configure menu displays the following commands: 

  

Displays a dialog box (see Select dialog above) to select the type and name of the device type to configure one 

of the following devices: 

FGI Devices  
X10 Devices 

Z-Wave Devices 

UPB Devices 

RS435/232 Devices 

Insteon Devices 

ALC Devices 

ZigBee Devices 

LON Devices 

Macro Devices 

Timers 

Variables 

  

Choose the type from the droplist and the device 



name from the droplist.  Click ―OK‖ to approve 

selection of the device.  A dialog box specific to the 

selected device appears (see dialog box shown on 

the right).  Enter data and choose settings to 

configure the device.  Click ―OK‖ to accept values. 

  

The Operations menu displays the following commands: 

  

Displays a dialog box to select for operation the type and name of the device type for: 

FGI Devices 

X10 Devices 

Z-Wave Devices 

UPB Devices 

RS435/232 Devices 

Insteon Devices 

ALC Devices 

ZigBee Devices 

LON Devices 

Macro Devices 

Timers 

Variables 

  

Choose the type from the droplist and the device name from the droplist.  Click ―OK‖ to approve selection of the 

device.  A dialog box specific to the selected device appears displaying the elements associated with the device.  

To edit the element‘s operation attributes, double-click on the element.  To add another element, click on the 

―Add‖ button.  In the ―Operation‖ dialog that appears, choose the operation from the droplist.  Click ―OK‖.  The 

―Device Element Operation‖ dialog appears.  Enter operational data for the device.  Click ―OK‖  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  



  

  

  

  

  

  

  

  

  

  

  

 The Tools menu displays the following:  

  

X10 Installer Tools: 

X10 Mapper invokes the X10 Mapper utility to map which X10 addresses are used in the system.   

X10 Tester invokes the X10 Tester utility to send commands to test X10 device function.   

X10 Logger invokes the X10 Logger utility to edit logging options and enable data logging.   

  

UPB Installer Tools: 

UPB Upstart invokes PCS Upstart utility to configure UPB devices.  UPB Upstart closes all 

controller applications and uses only the serial port communications.  Set the Upstart 

path in the Automator Options menu. 

UPB Mapper invokes the UPB Mapper utility to map which UPB addresses are used in the system.   

UPB Tester invokes the UPB Tester utility to send commands to test UPB device function.   

UPB Logger invokes the UPB Logger utility to edit logging options and enable data logging.   

  

Insteon Installer Tools: 

Insteon Mapper invokes the Insteon Mapper utility to map which Insteon addresses are used in the 

system.   

Insteon Tester invokes the Insteon Tester utility to send commands to test X10 device function.   

  

Insteon Logger invokes the Insteon Logger utility to edit logging options and enable data logging.   

  

Test Remote Access—used to test the functioning of the various components needed for remote access to the FSD 

Controller.  The first screen of results displays Remote Access HOST Settings, the next displays Remote Access 

HOST Addresses, and the third displays results of testing remote access components, including FSD Primary 

Server, FSD Target Server, FSD Update Server, FSD 

Redirection Server and the connect tests by FSD Upserver 

results (FSD Router and FSD Syserver). 

  

  

The Options menu displays the following commands:  
  

Set Automator Options   Selects FSD Automator options 

  

Controller Name ID  Displays the unique controller id 

assigned to the FSD Controller. 

  

TCP/IP address -- choose the appropriate radio button that 

corresponds to your situation: 

 Local Machine only 

 Use Address From Directory to identify computer 

hosting the FSD Router application. 

 Use LAN IP Address—enter the IP address of computer 

hosting the FSD Router application. 

 Use Internet IP Address—enter the address of the 

computer hosting the FSD Router application.  If 

using FSD Loader on the same computer as FSD 

Router, set the TCP/IP address to its default local host 

value, 127.0.0.1. 

  

Router IP Port - the port used to connect to and communicate with FSD Router and its connected serial port 



devices.  Note that (1) the specified port must match the port specified in the FSD Router application and (2) 

for access via a firewall protected link the specified port must have access permission. 

  

Server IP Port - the port used to connect with other applications called by FSD Automator (e.g. calling FSD 

Lister). 

  

Enforce Configuration – when more than one computer is connected to a controller, it is imperative to designate 

only one computer as the master and to select the Enforce Configuration checkbox.  WARNING: if more 

than one computer selects this checkbox, at start-up the ID configuration number is checked and changed if 

it differs. 

  

FSD Automator Watch Level selects the quantity of debug information presented on the FSD Automator view 

window.  Watch Level 0 disables most output, with increasing levels showing more detailed debugging 

information. 

  

Enable Debug File – all view window tests, plus other information, are logged in DEBUG.TXT in the 

computer‘s TEMP directory, which is set in the computer‘s environment variables. 

  

Enable Debug Crash – writes the debug output to the file after each entry.  This ensures completed writes to file 

while debugging, in the event there is an application crash. 

  

Create New Debug File – starts a new file when FSD Automator starts (otherwise debug information is 

appended to the previous file). 

  



  

Set Autostart Options – This dialog sets options for 

Autostart functions.  Select checkboxes to choose 

options to automatically start FSD Automator, 

whether the application appears on the desktop, 

and also whether to start FSD Viewer. 

  

Another option selects whether FSD Logger is 

started and if its window is displayed on the 

desktop. 

  

Selecting Start Router as a Service automatically 

starts FSD Router when the computer is 

turned on.  This also applies to FSD Logger. 

  

The user has the option to automatically start a 

custom application.  Enter the specifics in the 

edit boxes provided.  The custom application 

can also be started as a service. 

  

  

  

Set Router Options: 

Set Serial Port Options 

  

Set the Comm Port to the port assigned to connect the controller with the 

FSD Router.  Selecting the Auto Search checkbox allows FSD Router to 

determine the assigned Comm Port. 

  

Manually, one can select a Comm port COM1 – COM16, Parity enforcement, 

Number of Stop Bits, and number of Stop Bits to use.  Also select the baud 

rate for the port. 

  

Select Full Duplex for normal RS-232, RS-422, or RS-423 operation.  

Deselect Full Duplex for Half-Duplex operation, if FSD Router is used with 

an RS-485 or J1708 type port adapter, which connects the transmit and 

receive lines.  For use with RS-485 adapters, which use the RTS signal to 

enable transmit, select the RTS TX Enable option. 

  

For RS-232 use with hardware handshaking lines, select the Use DTR/DSR 

or Use CTS/RTS option. 

  

  

 Set Router Options 

  

Use this command to select TCP/IP socket options and debug options. 

  

Show TCP/IP Address -- Click the button to display the computer‘s ip 

configuration information and TCP/IP address. 

  

Router Port – use this port to connect to and communicate with other 

FSD applications (e.g. FSD Loader).  Note that the specified port must 

match the port selected in other FSD applications.  For access via a 

firewall protected link, the specified port must be given access 

permission.  Note that since FSD Router is a TCP/IP server application, 

specifying the TCP/IP address in the FSD Router application setup is not 

required.  For connecting to FSD Router from an application running on 

the same machine, the local access TCP/IP address 127.0.0.1 can be 

used.  For accessing FSD Router from another machine on the network 

or via the Internet, use the host machine‘s TCP/IP address. 

  

FSD Packet ID -- This value times 0x100 is added to 0x02000000 to construct the base ID value used in packets 



sent from FSD Router.  The connection index reported from FSD Router is added to this value to create the 

SOURCE_ID value for the packets. 

  

Remote Synch Port -- is the port assigned to communicate with FSD software running on a computer at a 

remote location. 

  

Time Synch Source -- when selected, will send the time on the computer clock to the FSD controller. 

  

Watch Level -- selects the quantity of debug information presented on the FSD Loader view window.  Watch 

Level 0 shows the minimum amount of output, Watch Level 1 shows packet types being sent in each direction 

to and from the serial port, Watch Level 2 also shows the first several bytes of each packet sent, and Watch 

Level 3 shows more detailed debugging information. 

  

Enable Debug File -- All view window test and other information are logged in DEBUG.TXT, found in the 

computer‘s TEMP directory.  These directories are set in the computer‘s environment variables. 

  

Enable Debug Crash -- flushes the debug output to the file after each write.  This action ensures completed 

writes while debugging application crash conditions. 

  

Create New Debug File -- Starts a new file upon FSD Loader startup (otherwise debug information is appended 

to the previous file). 

  

Allow CSUM Packets -- allows reception of packets appended with a 16 bit checksum instead of a 16 bit CRC 

value from devices connected to the serial port.  Packets arriving via a TCP/IP connection, and all transmitted 

packets will still use CRC validation. 

  

Check Validity – Applies internal packet CRC checking to packets in transit.  Otherwise packets will be trusted.  

Packets arriving through the serial port are always checked. 

  

Check Packet Size – enforces internally specified parameters on packet sizes based on packet type.  This 

enables FSD Router to discard invalid packets.  May be disabled by the installer during application 

development to relax constraints.  Packet type validity and maximum packet size will be enforced in either case. 

  

Auto Response – automatically returns an acknowledge status packet to the sender of any packet containing the 

BROADCAST_DESTINATION_ID (0xFFFFFFFF). 

  

Access Options  

  

Choose the access type to set password security 

for Router, Host, LAN, or Internet access. 

  

Security Level – select NONE to disable 

password protection or ENABLED to require 

password protected access from applications 

connecting to FSD Router via TCP/IP 

connections.  The four password secure 

activities are: Monitoring, Control, 

Configuration, and for some instances Installer. 

  

Password – 32 character maximum, case 

sensitive.  Specify the password which must be 

sent from a connection application to gain 

access to a FSD Router connection. 

  

For the password secure activities, selecting the 

checkbox on the far right enables remote access to the function. 

  

Lockout Time in Minutes is the length of waiting time imposed after 

the selected number of bad password  

  

  



Set Location and Time - used to enter location and time information for dawn and dusk calculations.  Select a 

preprogrammed location nearest to your location on the droplists, choose your zipcode on the droplist, or enter 

your location‘s latitude and longitude.  Verify the time zone, change time zone (if desired) and check whether or 

not to enable Daylight Savings Time.  Click ―OK‖ to enter values. 

  

  

  

  

  

  

Set Operating Modes - Displays dialog box to display 

Operating Modes assigned to the different Operating 

Mode groups. 

  

  

  

  

  

  

  

  

  

  

  

Report All States Requests the controller to report all current input and 

output states for all devices. 

  

Check for Updates - Displays dialog box to select the type of update 

desired.  
  

  

  

  

  

  

  

  

  

  

  

  

  

  

 The Help menu displays the following commands, which provide assistance with this application: 

  

View Tutorials—Displays a list of instructional tutorials to view.  
  

View Installation Guides—Displays a page listing FSD System and 

FSD Controller installation guides and Specification Sheets for FSD 

Controller and Devices.  Click on the link to display the pdf file. 

  

View Configuration Guides—Displays a page listing FSD Controller 

configuration guides.  Click on the link to display the pdf file. 

  

View Reference Manuals—Displays a page listing manuals providing 

help to use FSD Controller software.  Click on the link to display the 

pdf file. 

  

View Example Scenarios—Displays a page listing examples 

providing help to configure specific types of FSD Controller 

operations.  Click on the link to display the pdf file. 

  



View Product Specifications—Displays a page listing manuals providing product specifications for FSD and 

FGI automation products.  Click on the link to display the pdf file. 

  

Help Topics—Offers an index to Help topics for FSD Automator. 

  

About FSD Automator—Displays the version number of this application. 

  

Toolbar 

  

  

  

 Folder icon   Open an existing document.  FSD Automator displays the Open dialog box, where you can locate 

and open the desired file. 

  

Disk icon   Save the active document or template with its current name.  Use this command to save the active 

system data set to its current name and directory.  When you save a data set for the first time, FSD Automator 

displays the Save As dialog box so you can name your data set.  If you want to change the name and directory of 

an existing data set before you save it, choose the Save As command. 

  

Printer icon   Print the active document.  Invokes dialog to select print listings of device on the system, device 

wiring tree configuration, and supported FSD device types. 

  

―D‖ button   Select and activate a device display-monitoring and configuration window. 

  

―R‖ button   Request the controller to report current states for all devices on the system.  The Monitor Report All 

States command sends a command to the controller requesting a report of current values for all input and output 

states for devices on the system. 

  

The Monitor Device command is active only when the FSD Controller reporting state has been initialized. 

  

―A‖ button   Select FSD Automator options.  Use this command to select TCP/IP socket options and debug 

options. 

  

TCP/IP address -- choose the appropriate radio button that corresponds to your situation: 

 Local Machine only 

 Use Address From Directory to identify computer hosting the FSD Router application. 

 Use LAN IP Address—enter the IP address of computer hosting the FSD Router application. 

 Use Internet IP Address—enter the address of the computer hosting the FSD Router application.  If using 

FSD Loader on the same computer as FSD Router, set the TCP/IP address to its default local host value, 

127.0.0.1. 

  

Router IP Port – port used to connect and communicate with FSD Router and its connected serial port 

devices.  Note that the specified port must match the port specified in the FSD Router application.  For 

access via a firewall protected link, the specified port must have access permission. 

  

FSD Automator Watch Level—select the quantity of debug information presented on the FSD Automator view 

window.  Watch Level 0 disables most output, with increasing levels displaying more detailed debugging 

information. 

  

FSD Controller Watch Level—select the quantity of debug information to be sent from a connected FSD 

Controller.  The FSD Controller debug information will be presented on the FSD Automator view window.  

Watch Level 0 disables most output, with increasing levels displaying more detailed debugging information. 

  

Enable Debug File – select to log all view window tests, plus other information to DEBUG.TXT in the 

computer‘s F_TEMP or TEMP directory, which is set in the computer‘s environment variables. 

  

Enable Debug Crash – writes the debug output to the file after each entry, to ensure completed writes in the 

event the application crashes. 

  

Create New Debug File – Starts a new file when FSD Automator starts (otherwise debug information is 

appended to the previous file). 

  



―O‖ button   Select a device to activate a display-to configure device elements with operations. 

  

  

  



FSD Viewer 
  

  

FSD Viewer Overview 
  

In FSD Designer floor layouts and buildings can be designed and devices positioned in the constructed layout.  Use 

FSD Viewer to display the layouts. 

  

The user can configure FSD Autostart so that FSD Viewer is started by FSD Autostart and opens the last floor 

layout displayed.  If opening FSD Viewer directly, choose the .fvg file containing the desired floor layout. 

  

FSD Viewer Menu 
  

Right-click on the title bar to display the following menu items: 

  

Restore – when the window is minimized, the Restore command is active and when clicked will restore the 

minimized window onto the screen. 

  

Move – will allow the device dialog to be moved on screen. 

  

Minimize – will remove the window from the desktop, and minimized to the windows taskbar. 

  

Close – exits the application. 

  

Open Building – displays the Open dialog to choose a .fvg file to open. 

  

Edit Layout View – Opens the layout portion of the designer application to edit the opened layout (see FSD 

Designer). 

  

Load Confirmation – calls FSD Builder to build the image to load the changed configuration into the controller. 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

View Tutorials and Guides - opens a htm document that displays links to View Tutorials, View Installation Guides, 

View Configuration Guides, and View Reference Manuals.   

  

View FSD Designer – opens the application FSD Automator. 

  

View FSD Automator – brings FSD Automator into view. 



  

Check For Updates - starts FSD Upclient to check for FSD Controller software updates 

  

About FSD - Viewer displays information about the application‘s version. 

  

Help Topics - displays the Help Index for FSD Viewer.  
  

  

  

FSD Viewer 
  

Double-click on one of the layouts displayed in the FSD Viewer window to enlarge the layout.   

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



Double-click on a room to enlarge further.  If in the above figure, Zoom to Expand is chosen, the enlarged room 

display replaces the floor layout window.  Right-click on the title bar and choose Cancel Zoom in the menu to return 

to the floor layout.  In contrast, if Zoom to Expand is NOT selected, double-clicking on the room will enlarge it and 

the window displaying the floor layout is also displayed on the screen. 

Both enlarged layouts have similar menu (right-click title bar to display).  Choosing Edit Layout View displays the 

layout in FSD Designer to edit room or placement of devices, appliances, and furniture (see manual for FSD 

Designer). 

  

 

  

 

 

  

  

  

 

  

  

 

 

  

  



FSD Logger 
  

FSD Logger Overview 
FSD Logger records conversation in text file between controller and devices.  The user can set the level of detail 

recorded as desired.  One can choose among different debug file options. 

  

  

FSD Logger 
  

File Menu 

The File menu offers the following commands: 

  

  

Open Opens an existing system data set. 

Import Data Imports the application‘s Registry data from a file. 

Export Data Exports the application‘s Registry data to a file. 

Print Prints a system data set. 

Print Preview Displays the data set on the screen as it would appear printed. 

Print Setup Selects a printer and printer connection. 

Exit  Exits FSD Logger. 

  

View Menu 

The View menu offers the following commands: 

  

Toolbar Shows or hides the toolbar. 

  

Toolbar components: 

Folder icon Open an existing data set.  FSD Lister displays the Open dialog box, in which you can locate and 

open the desired file. 

  

Printer icon Print the active document. 

  

―D‖ button The Define Log File Properties command is used to define all log file instances for the FSD 

Logger application.  Within each log file instance definition, multiple device filters may be defined. 

  

―S‖ button The Enable Startup Logs command enables or disables all log files selected to be active at FSD 

Logger application start-up. 

  

―A‖ button The Enable All Logs command enables or disables all defined log files. 

  

―E‖ button The Extract Binary Log Files command extracts a binary log file to a text file. 

  

Status Bar Shows or hides the status bar. 

  

  

  

  

  

  

  

  

  

  

  

  

Log Menu 

The Log menu offers the following commands: 

  

Define Log File Properties  Displays Logger windows for all devices. 

Displays dialog to select log file. 

 FSD Logger 



  

FSD Logger Overview 
FSD Logger records conversation in text file between controller and devices.  The user can set the level of detail 

recorded as desired.  One can choose among different debug file options. 

  

  

FSD Logger 
  

File Menu 

The File menu offers the following commands: 

  

  

Open Opens an existing system data set. 

Import Data Imports the application‘s Registry data from a file. 

Export Data Exports the application‘s Registry data to a file. 

Print Prints a system data set. 

Print Preview Displays the data set on the screen as it would appear printed. 

Print Setup Selects a printer and printer connection. 

Exit  Exits FSD Logger. 

  

View Menu 

The View menu offers the following commands: 

  

Toolbar Shows or hides the toolbar. 

  

Toolbar components: 

Folder icon Open an existing data set.  FSD Lister displays the Open dialog box, in which you can locate and 

open the desired file. 

  

Printer icon Print the active document. 

  

―D‖ button The Define Log File Properties command is used to define all log file instances for the FSD 

Logger application.  Within each log file instance definition, multiple device filters may be defined. 

  

―S‖ button The Enable Startup Logs command enables or disables all log files selected to be active at FSD 

Logger application start-up. 

  

―A‖ button The Enable All Logs command enables or disables all defined log files. 

  

―E‖ button The Extract Binary Log Files command extracts a binary log file to a text file. 

  

Status Bar Shows or hides the status bar. 

  

  

  

  

  

  

  

 Log Menu 

The Log menu offers the following commands: 

  

Define Log File Properties   Displays Logger 

windows for all devices. 

Displays dialog to select log file. 

  

  

  

  

   Add log file definitions button displays Log File Definition dialog.  User can specify the files name, a brief 

description and set operational parameters for logging, including checkboxes to enable log file, enable log file at 

startup, and create backup file.  One can specify the log duration: daily, weekly, monthly and set the maximum 



log file size: 256, 512, 1024, 2048, or 4096K.  The format for the log file can be set as binary or as comma 

delimited.  The user can set filter options.   

  

Clicking Add filter definition displays the Edit Filter Options dialog.  The filter name can be assigned, a checkbox 

toggles enabling of the filter.  The devices to log can be set.  Either select all devices or select specific devices by 

using the droplist for device types and droplist for device name.  In the Select Elements to Log section, check the 

elements to be logged.  One can set to log all reports, to set an interval for logging (1, 5, 10, 15, 20, 25, 30, 60, 

300 sec.), or to log changes only. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Enable Startup Logs  Enables / Disables Log files selected to be enabled at FSD Logger application start-up. 

  

Enable All Logs  Enables / Disables all defined Log files. 

  

Extract Binary Log File  Extracts a binary log file to a text file. 

  

Options Menu 

  

Set Logger Options Selects Logger communications and watch 

options 

  

TCP/IP address -- choose the appropriate radio button that corresponds 

to your situation:  
  Local Machine only 

 Use Address From Directory to identify computer hosting the FSD 

Router application. 

  Use LAN IP Address—enter the IP address of computer hosting 

the FSD Router application. 

 Use Internet IP Address—enter the address of the machine hosting 

the FSD Router application.  If using FSD Loader on the same 

machine as FSD Router, set the TCP/IP address to its default local 

host value, 127.0.0.1. 

  

Router IP Port is the port to be used to connect to and communicate 

with FSD Router and its connected serial port devices.  Note that the specified port must match that 

selected within the FSD Router application, and for access via a firewall protected link the specified port 

must be given access permission. 

  

FSD Logger Watch Level selects the quantity of debug information presented on the FSD Logger view window.  



Watch Level 0 disables most output, with increasing levels used to show more detailed debugging 

information. 

  

Enable Debug File – All view window test, plus other information will be logged in DEBUG.TXT in the 

computer‘s TEMP directory, as set in the computer‘s environment variables. 

  

Enable Debug Crash – flushes the debug output to the file after each write, to ensure completed writes while 

debugging application crash conditions. 

  

Create New Debug File – Starts a new file upon FSD Logger startup (else debug information is appended to the 

previous file). 

  

  

Help Menu 

The Help menu offers the following commands, which provide you assistance with this application: 

  

  

Help Topics Offers you an index to topics on which you can get help. 

About FSD Logger Displays the version number of this application. 

  

  

For more detailed instructions on using FSD Logger, in FSD Automator, from the Help menu choose ―View 

Configuration Guide‖.  In the displayed list select ―FSD Logger Configuration Guide‖. 

  

Add log file definitions button displays Log File Definition dialog.  User can specify the files name, a brief 

description and set operational parameters for logging, including checkboxes to enable log file, enable log file at 

startup, and create backup file.  One can specify the log duration: daily, weekly, monthly and set the maximum 

log file size: 256, 512, 1024, 2048, or 4096K.  The format for the log file can be set as binary or as comma 

delimited.  The user can set filter options.   

  

Clicking Add filter definition displays the Edit Filter Options dialog.  The filter name can be assigned, a checkbox 

toggles enabling of the filter.  The devices to log can be set.  Either select all devices or select specific devices by 

using the droplist for device types and droplist for device name.  In the Select Elements to Log section, check the 

elements to be logged.  One can set to log all reports, to set an interval for logging (1, 5, 10, 15, 20, 25, 30, 60, 

300 sec.), or to log changes only. 

  

Enable Startup Logs  Enables / Disables Log files selected to be enabled at FSD Logger application start-up. 

  

Enable All Logs  Enables / Disables all defined Log files. 

  

Extract Binary Log File  Extracts a binary log file to a text file. 

  

Options Menu 

  

Set Logger Options Selects Logger communications and watch options 

  

TCP/IP address -- choose the appropriate radio button that corresponds to your situation: 

  Local Machine only 

 Use Address From Directory to identify computer hosting the FSD Router application. 

  Use LAN IP Address—enter the IP address of computer hosting the FSD Router application. 

 Use Internet IP Address—enter the address of the machine hosting the FSD Router application.  If using FSD 

Loader on the same machine as FSD Router, set the TCP/IP address to its default local host value, 

127.0.0.1. 

  

Router IP Port is the port to be used to connect to and communicate with FSD Router and its connected serial 

port devices.  Note that the specified port must match that selected within the FSD Router application, and 

for access via a firewall protected link the specified port must be given access permission. 

  

FSD Logger Watch Level selects the quantity of debug information presented on the FSD Logger view window.  

Watch Level 0 disables most output, with increasing levels used to show more detailed debugging 

information. 

  



Enable Debug File – All view window test, plus other information will be logged in DEBUG.TXT in the 

computer‘s TEMP directory, as set in the computer‘s environment variables. 

  

Enable Debug Crash – flushes the debug output to the file after each write, to ensure completed writes while 

debugging application crash conditions. 

  

Create New Debug File – Starts a new file upon FSD Logger startup (else debug information is appended to the 

previous file). 

  

  

Help Menu 

The Help menu offers the following commands, which provide you assistance with this application: 

  

  

Help Topics Offers you an index to topics on which you can get help. 

About FSD Logger Displays the version number of this application. 

  

  

For more detailed instructions on using FSD Logger, in FSD Automator, from the Help menu choose ―View 

Configuration Guide‖.  In the displayed list select ―FSD Logger Configuration Guide‖. 

  

  



FSD Upclient 
 

FSD Upclient Overview  
With FSD Upclient the user can update FSD Controller software via the 

internet.  Upon opening, the application displays a select update dialog.  

Select the update type that corresponds to your situation. 

   

  

  

  

   

FSD Upclient Menu Layout 

File Menu 
  

Use either the Exit command or the Close command on the application Control menu to end the FSD Update 

Client session.  FSD Update Client prompts you to save documents with unsaved changes. 

  

  

View Menu 
  

The toolbar is displayed across the top of the application window, below the menu bar.  The toolbar provides 

quick mouse access to many tools used in FSD Update Client, 

  

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T). 

  

Click To 
―L‖ button Loads a FSD formatted file to the controller or attached FSD device. 

  

―O‖ button Offloads log data from a device, clearing the device data log. 

  

―A‖ button Attaches a J1708 device and switches to FSD packet mode. 

  

―D‖ button Detaches a previously attached device and switches to native mode. 

  

  

The status bar is displayed at the bottom of the FSD Update Client window.  To display or hide the status bar, use 

the Status Bar command in the View menu. 

  

The left area of the status bar describes how menu items act, as the arrow keys navigate through the menus.  This 

area also shows messages that describe the actions of toolbar buttons they are depressed, before releasing them.  If 

you decide not to execute the command, release the mouse button when not pointing to the toolbar button. 

  

The right areas of the status bar indicate which of the following keys are latched down: 

  

Indicator Description 
CAP  The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

  

  



 Options Menu 
Set Upclient Options 

  

Update Server Port – use this port to connect to and 

communicate with FSD Router and its connected serial port 

devices.  Note that the specified port must match the port 

selected in the FSD Router application.  For access via a 

firewall protected link, the specified port must be given access 

permission. 

  

Primary Server Address -- The address of the machine hosting 

the FSD Router application.  If using FSD Update Client on 

the same machine as FSD Router, set the TCP/IP address to its 

default local host value, 127.0.0.1. 

  

FSD Update Client Watch Level -- selects the quantity of 

debug information presented on the FSD Update Client view 

window.  Watch Level 0 displays the least amount of 

information, with increasing levels showing more detailed debugging information. 

  

Debug Options 

Enable Debug File -- All view window test and other information are logged in DEBUG.TXT, found in the 

computer‘s TEMP directory.  These directories are set in the computer‘s environment variables. 

  

Enable Debug Crash -- flushes the debug output to the file after each write.  This action ensures completed writes 

while debugging application crash conditions. 

  

Create New Debug File -- Starts a new file upon FSD Loader startup (otherwise debug information is appended to 

the previous file). 

  

  

Help Menu 
The Help menu offers the following commands, which provides assistance with this application: 

  

Help Topics Use this command to display the opening screen of Help. From the opening screen, you can jump 

to step-by-step instructions for using Update Client and various types of reference information. 

  

After Help opens, click the Contents button to return to the opening screen. 

  

About FSD Upclient Displays copyright notice and the version number of this application. 

  

  



FSD Router 

 
Overview FSD Router 

FSD Router is a server application to route communications among serial ports and TCP/IP addresses. 

FSD Router Menu Layout 

File Menu 
  

Use either the Exit command or the Close command on the application Control menu to end the FSD Router 

session.  FSD Router prompts you to save documents with unsaved changes. 

  

  

View Menu 
  

The toolbar is displayed across the top of the application window, below the menu bar.  The toolbar provides 

quick mouse access to many tools used in FSD Router, 

  

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T). 

  

Click To 
―C‖ button Displays dialog to set port settings. 

  

―S‖ button Displays dialog to set router options. 

  

―P‖ button Displays dialog to set password options. 

  

―Red Octagon‖ button   Stops sending all packets. 

  

Options Menu 
  

The Options menu provides choices to set options for serial ports, router, and access.  
  

  

  

  

Set Serial Port Options  
  

Set the Comm Port to the port assigned to connect the controller with the 

FSD Router.  Selecting the Auto Search checkbox allows FSD Router to 

determine the assigned Comm Port. 

  

Manually, one can select a Comm port COM1 – COM16, Parity enforcement, 

Number of Stop Bits, and number of Stop Bits to use.  Also select the baud 

rate for the port. 

  

Select Full Duplex for normal RS-232, RS-422, or RS-423 operation.  

Deselect Full Duplex for Half-Duplex operation, if FSD Router is used with 

an RS-485 or J1708 type port adapter, which connects the transmit 

and receive lines.  For use with RS-485 adapters, which use the RTS 

signal to enable transmit, select the RTS TX Enable option. 

  

For RS-232 use with hardware handshaking lines, select the Use 

DTR/DSR or Use CTS/RTS option. 

  

  

Set Router Options 

  

Use this command to select TCP/IP socket options and debug 

options. 

  

Show TCP/IP Address -- Click the button to display the computer‘s 



ip configuration information and TCP/IP address. 

  

Router Port – use this port to connect to and communicate with other FSD applications (e.g. FSD Loader).  Note 

that the specified port must match the port selected in other FSD applications.  For access via a firewall 

protected link, the specified port must be given access permission.  Note that since FSD Router is a TCP/IP 

server application, specifying the TCP/IP address in the FSD Router application setup is not required.  For 

connecting to FSD Router from an application running on the same machine, the local access TCP/IP address 

127.0.0.1 can be used.  For accessing FSD Router from another machine on the network or via the Internet, use 

the host machine‘s TCP/IP address. 

  

  

FSD Packet ID -- This value times 0x100 is added to 0x02000000 to construct the base ID value used in packets 

sent from FSD Router.  The connection index reported from FSD Router is added to this value to create the 

SOURCE_ID value for the packets. 

  

Remote Synch Port -- is the port assigned to communicate with FSD software running on a computer at a 

remote location. 

  

Time Synch Source -- when selected, will send the time on the computer clock to the FSD controller. 

  

Watch Level -- selects the quantity of debug information presented on the FSD Loader view window.  Watch 

Watch Level 0 shows the minimum amount of output, Watch Level 1 shows packet types being sent in each 

direction to and from the serial port, Watch Level 2 also shows the first several bytes of each packet sent, and 

Watch Level 3 shows more detailed debugging information. 

  

  

Enable Debug File -- All view window test and other information are logged in DEBUG.TXT, found in the 

computer‘s TEMP directory.  These directories are set in the computer‘s environment variables. 

  

Enable Debug Crash -- flushes the debug output to the file after each write.  This action ensures completed 

writes while debugging application crash conditions. 

  

Create New Debug File -- Starts a new file upon FSD Loader startup (otherwise debug information is appended 

to the previous file). 

  

Allow CSUM Packets -- allows reception of packets appended with a 16 bit checksum instead of a 16 bit CRC 

value from devices connected to the serial port.  Packets arriving via a TCP/IP connection, and all transmitted 

packets will still use CRC validation. 

  

Check Validity – Applies internal packet CRC checking to packets in transit.  Otherwise packets will be trusted.  

Packets arriving through the serial port are always checked. 

  

Check Packet Size – enforces internally specified parameters on packet sizes based on packet type.  This 

enables FSD Router to discard invalid packets.  May be disabled by the installer during application 

development to relax constraints.  Packet type validity and maximum packet size will be enforced in either case. 

  

Auto Response – automatically returns an acknowledge status packet to the sender of any packet containing the 

BROADCAST_DESTINATION_ID 

(0xFFFFFFFF). 

  

Access Options  

  

Choose the access type to set password 

security for Router, Host, LAN, or Internet 

access. 

  

Security Level – select NONE to disable 

password protection or ENABLED to require 

password protected access from applications 

connecting to FSD Router via TCP/IP 

connections.  The four password secure 

activities are: Monitoring, Control, 



Configuration, and for some instances Installer. 

  

Password – 32 character maximum, case sensitive.  Specify the password which must be sent from a connection 

application to gain access to a FSD Router connection. 

  

For the password secure activities, selecting the checkbox on the far right enables remote access to the function. 

  

Lockout Time in Minutes is the length of waiting time imposed after the selected number of bad password 

attempts, before FSD Router will accept password protected logon attempts from any connecting application.  

This feature discourages use of automatic password generators and other trial-and-error password entry efforts. 

  

Attempts is the number of incorrect passwords that connecting applications can make before the Lockout Time 

is imposed.  Note that this is the total logon attempts from all applications, not just from a single application. 

  

Controller Name ID -- displays the unique identifier for the controller on the system. 

  

Depending on the access type selected, check boxes are active to indicate that TCP/IP address is STATIC or to 

Disable Directory Service. 

  

  

Stop All Packets -- to cease transmission of packets. 

Status Bar 
  

The status bar is displayed at the bottom of the FSD Router window.  To display or hide the status bar, use the 

Status Bar command in the View menu. 

  

The left area of the status bar describes how menu items act, as the arrow keys navigate through the menus.  This 

area also shows messages that describe the actions of toolbar buttons they are depressed, before releasing them.  If 

you decide not to execute the command, release the mouse button when not pointing to the toolbar button. 

  

The right areas of the status bar indicate which of the following keys are latched down: 

  

Indicator Description 
CAP The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

  

  

  

Help Menu 
  

The Help menu offers the following commands, which provides assistance with this application: 

  

Help Topics Use this command to display the opening screen of Help. From the opening screen, you can jump 

to step-by-step instructions for using Router and various types of reference information. 

  

After Help opens, click the Contents button to return to the opening screen. 

  

About FSD Router Displays copyright notice and the version number of this application. 
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Alarm 
  

Device Types in family 
  

Device Family           

Timer Alarm Timer         

 

Device Type Description 

 

Alarm Timer 

Use this timer‘s dialog to set the properties to 

send an alarm notification with the 

specifications to send a second or third alarm 

notification, if desired.   

  

Device Dialog Box 

The device dialog displays the various alarm 

states.  A checked checkbox reports whether the 

alarm is triggered, or if the first, second, or third 

notification has occurred (Alarm, Second, 

Third).  Buttons are available to trigger the alarm, to enable the alarm, or to deactivate the alarm.  

  

  

Right-clicking on the title bar displays a menu list, including commands to configure 

the Alarm Timer. 

  Configure Display - Use this 

command to choose the picture used 

on the device dialog.  In the 

―Configure Display‖ dialog that 

appears, click ―Browse‖ to select the 

picture to be shown on the device 

dialog.  Click the ―Open‖ button to 

implement the selection.  In the 

―Configure Display‖ dialog apply the settings to either  

t

h

e

 

specific device, the device type, or the 

devices in the group.  Click ―OK‖. 

  

  

 Configure Alarm Timer - In the upper 

section, select how the alarm will 

behave.  One can set either in seconds or 

minutes the delay to trigger the alarm, 

how long the alarm lasts, and the delay 

to send the subsequent alarm notification 

(second or third alarms).  Use the 

following sections to configure and 

enable the input and operating modes; 

how the alarm is armed, notification 

options; enter text to send during 

notification , and to set a pass code to 

disarm or cancel the alarm.  Click the 

―Define Pass Code‖ to enter a pass code.  

Reenter the pass code for verification.  

Click ―OK‖ to store pass code.  Clicking 



the ―Reporting Options‖ button displays the Configure Device dialog (see below).  Click ―OK‖ to 

finalize selections. 

  

   

 Configure Device - Use the following 

sections to configure the reporting for 

either the Input or Output Settings.  If 

reporting when changes occur is desired, 

choose ―Report Changes‖.  Check the box 

for ―Report Periodically‖ and select the 

interval for periodic reporting from the 

droplist.  These settings can be applied to 

either the specific device, the device type, 

or the devices in the group.  Click ―OK‖ 

to finalize selections. 

  

  

  

  

  

  

  

  

 Configure Operations - Select this command 

to display a dialog to configure the device elements for the operation desired for the device.  

Double click on the device name to display the ―Device Element Operation‖ dialog or click the 

―Add‖ button to add an operation.  A detailed discussion on configuring device element operations 

is found in ―FSD Operation Configuration Guide‖. 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Other commands control the placement and size of the dialog box and a command to close the dialog.  

Selections on the menu lead to presentation of Help Topics, information about the Alarm Timer 

device, and software version information for the Alarm Timer.   

  

  

  

  



Alarm Clock 
  

Device Types in family 

  
 

  

  

  

  

  

Device Type Description 

  

Alarm Clock 

Use this device dialog to use the controller as an alarm clock.  Set the time to trigger the alarm, the 

duration of the alarm, and whether or not there are two different controlled events triggered.  These 

two events are based on the alarm time.  The user can also set the duration of the snooze period. 

  

Device Dialog Box  
The device dialog displays the 

various alarm states..  Reported is 

whether the alarm is triggered, if 

the first, second, or third 

controlled event has occurred 

(Alarm, Second, Third) and 

buttons to trigger the alarm or 

enable the alarm.  There is a 

button to implement a Snooze 

reset of alarm and another button 

to deactivate the alarm.  

  

 Right-clicking on the title bar displays a menu list, including 

commands to configure the Alarm Timer. 

  
 

  

  

  

  

 

 

 

  

 Configure Display - Use this command to choose the 

picture used on the device dialog.  In the 

―Configure Display‖ dialog that appears, click 

―Browse‖ to select the picture to be shown on the 

device dialog.  Click the ―Open‖ button to 

implement the selection.  In the ―Configure 

Display‖ dialog apply the settings to either the 

specific device, the device type, or the devices in 

the group.  Click ―OK‖. 

  

  

  

Device Family           

Timer Alarm Clock         



 

 Configure Alarm Clock - In 

the upper section, the user 

can configure the device to 

activate an alarm for a 

specific clock time value 

or time relative to specific 

sunrise or sunset event 

choose from droplist.  

Relative time offsets are 

relative to midnight (12:00 

AM).  For example, to set 

a trigger time for a few 

minutes before the 

selected Dawn /Dusk time, 

check the ―Relative‖ 

checkbox and set the time 

to 11:xx PM.  Similarly, to 

set a trigger time for a few 

minutes after the selected 

Dawn / Dusk time, set the 

time to 12:xx AM.  In the 

section on ―Enable on 

Days:: choose the 

specified days of the week 

the alarm is enabled.  One 

can further stipulate 

whether the alarm occurs 

on a holiday or special 

days set by the user 

(―Holiday‖, ―Special Day 

1‖, ―Special Day 2‖, or ―Special Day 3‖).  The alarm clock device can be programmed to control 

up to three separate, but sequentially timed actions, connected by operations to the alarm clock 

device‘s ―From‖ elements, with the second and third output times specified relative to the first and 

second alarm clock output.  One can set either in seconds or minutes the delay to trigger the alarm, 

how long the alarm lasts, and the delay to trigger the next controlled events (second or third 

―alarms‖).  Use the following sections to enable the operating modes and how the alarm is armed.  

Clicking the ―Reporting Options‖ button displays the Configure Device dialog (see below).  Click 

―OK‖ to finalize selections. 

  

  

  

  Configure Device - Use the following sections 

to configure the reporting for either the Input or 

Output Settings.  If reporting when changes occur 

is desired, choose ―Report Changes‖.  Check the 

box for ―Report Periodically‖ and select the 

interval for periodic reporting from the droplist.  

These settings can be applied to either the 

specific device, the device type, or the devices in 

the group.  Click ―OK‖ to finalize selections. 

  

  

  

  

  

  

  

  

  

  

  



  

  

  

  

  

 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on configuring device element operations is found in ―FSD Operation Configuration Guide‖. 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Other commands control the placement and size of the dialog box and a command to close the dialog.  

Selections on the menu lead to presentation of Help Topics, information about the Alarm Clock device, 

and software version information for the Alarm Clock.   

  

  

  

  



  



Event Timer 
  

Device Types in family 

  

Device Family           

Timer Event         

 

  

Device Type Description 

  

Time of Day Event 

Use this device timer to instruct the controller to turn on and off a particular light or appliance on the 

system.  The dialog displays whether the event is currently on and reports whether or not the event is 

enabled for the current day.   

  

Device Dialog Box 

The dialog displays whether the event 

is currently on of off (TRUE or 

FALSE) and reports whether or not the 

event is enabled for the current day and 

also if the device is enabled in the 

current operating mode.   

  

  

  

 Right-clicking on the title bar displays a menu list, including 

commands to configure the Alarm Timer. 

  

  

  

  

 Configure Display - Use this command to choose the picture used 

on the device dialog.  In the ―Configure Display‖ dialog that 

appears, click ―Browse‖ to select the picture to be shown on the 

device dialog.  Click the ―Open‖ button to implement the 

selection.  In the ―Configure Display‖ dialog 

apply the settings to either the specific device, 

the device type, or the devices in the group.  

Click ―OK‖. 

  

  

 Configure Alarm Clock - In the upper section, the 

user can configure the device to start and to stop 

an event for a specific clock time value or time 

relative to specific sunrise or sunset event 

choose from droplist.  Relative time offsets are 

relative to midnight (12:00 AM).  For example, 

to set a trigger time for a few minutes before the 

selected Dawn /Dusk time, check the ―Relative‖ checkbox and set the time to 11:?? PM.  

Similarly, to set a trigger time for a few minutes after the selected Dawn / Dusk time, set the time 

to 12:?? AM.  The next section one can program the event timer to turn on and off at random times 

during the time period specified in the start/stop section.  The user can (1) set the probability that 

the event is on at the start time, (2) delay the start or stop time up to a maximal specified time, (3) 

set the range of time for the event to be on, and (4) set the range of time the event is off.   In the 

section on ―Enable on Days:: choose the specified days of the week the event is enabled.  One can 

further stipulate whether the event occurs on a holiday or special days set by the user (―Holiday‖, 

―Special Day 1‖, ―Special Day 2‖, or ―Special Day 3‖).  Set the date range for the event to occur, 

or check ―Always‖.  Use the following sections to enable the operating modes.  Clicking the 



―Reporting Options‖ button displays the Configure Device dialog (see below).  Click ―OK‖ to 

finalize selections. 

  

  

  

  

  

 Configure Device - 

Use the following 

sections to 

configure the 

reporting for either 

the Input or Output 

Settings.  If 

reporting when 

changes occur is 

desired, choose 

―Report Changes‖.  

Check the box for 

―Report 

Periodically‖ and 

select the interval 

for periodic 

reporting from the 

droplist.  These 

settings can be 

applied to either 

the specific device, 

the device type, or 

the devices in the 

group.  Click 

―OK‖ to finalize 

selections. 

  

  

  

  

  

  Configure Operations - Select this command 

to display a dialog to configure the device 

elements for the operation desired for the device.  

Double click on the device name to display the 

―Device Element Operation‖ dialog or click the 

―Add‖ button to add an operation.  A detailed 

discussion on configuring device element 

operations is found in ―FSD Operation 

Configuration Guide‖. 

  

Other commands control the placement and size 

of the dialog box and a command to close the 

dialog.  Selections on the menu lead to 

presentation of Help Topics, information about 

the Event Timer device, and software version 

information for the Event Timer.   

  

  

  

  



Fade Timer 
  

Device Types in family 

  

Device Family           

Timer Fade Timer         

 

  

Device Type Description 

  

Fade Timer  
Use the fade timer to set a device to increase or decrease the output of a device gradually.  For 

instance, a light can be faded to a set level.  If wanted, the level is held for a set time, before changing 

to another set level. 

  

Device Dialog Box 

A Fade Timer allows the 

device to be turned on or off 

in a gradual fashion.  If 

desired a holding level can be 

programmed before the end 

fade level is reached.   

  

Typically one implements a 

slow bright / dim fade 

behavior for a light dimmer 

switch or module, which does not support internal fade time control.   The Fade Timer can also execute 

a gradual change in any other analog control value, such as slowly increasing the target temperature of 

a building heated by a heat pump to avoid triggering its emergency heat function. 

  

When triggered the fade timer device controls the change in power level for the device from a start 

percentage level (0—100%), to a hold level, to an end fade level.  Each of these levels has a specific 

time period assigned. 

  

The Fade Timer display shows the state of the fade timer, the 

different settings, buttons to enable the trigger, set the trigger state, 

and turn the pause time on or off. 

  

Right-clicking on the title bar displays a menu list, including 

commands to configure the Fade Timer. 

  

  

 Configure Display - Use this command to choose the picture used 

on the device dialog.  In the ―Configure Display‖ dialog that 

appears, click ―Browse‖ to select the picture to be shown on the 

device dialog.  Click the ―Open‖ button to 

implement the selection.  In the ―Configure 

Display‖ dialog apply the settings to either the 

specific device, the device type, or the devices in 

the group.  Click ―OK‖. 

  

  

  

  

 



 Configure Device - Check the 

checkboxes to configure the fade 

timer.  Choose Edge (i.e. event) 

Triggered Input when a change in the 

state of input occurs.   In the various 

edit boxes set values (0 - 100) for the 

fade and hold levels and time values 

in minutes or seconds for the fades 

and accumulated time limit.  Use the 

following sections to configure the 

reporting for either the Input or 

Output Settings.  If reporting when 

changes occur is desired, choose 

―Report Changes‖.  Check the box 

for ―Report Periodically‖ and select 

the interval for periodic reporting 

from the droplist.  These settings can 

be applied to either the specific 

device, the device type, or the 

devices in the group.  Click ―OK‖ to 

finalize selections. 

  

  

  

  

  

  

 

  

 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on configuring device element operations is found in ―FSD Operation Configuration Guide‖. 

  

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

Other commands control the placement and size of the dialog box and a command to close the 

dialog.  Selections on the menu lead to presentation of Help Topics, information about the Fade 

Timer device, and software version information for the Fade Timer.   

  

  

  

  



 

Holiday Schedule 
  

Device Types in family  

Device Family           

Timer Holiday 

Schedule 

        

 

 Device Type Description 

  

Holiday Schedule Timer 

Use the Holiday Schedule tool to set timer events that differ from the daily timer events scheduled.  

Holiday and three other special schedules can be configured.  Dialog displays the holiday status for the 

current day. 

  

Device Dialog Box 

The Holiday Schedule timer 

device allows the user to 

control devices based on date 

designations.  Using the 

Holiday Schedule device 

dialog box the user can 

schedule special dates.  One 

can configure multiple 

Holiday Schedule devices 

onto the system, for example 

a separate Holiday Schedule 

for Holidays and a schedules 

for each category of Special 

Days. 

  

  

To assign a date to be a holiday or special event, 

click the ―Insert‖ button on a Holiday Schedule 

device dialog.  An Edit Holiday dialog box appears.  

Set the start and stop date for the time period, ensure 

that the Enable Date checkbox is selected, enter a 

name for the event, and select the check boxes to 

designate this event as annual and as Holiday, 

Special Day 1, Special Day 2, and/or Special Day 3.  

Other configurable conditions are cancellation of all 

scheduled events for the specified time period, or disabling all alarm clocks on those days.  Click 

―OK‖ and the entered event is displayed in the list box.  Double clicking on a listed event allows 

editing of event.  To delete the event, select the event and click the ―Delete‖ button. 

  

To assign the current date as a special event click the ―Today is Special‖ 

button.  Note: if current date is already assigned and enabled as a special 

date, the button states ―Today is NOT Special‖.  Clicking this button 

displays the event assigned with the ―Today is Special‖ button. 

  

Similarly, to assign tomorrow‘s date as a special event, click the 

―Tomorrow is Special‖ button 

  

  

Right-clicking on the title bar displays a menu list, including commands 

to configure the Holiday Schedule. 

  

  

  



  

  

 Configure Display - Use this command to choose the 

picture used on the device dialog.  In the 

―Configure Display‖ dialog that appears, click 

―Browse‖ to select the picture to be shown on the 

device dialog.  Click the ―Open‖ button to 

implement the selection.  In the ―Configure 

Display‖ dialog apply the settings to either the 

specific device, the device type, or the devices in 

the group.  Click ―OK‖. 

  

  

  

 Configure Device - Use the 

following sections to configure 

reporting of the output settings 

by reporting changes and/or 

reporting periodically.  Choose 

the Output Interval in seconds 

from the droplist.   

  

  

  

  

  

  

 Configure Operations - 

Select this command to 

display a dialog to 

configure the device 

elements for the 

operation desired for 

the device.  Double 

click on the device 

name to display the 

―Device Element 

Operation‖ dialog or 

click the ―Add‖ button 

to add an operation.  A 

detailed discussion on 

configuring device 

element operations is 

found in ―FSD 

Operation Configuration Guide‖. 

  

  

  

Other commands control the placement and size of the dialog box and a command to close the dialog.  

Selections on the menu lead to presentation of Help Topics, information about the Holiday Schedule 

Timer device, and software version information for the Holiday Schedule Timer.   

  

  



  

Operation 
  

Device Types in family  

Device Family           

Timer Operating Mode         

 

 Device Type Description 

  

Operating Mode 

Use this device to activate or deactivate operating modes configured in the FSD Controller.  

  

Device Dialog Box  
The Operating Mode dialog listbox displays the 

operating mode that are enabled on the system 

(defined in FSD Namer).  Shown are the different 

group numbers and the operating modes 

associated with the group.  Double-clicking on 

one of the lines activates or deactivates the 

operating mode.  

  

  

  

  

  

Right-clicking on the title bar displays a menu list, including commands to 

configure the Operating Mode device. 

  

  

  

  

  

  

  





 Configure Display - Use this command to choose the picture used 

on the device dialog.  In the ―Configure Display‖ dialog that 

appears, click ―Browse‖ to select the picture to be shown on the 

device dialog.  Click the ―Open‖ button to implement the 

selection.  In the ―Configure Display‖ dialog apply the settings 

to either the specific device, the device type, or the devices in 

the group.  Click ―OK‖. 

  

  

  



 

  

 Configure Device - This dialog displays 

a list of modes (A - H).  For each of 

these modes select a group and 

opearating mode from the droplist.  

The following section configures 

reporting for Output Settings.  If 

reporting when changes occur is 

desired, choose ―Report Changes‖.  

Check the box for ―Report 

Periodically‖ and select the interval 

for periodic reporting from the 

droplist.  apply the settings to either 

the specific device, the device type, or 

the devices in the group.  Click ―OK‖ 

to finalize selections.  
  

  

  

  

  

  

  

  

  

 Configure Operations - Select this 

command to display a dialog to 

configure the device elements for the 

operation desired for the device.  

Double click on the device name to 

display the ―Device Element 

Operation‖ dialog or 

click the ―Add‖ 

button to add an 

operation.  A 

detailed discussion 

on configuring 

device element 

operations is found 

in ―FSD Operation 

Configuration 

Guide‖. 

  

  

  

 

 

 

 

 

 

 

Other commands control the placement and size of the dialog box and a command to close the 

dialog.  Selections on the menu lead to presentation of Help Topics, information about the 

Operating Mode device, and software version information for the Operating Mode device.   

  

  

  

  



Button Controller 
  

Device Types in family 

Device Family           

Timer 8 Button 

Control 

16 Button 

Control 

      

  

Device Type Description 

  

8 Button Control 

Use this nontime based timer to assign eight buttons to take input from other devices and or the buttons 

be programmed to run ―Scenes‖ for lighting, to run macros, or do simple switching to control X10 and 

FGI devices on the system.   

  

16 Button Control 

Same as the 8 Button Control, but with 16 buttons. 

  

Device Dialog Box 

8-Button Control and 16-Button Control device types can transcribe 

input from other devices and in return send out programmed X10, UPB, 

or other protocol commands to mediate control of target devices.  For 

example, a Button Control device could be configured to send X10 

extended commands to set ―Scenes‖ in response to inputs from a 

hardwired switch or a low cost X10 switch console.  ―Buttons‖ on 

button control devices can also be configured to invoke direct macros in 

response to devices setting ―To‖ element values.   

  

Each button can be configured as a momentary, push-ON push-OFF 

operation, or as button pairs where one button sets an ON state and the 

other sets an OFF state.  ON and OFF responses may also be 

independently configured. 

  

The two button control device types are identical, except for the maximum 

number of buttons controlled.   

  

  

Right-clicking on the title bar displays a menu list, including commands to 

configure the Retriggerable Timer. 

  

  

 Configure Display - Use this command to choose the picture used on the device dialog.  In 

the ―Configure Display‖ dialog that appears, click ―Browse‖ to select the picture to be 

shown on the device dialog.  Click the ―Open‖ button to implement the selection.  The listbox displays the 8 or 16 

buttons and whether the button is enabled, configured as a pair of buttons, or configured as a push on/off button, and 

the label name of the button.  Double-clicking on the number in the listbox displays the edit button info box.  In this 

box configure the button as part of an on/off pair or as puh on/off.  Assign a label for the button and also a label used 

in the off state.  

  

  

  

  

  

  

  

  

  

  



  

  

  

  Configure Device - This dialog displays a listbox of 

the buttons in the control showing the type of button, 

label, type and name associated with its type.  Double-

clicking on a button‘s entry opens the Edit <device> 

Button Info dialog.  The specific display depends on 

the button type.  Shown are button info dialogs for X10 

and Scene.  Choose the appropriate button type from 

the ―Button Type‖ droplist.  For the X10 button type, 

the user sets the X10 Controller and the type of X10 

variant.  Set the house and unit code, the ON and OFF 

command from the droplist.  If an extended command 

is chosen, then contimue to select the extended 

command type and extended command function from 

the droplist.  For Scene or Macro button type, select the 

scene or macro to associate with the button.  The 

following section configures reporting for Output 

Settings.  If reporting when changes occur is desired, 

choose ―Report Changes‖.  Check the box for ―Report 

Periodically‖ and select the interval for periodic 

reporting from the droplist.  Click ―OK‖ to finalize selections. 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  Configure Operations - Select this command to display a dialog 

to configure the device elements for the operation desired for the 

device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the 

―Add‖ button to add an operation.  A 

detailed discussion on configuring device 

element operations is found in ―FSD 

Operation Configuration Guide‖. 

  

Other commands control the 

placement and size of the dialog 

box and a command to close the 

dialog.  Selections on the menu 

lead to presentation of Help 

Topics, information about the 

Button Control device, and 

software version information for 

the Button Control device.   

  

  

  



Delay Timer 
  

Device Types in family 

Device Family           

Timer Delay Timer 

(Boolean) 

Delay Timer 

(Byte) 

      

 

 Device Type Description 

  

Delay Timer 

Use this device to impose a delay in 

output following an input.  

  

Device Dialog Box 

There are two types of delay timers, byte and 

boolean.  Shown in the figure on the right is 

the byte type.  Input and output states are 

displayed as values from 0 to 255.  For the Boolean type, values displayed are either 

True or False.   

  

  

Right-clicking on the title bar displays a menu list, including commands to configure 

the Delay Timer device. 

  

  

 Configure Display - Use this command to choose the picture used on 

the device dialog.  In the ―Configure Display‖ dialog that appears, click 

―Browse‖ to select the picture to be shown on the device dialog.  Click 

the ―Open‖ button to implement the selection.  In the ―Configure 

Display‖ dialog apply the settings to either the specific device, the 

device type, or the devices in the group.  Click ―OK‖. 

  

  

  

 Configure Device - This dialog 

displays a list of Outputs.  Each 

output has a droplist to select a step.  

For the steps programmed, a delay 

time can be set in Milliseconds or 

Seconds.  The following section 

configures reporting for Input and 

Output Settings.  If reporting when 

changes occur is desired, choose 

―Report Changes‖.  Check the box 

for ―Report Periodically‖ and select 

the interval for periodic reporting 

from the droplist.  apply the settings 

to either the specific device, the 

device type, or the devices in the 

group.  Click ―OK‖ to finalize 

selections. 

  

  

  

  

  









 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on configuring device element operations is found in ―FSD Operation Configuration Guide‖. 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Other commands control the placement and size of the dialog box and a command to close the 

dialog.  Selections on the menu lead to presentation of Help Topics, information about the Delay 

Timer device, and software version information for the Delay Timer device.   

  

  

  

  



Retriggerable Timer 
  

Device Types in family 

  

Device Family           

Timer Retriggerable 

Timer 

        

 

  

Device Type Description 

  

Retriggerable Timer 

Use the retriggerable timer to set a device to repeatedly trigger an event.  The user can specify a period 

of delay after the trigger, the time the device is active, and the time the device is inactive.   

  

Device Dialog Box 

A Retriggerable Timer allows a 

device to be repeatedly triggered.  

If desired a delay period after 

trigger can be programmed.  The 

length of time the device is active 

is specified, along with the period 

of inactivity between active 

periods.   

  

When the Trigger Enabled is 

toggled to TRUE, a trigger input starts the timer for the specified interval.  

The remaining time in the period (for delay, on, or refractory period) is 

displayed.  If the Pause Time is toggled to TRUE, then the timed interval 

control of the device is disabled 

  

Right-clicking on the title bar displays a menu list, including commands to 

configure the Fade Timer. 

  

  

  

  

  

   Configure Display - Use this command to choose the picture 

used on the device dialog.  In the ―Configure Display‖ dialog 

that appears, click ―Browse‖ to select the picture to be shown on 

the device dialog.  Click the ―Open‖ button to implement the 

selection.  In the ―Configure Display‖ dialog apply the settings 

to either the specific device, the device type, or the devices in 

the group.  Click ―OK‖. 

  

  

  



 

  

  

 Configure Device - Check the checkboxes to 

configure the retriggerable timer.  Choose 

Edge (i.e. event) Triggered Input to trigger 

an event when a change in the state of input 

occurs.  Choose Blink While Triggered, for 

the output to pulsate on/off (not an option 

when Retriggerable While Active is 

selected). Selecting Retriggerable While 

Active allows the user to repeatedly 

retrigger the event during the active period.  

The retrigger restarts the active interval 

period.  However, if Accumulate Time is 

selected, this allows each retrigger to add 

the specified time to the end of the current 

period.  To impose a limit to the amount of 

active time allowed, enter a limit, in 

seconds or minutes.  Choose Force Inactive 

on Trigger End to end the active period 

when the trigger ends, but the interval 

hasn‘t ended. 

 

 In the various edit boxes set values for the 

amount of time for delay after trigger, 

output active time, and refractory period in 

minutes or seconds.  There are also 

checkboxes available to customize how 

input signals are evaluated. 

 

Use the following sections to configure the 

reporting for either the Input or Output 

Settings.  If reporting when changes occur is desired, choose ―Report Changes‖.  Check the box 

for ―Report Periodically‖ and select the interval for periodic reporting from the droplist.  These 

settings can be applied to either the specific device, the device type, or the devices in the group.  

Click ―OK‖ to finalize selections. 

  

  

 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on configuring device element operations is found in ―FSD Operation Configuration Guide‖. 

Other commands control the placement and size of the dialog box and a command to close the 

dialog.  Selections on the menu lead to presentation of Help Topics, information about the Fade 

Timer device, and software version information for the Fade Timer.   

  

  

  

  



X10 Controller 
  

Device Types in family 

Device Family     

RS485/232 X10 Interface (CM11A)   

Timer X10 Interface (TW523)   

 

 Device Type Description 

X10 Interface (TW523)  
The TW523 is also a two-way communication X10 device interface that allows 

connection between the FSD Controller and the X10 network.  The connection 

between the two units uses an RJ11 cable. 

 

The X10 Interface model PL513 is similar to TW523, but since it is a one-way 

communication device, we recommend the TW523. 

  

  

  

X10 Interface (CM11A)  
The CM11A is an X10 device interface that allows connection between the FSD 

Controller and the X10 network (powerline interface).  The connection between the 

two units uses an RS232 serial port. 

  

  

 

  

Device Dialog Box 

The device dialog shows information about the X10 controller.  Right-clicking on 

the title bar displays a menu list, including commands to configure the X10 

Controller functions. 

  

  

  

  

  

  

  

  

  

 Configure Display - Use this command to choose the picture used 

on the device dialog.  In the     ―Configure Display‖ dialog that 

appears, click ―Browse‖ to select the picture to be shown on the 

device dialog.  Click the ―Open‖ button to implement the 

selection.  In the ―Configure Display‖ dialog apply the settings 

to either the specific device, the device type, or the devices in 

the group.  Click ―OK‖. 

  

  

  























 Configure Device - Use this command to set the 

type of interface used for input and output signals 

(None, PL513 (power line interface), or TW523 

(2-way communication power line interface).  

The user can also set number of times to send 

transmit packets, to set the number of echo 

received packets, to apply the settings to either 

the specific device, the device type, or the devices 

in the group, and to set the Watch Level Control 

(determines the amount of information reported 

to the user in the debug text file).  Click ―OK‖ to 

finalize selections. 

  

  

  

  

  

  

  

  

 Configure Operations - this command does not currently apply to this dialog. 

  

Other commands control the placement and size of the dialog box and a command to close the dialog.  

Selections on the menu lead to presentation of Help Topics, or version information about the device 

and about the X10 Controller.   

  

  

  

  



Super Bridge 
  

Device Types in family 

Device Family           

Timer Super Bridge 8 Super Bridge 16       

 

 Device Type Description 

  

Super Bridge 

Use this device to implement a bridge between different device families.  In this manner one device 

type can control another device type (for example, a UPB switch controlling an X10 device).   

  

Device Dialog Box 

There are two sizes of Super Bridges:  either 

8 or 16 buttons.  The Super Bridge acts to 

bridge commands from one device family to 

a different device family.  Even though 

different devices have their own 

communications protocols, with the Super 

Bridge configured the FSD Bridge Controller 

translates the commands from one device 

family to another device family.   

  

The Super Bridge device dialogs display 

switches that control and indicate the state of 

each switch.  Slider controls are shown for 

controlling bridged devices with dimmer 

capabilities. 

  

Right-clicking on the title bar displays a 

menu list, including commands to configure 

the Super Bridge. 

  

  

  

 Configure Display - Use this command to choose the 

picture used on the device dialog.  In the ―Configure 

Display‖ dialog that appears, click ―Browse‖ to 

select the picture to be shown on the device dialog.  

Click the ―Open‖ button to implement the selection.  

In the ―Configure Display‖ dialog apply the settings 

to either the specific device, the device type, or the 

devices in the group.  Click ―OK‖. 

  

  

  

  

 



 Configure Device - The Configure Super 

Bridge dialog displays a list box displaying 

address groups within Bridge Controller 

Configuration.  Double-clicking on an 

address group line in the list box will display 

the Edit Super Bridge dialog box to edit 

bridge behavior for a block of four sequential 

input and output addresses (see next section, 

Edit Bridge Group).  The following section 

configures reporting for Input and Output 

Settings.  If reporting when changes occur is 

desired, choose ―Report Changes‖.  Check 

the box for ―Report Periodically‖ and select 

the interval for periodic reporting from the 

droplist.  Apply the settings to either the 

specific device, the device type, or the 

devices in the group.  Double-click on any of 

the lines in the Bridge Group Configuration 

list box to configure the bridging (see next 

section)  Click ―OK‖ to finalize selections. 

  

   

 Edit Bridge Group - In the Input Settings 

section. enter the device family and address 

information for the devices that send signals 

to the FSD Controller.  In this example X10 

devices will control UPB devices.  For X10 

devices using extended command, also enter 

the protocol variation to use based on the X10 

device models.  Also select the radio button to 

indicate whether the address is a unit or group 

ID.  For devices to receive the bridged signals 

from the FSD Controller, enter configuration 

data in the Output Settings section.  For each 

section the first address entered is used as a 

base address with the next three devices 

assigned the next three addresses in the 

sequence.  For each section use the drop lists to 

choose the device family, X10 variation if 

applicable, and device family controller (on 

FSD Controller models supporting more than 

one).  Depending on the device family, enter 

other appropriate information required for the 

device family in the displayed drop lists and 

radio button selections.  In this example, the 

X10 device with address I-8 will control the UPB device at address 001::005 (and I-9 controls 

001::006 etc.). 

  

For subsequent address groups in the Bridge Group Configuration, double click on the address 

group entry in the initial list box.  If the same device families are used for input and output to the 

controller as the previous line and with consecutive addresses, select the Inherit Settings 

checkbox.  If the output device group has dimmer capabilities, check the ―Enable Dimmer 

Operation‖ checkbox to enable bridging dimmer values through the Super Bridge.  

  

 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on configuring device element operations is found in ―FSD Operation Configuration Guide‖. 

  

Other commands control the placement and size of the dialog box and a command to close the 

dialog.  Selections on the menu lead to presentation of Help Topics, information about the Super 

Bridge device, and software version information for the Super Bridge device.   



X10 Switch 

  

Device Types in family 

Device Family           

X10 X10 Switch X10 Appliance 

Module 

X10 Lamp 

Module 

X10 Two-Way 

Appliance  

Module 

X10 Two-Way 

Lamp Module 

X10 X10 Remote 

Chime 

X10 Siren LEV DHC 

Dimmer 

COMPOSE 

Dimmer 

PCS Dimmer 

X10 SmartLinc  

Dimmer 

        

  

Device Type Description 

X10 Switch 

Any switch that receives X10 commands to turn on or off the equipment to which the switch is 

connected. 

X10 Appliance Module 

Module that plugs into electrical receptacle and receives X10 commands to turn on and off an 

appliance that is plugged into this module. 

X10 Lamp Module 

Module that plugs into electrical receptacle and receives X10 commands to turn on and off an 

lamp (non-fluorescent and limited to 300 watts) that is plugged into this module. 

X10 Two-Way Appliance Module 

Module that plugs into electrical receptacle and receives X10 commands to turn on and off an 

appliance that is plugged into this module.  This module sends a communication when it performs 

its local operation. 

X10 Two-Way Lamp Module 

Module that plugs into electrical receptacle and receives X10 commands to turn on and off an 

lamp (non-fluorescent and limited to 300 watts) that is plugged into this module.  This module 

sends a communication when it performs its local operation. 

X10 Remote Chime 

Receives specific input from X10 motion sensor to cause chime to sound. 

X10 Siren 

Receives specific input from sensors to trigger siren to sound. 

  

The following device types receive X10 input to turn on and off lights, and also commands to set light 

intensity.  The dimmer value is retained and illuminates to that level when turned on manually. 

  

LEV DHC Dimmer 

COMPOSE Dimmer 

PCS Dimmer 

SmartLinc Dimmer 

  

 Device Dialog Box 

The device dialog shows controls to operate the 

X10 switch.  In the example of the lamp 

module, there are buttons to turn the lamp on or 

off.  If equipped with dimmer capability, there 

is a sliding bar to brighten or dim the light.   

  

 Right-clicking on the title bar displays a menu list, including commands to 

configure the X10 Switch. 

  

  

  

  



  

  

  

  

 Configure Display - Use this command to choose the picture 

used on the device dialog.  In the ―Configure Display‖ 

dialog that appears, click ―Browse‖ to select the picture to 

be shown on the device dialog.  Click the ―Open‖ button to 

implement the selection.  In the ―Configure Display‖ dialog 

apply the settings to either the specific device, the device 

type, or the devices in the group.  Click ―OK‖. 

  

   

 Configure Device - Use this command to configure 

the reporting for either the Input or Output Settings.  If 

reporting when changes occur is desired, choose 

―Report Changes‖.  Check the box for ―Report 

Periodically‖ and select the interval for periodic 

reporting from the droplist.  These settings can be 

applied to either the specific device, the device type, or 

the devices in the group.  Click ―OK‖ to finalize 

selections. 

  

  

  

  

  

  

 Configure Operations - Select this command to 

display a dialog to configure the device elements 

for the operation desired for the device.  Double 

click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on device element operation configuration can be found in ―FSD Operation Configuration Guide‖. 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Other commands control the placement and size of the dialog box 

and a command to close the dialog.  Selections on the menu lead to 

presentation of Help Topics, information about the X10 device (see 

figure), and software version information for the X10 Switch.   

  

  

  



  



UPB Controller 
  

Device Types in family 

   

Device Family     

RS485/232 UPB Interface (PIM)   

 

 Device Type Description  
UPB Interface (PIM) 

The PIM is an UPB device interface that allows connection between the 

FSD Controller and the UPB network (powerline interface).  The 

connection between the two units uses an RS232 serial port. 

  

  

  

 

Device Dialog Box  
The device dialog shows information about the UPB controller.  Right-clicking 

on the title bar displays a menu list, including commands to configure the UPB 

Controller functions. 

  

  

  

 Configure Display - Use this 

command to choose the 

picture used on the device 

dialog.  In the ―Configure 

Display‖ dialog that appears, 

click ―Browse‖ to select the 

picture to be shown on the 

device dialog.  Click the 

―Open‖ button to implement 

the selection.  In the ―Configure Display‖ dialog apply the settings to either the specific device, the 

device type, or the devices in the group.  Click ―OK‖. 

  

 

    Configure Device -  The user can set 

number of times to send transmit packets, to 

set the number of echo received packets, to 

apply the settings to either the specific 

device, the device type, or the devices in the 

group, and to set the Watch Level Control 

(determines the amount of information 

reported to the user in the debug text file).  

Click ―OK‖ to finalize selections. 

  

  

  

  

  

  Configure Operations - this command does not 

currently apply to this dialog. 

  

Other commands control the placement and 

size of the dialog box and a command to 

close the dialog.  Selections on the menu lead to presentation of Help Topics, or version information about 

the device and about the UPB Controller.   

  

  



  

UPB Switch 
  

Device Types in family 

  

Device Family           

UPB UPB Switch UPB Appliance 

Module 

UPB Dimmer     

 

Device Type Description 

UPB Switch 

Any switch that receives UPB commands to turn on or off the equipment to which the switch is 

connected. 

UPB Appliance Module 

Module that plugs into electrical receptacle and receives UPB commands to turn on and off an 

appliance that is plugged into this module. 

UPB Dimmer 

Module that plugs into electrical receptacle and receives UPB commands to turn on and off and 

dim a lamp. 

  

Device Dialog Box  
The device dialog shows controls to 

operate the UPB switch.  In the example 

of the dimmer module, there are buttons to 

turn the lamp on or off.  If equipped with 

dimmer capability, there is a sliding bar to 

brighten or dim the light.   

  

  

  

  

  

Right-clicking on the title bar displays a menu list, including commands to 

configure the UPB Switch. 

  

  

  

   

  

  

  

 Configure Display - Use this command to choose the picture used on 

the device dialog.  In the  ―Configure Display‖ dialog that appears, 

click ―Browse‖ to select the picture to be shown on the device 

dialog.  Click the ―Open‖ button to implement the selection.  In the 

―Configure Display‖ dialog apply the settings to either the specific 

device, the device type, or the devices in the group.  Click ―OK‖. 

  

  

  

  

  

 



 Configure Device - Use this command to configure the reporting for either the Input or Output 

Settings.  If reporting when changes occur is desired, choose ―Report Changes‖.  Check the box 

for ―Report Periodically‖ and select the interval for periodic reporting from the droplist.  These 

settings can be applied to either the specific device, the device type, or the devices in the group.  

Click ―OK‖ to finalize selections.  
  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  



 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on device element operation configuration can be found in ―FSD Operation Configuration Guide‖. 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Other commands control the placement and size of the dialog box and a command to close the dialog.  

Selections on the menu lead to presentation of Help Topics, information about the UPB device (see 

figure), and software version information for the UPB Switch type device.   

  

  

  



UPB Input/Output 
  

Device Types in family 

  

  

Device Family     

UPB UPB Input Output Module   

 

Device Type Description 

UPB Input/Output Module 

The Input/Output Module is an UPB device that identifies and transmits the status of low voltage 

input.  The device output can control the operation of low voltage actuators.   

 

Device Dialog Box 

The device dialog shows information about 

the UPB Input/Output.  Dis played as 

activateable buttons are the states for the 

Outputs that control devices and reported 

are the UPB Inputs. 

  

  

  

  

  

  

Right-clicking on the title bar displays a menu list, including commands 

to configure the UPB Input/Output functions. 

  

  

  

  

  

  

  

  Configure Display - Use this command to choose the 

picture used on the device dialog.  In the ―Configure 

Display‖ dialog that appears, click ―Browse‖ to select the 

picture to be shown on the device dialog.  Click the 

―Open‖ button to implement the selection.  In the 

―Configure Display‖ dialog apply the settings to either the 

specific device, the device type, or the devices in the 

group.  Click ―OK‖. 

  

  

 Configure Device - Use this 

command to configure the 

reporting for either the Input or 

Output for reporting changes or 

periodic reporting.  Enter the 

measurement interval and 

choose the reporting interval 

from the droplist.  These 

settings can be applied to either 

the specific device, the device 

type, or the devices in the 

group.  Click ―OK‖ to finalize 

selections. 

  

  



  

  

  

  

  

  

 Configure Operations - Select this command to display a dialog to configure the device elements for 

the operation desired for the device.  Double click on the device name to display the ―Device 

Element Operation‖ dialog or click the ―Add‖ button to add an operation.  A detailed discussion 

on device element operation configuration can be found in ―FSD Operation Configuration 

Guide‖..  
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Other commands control the placement and size of the dialog box and a command to close the dialog.  

Selections on the menu lead to presentation of Help Topics, or version information about the device 

and about the UPB Input/Output module.   

  

  

  

  



 

FSD Lister 
  

FSD Lister Overview 
  

FSD Lister displays a list of devices in the entire system.  The lists can be displayed in different formats.  FSD 

devices can be displayed in a horizontal or vertical tree listing.  FSD devices can also be listed by type or 

alphabetically.  FSD Lister can display the following device groupings: FSD, X10, Z-Wave, UPB, RS435/232. 

Macro, Timer, and Variable.  In addition, a summary list can be generated. 

  

The generated lists can also be printed. 

  

FSD Lister Menu 
  

The File menu offers the following commands: 

  

Open Opens an existing document. 

Print Prints a document. 

Print Preview Displays the document on the screen as it would appear printed. 

Print Setup Selects a printer and printer connection. 

Exit Exits FSD Lister. 

  

  

The View menu offers the following commands: 

  

FGI Device List Displays the FGI device list in the view 

window. 

FGI Horizontal Tree Displays the FGI device tree horizontally 

in the view window. 

FGI Vertical Tree Displays the FGI device tree vertically in 

the view window. 

X10 Device List Displays list of X10 devices on system 

Z-Wave Device List Displays list of Z-Wave devices on 

system 

UPB Device List Displays list of UPB devices on system 

RS435/232 Device List Displays list of RS435/232 devices on 

system 

Macro Device List Displays list of Macro devices on system 

Timer List Displays list of Timer devices on system 

Variable List Displays list of Variable devices on 

system 

Summary Displays the device summary in the view 

window. 

Supported Types Displays popup menu to choose between 

display sort options. 

List Options Display the Options dialog box to set options for Lister: 

Checkboxes for: 

 List View 

 List by Type/Description 

 Device Tree Display 

Header Labels Displayed 

  

Toolbar Shows or hides the toolbar. 

  

Folder icon Open an existing data set.  FSD Lister displays the Open dialog box, in which you can locate and 

open the desired file. 

  

Printer icon Print the active document. 

  

―F‖ button Display the device list in the view window. 



  

―H‖ button Display the device tree horizontally in the view window. 

  

―V‖ button Display the device tree vertically in the view window. 

  

―S‖ button Display the device summary in the view window. 

  

―T‖ button Display the supported device types sorted by Device Type. 

  

―D‖ button Display the supported device types sorted by Device Type Description. 

  

―O‖ button Display the Options dialog box to set options for Lister: 

Checkboxes for: 

 List View 

 List by Type/Description 

 Device Tree Display 

 Header Labels Displayed 

  

Status Bar Shows or hides the status bar. 

  

The Types menu allows the user to select a device families or virtual 

devices and have them listed either by Type or by Description. 

  

  

  

  

  

  

  

  

  

  

  

  

The Help menu offers the following commands, which provides assistance with this application: 

  

  

Help Topics Offers you an index to topics on which you can obtain help. 

About FSD Lister Displays the version number of this application. 

  

  



FSD Creator 
  

FSD Creator Overview 
Use this tool to create Direct Macros and Macro Device Types.  Direct Macros are single-instance macros that link 

directly to device elements.  It is a relatively simple approach to generate customized control sequences.  Macro 

Device Types are custom designed virtual device types.   

  

For a detailed reference on developing macros with FSD Creator, choose View Configuration Guides from the Help 

menu in FSD Automator.  Choose FSD Macro Developers Guide from the displayed list. 

  

  

FSD Creator 
  

To create a new macro, choose FSD Creator from 

the FSD Automator‘s View menu.  Use the radio 

buttons to select whether to work with Direct 

Macros or Macro Device Types.   

  

To add a macro, click the Insert button and the 

Edit Macro is displayed (see below).  Select a 

macro and click the Delete button to delete the 

macro.  To import or export the macro, click its 

respective button.  After importing a macro, 

connect any device elements specified in the 

macro.  See FSD Macro Developers Guide for 

further details (Choose View Configuration 

Guides from the Help menu in FSD 

Automator.  Choose FSD Macro Developers 

Guide from the displayed list.)  When macros 

are completed, click the Load button to Load 

Configuration. 

  

  

Edit Macro 

  

After inserting a macro in the Creator (see 

above), in the Edit Macro dialog, enter a name 

for the macro.  The macro can be disabled until 

finished and tested.  If the Autostart checkbox 

is checked, the Direct Macro or all FSD Namer 

defined macro devices, based on the Macro 

Device Type, start automatically on controller 

restart.  Otherwise, the macro runs when 

explicitly invoked or triggered by a Start 

Trigger event. 

  

Program the macro by selecting Insert from the 

macro editing dialog and choosing a macro 

component to use (see below).  If no line is selected in the listbox, new items are inserted at the end of the list.  If a 

line is selected, new items are inserted above the selected item.  Deselect items by clicking in the area at the end of 

the displayed list.  Reorder item sequence by clicking a line and moving it up or down in the list with the indicated 

buttons below.  Double click a line to edit it.   

  

  

  

  

  

  

Edit Macro Item 

  



In the Edit dialog box, choose the macro function from the droplist (see FSD Macro Developer‘s Guide for 

definitions of functions).  Depending on the function selected, a function-specific edit macro item dialog appears.  

The Edit X10 Item is shown as an example.  Select the checkbox to enable the macro function.  Enter a comment to 

state that the function does in the macro and select the appropriate properties for the macro.   

  

   

  

 

 

  



FSD Namer 
  

Overview FSD Namer 
Allows the user to assign a name, location, and other identification to a selected device type.  The device can now 

be configured in the system.  FSD Namer can be accessed from the View menu in FSD Automator and selecting 

the specific device category or FSD Namer can be run as a stand-alone application. 

  

  

FSD Namer Menu Layout  
When accessing FSD Namer by using the View menu in FSD Automator, 

choose the device category wanted (list may vary depending on controller 

type).  A list of the devices of that category on the system is displayed. 

  

  

  

  

  

  

 If FSD Namer is used as a stand-alone program: 

  

The File menu displays the following commands: 

  

Open Opens an existing document. 

Save Saves an opened document using the same file name. 

Print Prints a document. 

Print Preview Displays the document on the screen as it would appear printed. 

Print Setup Selects a printer and printer connection. 

Exit Exits FSD Namer. 

  

  

The View menu displays the following selections to choose the device 

category to edit:   

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

The Help menu provides: 

Help Topics—an index to Help topics for FSD Namer. 

  

  

 

FSD Namer Menu Layout 

  
The File menu displays the following commands (only for FSD Namer started as stand-alone program): 

  

Open Opens an existing document. 

Save Saves an opened document using the same file name. 

Print Prints a document. 



Print Preview Displays the document on the screen as it would appear printed. 

Print Setup Selects a printer and printer connection. 

Exit Exits FSD Namer. 

  

The View menu displays the following device categories to select:  
  

FGI Device Shows list for adding FGI devices or modifying names and locations. 

The FGI Device List command opens a device listing window, which allows assigning a name and location to a 

device. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To reflect changes in the hardware system configuration, in particular the addition and removal of devices, 

additional functions are provided.  Single-clicking on a device information row selects the device name to 

manipulate its position on list. 

  

Below the device listings, four buttons are now active – Insert, Delete, Move Up, and Move Down. 

  

FGI devices are ―plug-and-play‖, thus when plugging an FGI device to the controller, the system recognizes 

the device type.  Selecting the device in the list and clicking the Insert button displays a dialog to enter a 

name and location for the device.  This corresponds to a hardware device insertion with other device types.  

Note: always run the FSD Automator program with the new system configuration and save the device 

configuration from within FSD Automator before using FSD Namer to modify name and location 

information.  FSD Automator inserts the device information row in all fields except the name and location 

fields.  Thus, the Insert button performs the corresponding insertion on the name and location entries only, 

without affecting the remaining device information entries. 

  

Similarly, the Delete button removes name and location information from the selected device information 

row, adjusting the remaining entries appropriately, to correspond to a device deletion from the hardware 

system.  Again note that FSD Automator should be run first and the new configuration saved, prior to 

invoking FSD Namer, and that Delete only affects the name and location entries in the device information 

listing.. 

  

Move Up and Move Down provide more flexibility for rearranging the device name and location 

assignments.  The selected entry moves up or down one position, swapping places with the name and location 

information from the targeted row. 

  

Modified name and location information are automatically saved when the device list box is closed. 

  

Double-clicking on a device information row brings up a dialog that allows entry and editing of the device 

name and location information, and also display of Device Type, Device Subtype, Device ID, Device Path, 

and a table of element information.  There is an ―Enable All‖ button to enable all elements and a ―Disable 

All‖ button to disable all elements.  Click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Double-clicking on an element in the table displays an edit element name dialog box.  In this box the user can 

edit the element name, enable or disable the element.  In this edit box click ―OK‖ to retain changes, otherwise 

click ―Cancel‖. 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



X10 Devices 

Shows X10 device list for modifying 

names and locations. The X10 

Device List command opens a 

device listing window, where the 

user can insert a device type of the 

X10 family.  Selecting the Name or 

Address radio button displays the list 

alphabetically by Name or by 

Address. 

  

The Insert button displays an Edit 

X10 Device  dialog to choose an 

X10 Device Type, to enter a 

device name, to associate the 

device with a controller interface, 

to assign a house and unit code, 

and to choose unit code or group 

id.   

  

Similarly, the Delete button removes 

the device instance from the system.  
  

  

Double-clicking on the device 

information row displays the Edit 

X10 Device dialog that allows entry 

and editing of the device name and 

location information and selection of 

a device family controller interface. 

  

Use the House Code and Unit Code 

droplist boxes to reassign an address 

for the device. 

  

The number of elements for the 

device is shown and the elements are 

displayed in the table.  Listed are the 

element number, whether the 

element is enabled, the element‘s 

address, element name, and the 

device type element name.  There is 

an ―Enable All‖ button to enable all 

elements and a ―Disable All‖ button 

to disable all elements.  Click ―OK‖ 

to retain changes, otherwise click 

―Cancel‖. 

  

Double-clicking on an element in the table displays an edit element name 

dialog box.  In this box the user can edit the element name, enable or 

disable the element, and, if applicable, change the attributes of the element 

and assign an address if the device has more than one address.  In this edit 

box click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

 NOTE:  The Device List, Edit Device List, and Edit Element Name dialog boxes 

as described for X10 devices are similar for many of the remaining devices. 

  

  

Z-Wave Devices 

Shows Z-Wave device list where the user can insert a device type of the Z-

Wave family. 

The Z-Wave Device List command opens a device listing window to insert or modify a Z-Wave device on the 



system.  Selecting the Name or Address radio button displays the list alphabetically by Name or by Address. 

  

The Insert button displays an Edit Z-Wave Device dialog to choose an Z-Wave Device Type, to enter a 

device name, to associate the device with a controller interface, and to assign a house id and unit id.  

  

Similarly, the Delete button removes the device instance from the system. 

  

Double-clicking on the device information row displays the Edit Z-Wave Device dialog that allows entry and 

editing of the device name and location information and selection of a device family controller interface. 

  

Use the Unit ID droplist box to assign an address for the device. 

  

The number of elements for the device is shown and the elements are displayed in the table.  Listed is the 

element number, whether the element is enabled, the element‘s address, element name, and the device type 

element name.  There is an ―Enable All‖ button to enable all elements and a ―Disable All‖ button to disable 

all elements.  Click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

Double-clicking on an element in the table displays an edit element name dialog box.  In this box the user can 

edit the element name, enable or disable the element, and, if applicable, change the attributes of the element 

and assign an address if the device has more than one address.  In this edit box click ―OK‖ to retain changes, 

otherwise click ―Cancel‖. 

  

UPB Devices 

Shows UPB device list where the user can insert a device type of the UPB family. 

The UPB Device List command opens a device listing window to insert or modify a UPB device on the 

system. .  Selecting the Name or Address radio button displays the list alphabetically by Name or displayed 

by Address. 

  

The Insert button displays an Edit Z-Wave Device dialog to choose an Z-Wave Device Type, to enter a 

device name, to associate the device with a controller interface, and to assign a network id and unit id. 

  

Similarly, the Delete button removes the device instance from the system. 

  

Double-clicking on the device information row displays the Edit UPB Device dialog that allows entry and 

editing of the device name and location information and selection of a device family controller interface. 

  

Use the Network ID and Unit ID droplist boxes to assign an address for the device. 

  

The number of elements for the device is shown and the elements are displayed in the table.  Listed is the 

element number, whether the element is enabled, the element‘s address, element name, and the device type 

element name.  There is an ―Enable All‖ button to enable all elements and a ―Disable All‖ button to disable 

all elements.  Click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

Double-clicking on an element in the table displays an edit element name dialog box.  In this box the user can 

edit the element name, enable or disable the element, and, if applicable, change the attributes of the element 

and assign an address if the device has more than one address.  In this edit box click ―OK‖ to retain changes, 

otherwise click ―Cancel‖. 

  

RS-485/232 Devices 

Shows RS-485/232 device list where the user can insert a device type of the RS-485/232 family. 

The RS-485/232 Device List command opens a device listing window to insert or modify a RS-485/232 

device on the system.   

  

The Insert button displays an Edit RS-485/232 Device dialog to choose an RS-485/232 Device Type, to enter 

a device name and a location.  

  

Similarly, the Delete button removes the device instance from the system. 

  

Double-clicking on the device information row displays the Edit RS-485/232 Device dialog that allows entry 

and editing of the device name and location information and , if applicable, any address information. 

  

The number of elements for the device is shown and the elements are displayed in the table.  Listed is the 



element number, whether the element is enabled, element name, and the device type element name.  There is 

an ―Enable All‖ button to enable all elements and a ―Disable All‖ button to disable all elements.  Click ―OK‖ 

to retain changes, otherwise click ―Cancel‖. 

  

Double-clicking on an element in the table displays an edit element name dialog box.  In this box the user can 

edit the element name, enable or disable the element, and, if applicable, change the attributes of the element.  

In this edit box click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

  

Macro Devices 

Shows Macro device list where the user can insert a macro device. 

The Macro Device List command opens a device listing window to insert or modify a Macro device on the 

system.  (Macro devices are created using FSD Creator, see FSD Creator manual.) 

  

The Insert button displays an Edit Macro Device dialog to choose an Macro Device Type, to enter a device 

name and a location.  

  

Similarly, the Delete button removes the device instance from the system. 

  

Double-clicking on the device information row displays the Edit Macro Device dialog that allows entry and 

editing of the device name. 

  

The number of elements for the device is shown and the elements are displayed in the table.  Listed is the 

element number, whether the element is enabled, element name, and the device type element name.  There is 

an ―Enable All‖ button to enable all elements and a ―Disable All‖ button to disable all elements.  Click ―OK‖ 

to retain changes, otherwise click ―Cancel‖. 

  

Double-clicking on an element in the table displays an edit element name dialog box.  In this box the user can 

edit the element name, enable or disable the element, and, if applicable, change the attributes of the element.  

In this edit box click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

Timers, etc. Devices 

Shows Timer etc. device list where the user can insert a device type of the Timer etc. family. 

The Timer etc. Device List command opens a device listing window to insert or modify a Timer etc. device 

on the system.   

  

The Insert button displays an Edit Timer etc. Device dialog to choose an Timer etc. Device Type, to enter a 

device name and a location.  

  

Similarly, the Delete button removes the device instance from the system. 

  

Double-clicking on the device information row displays the Edit Timer etc. Device dialog that allows entry 

and editing of the device name and location information  

  

The number of elements for the device is shown and the elements are displayed in the table.  Listed is the 

element number, whether the element is enabled, element name, and the device type element name.  There is 

an ―Enable All‖ button to enable all elements and a ―Disable All‖ button to disable all elements.  Click ―OK‖ 

to retain changes, otherwise click ―Cancel‖. 

  

Double-clicking on an element in the table displays an edit element name dialog box.  In this box the user can 

edit the element name, enable or disable the element, and, if applicable, change the attributes of the element.  

In this edit box click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

Variables 

Shows Variables list where the user can insert a variable. 

The Variables List command opens a device listing window to insert or modify a variable on the system.   

  

The Insert button displays an Edit Variable dialog to choose a variable, to enter a name for the instance of the 

variable.  Clicking on the Edit Value button allows assigning a value or setting conditions to the variable. 

  

Similarly, the Delete button removes the variable instance from the system. 

  



Double-clicking on the variable information row displays the Edit Variable dialog that allows entry and 

editing of the device name and location information  

  

  

Operating Mode 

Shows Operating Mode list for mode name, enabled and mode number. 

The Operating Modes List command opens a dialog with two device listing windows.  One window lists 

Operating Mode Groups, displaying enabled status, group number, style, and operating mode group name.  

The other window lists Operating Modes, displaying the enabled status, group number, and operation. 

  

Double-clicking on an operating mode group displays a dialog that allows the user to enter or edit the 

operating mode group name and to enable or disable the operating mode group.  The user can also assign the 

operating mode group style by selecting either Radio Button, Independent, ALL TRUE, or ALL FALSE.  

Click ―OK‖ to retain changes, otherwise click ―Cancel‖. 

  

Double-clicking on an operating mode displays a dialog that allows entry and editing of the operating mode 

name and to enable or disable the operating mode.  The user can also assign the operating mode to an 

operating mode group by clicking on the Operating Mode Group droplist and choosing a group.  Click ―OK‖ 

to retain changes, otherwise click ―Cancel‖. 

  

Click ―OK‖ to retain changes, otherwise click ―Cancel‖.  Either action will exit Operating Mode List dialog. 

  

  

  

  

FSD Lister Invokes FSD Lister to show devices on system. 

The FSD Lister command invokes the FSD Lister utility, which displays FGI devices on the system as a list, a 

device wiring tree, or a summary of devices on the system.  FSD Lister also can be used to view a list of 

supported device types that can be used with an FGI system, including X10, Z-Wave, UPB, RS485/232, 

Macro, Timer, and Variable.  See FSD Lister manual. 

  

  

Toolbar Shows or hides the toolbar. 

Folder icon Open an existing data set.  FSD Namer displays the Open dialog box, in which you can locate and 

open the desired file. 

  

Disk Icon Saves the current document. 

  

Printer icon Prints the active document. 

  

―F‖ button Displays the device list in the view window. 

  

―?‖ icon Displays the About FSD Namer dialog box. 

  

―Arrow - ?‖ icon Activates Context-sensitive help.  Click on the ―Arrow - ?‖ icon , select the menu, button, 

or other object to display the help information connected with the object. 

  

Status Bar Shows or hides the status bar. 

  

The Help menu displays the following commands, which provides assistance with this application: 

  

Help Topics Offers you an index to topics on which you can obtain help. 

Use this command to display the opening screen of Help.  From the opening screen, you can jump to step-by-

step instructions for using FSD Namer and various types of reference information. 

  

After Help opens, click the Contents button to return to the opening screen. 

  

About Displays the version number of this application. 

Use this command to display the copyright notice and version number of your copy of FSD Namer 

  

  



FSD Designer 
  

FSD Designer Overview 
FSD Designer is a multifunctional tool used to construct floor layouts of the building for placement of 

devices and furniture.  The user can create furniture, appliance, and device icons for use in the floor layout.  

The user can also build icon and menu layouts. 

  

  

FSD Designer Menu 
  

The application opens with the FSD Designer screen.  Choose between creating a new drawing or opening an 

existing one.  Choose among the following drawing types:  (1) Composite:  Building Information, Floor 

Layout, Device Layout; and (2) Fundamental:  Floor Plan Drawing, Furniture Drawing‘ Appliance Drawing, 

and Device Icon. 

  

When creating a new drawing, a screen with a drawing grid appears.  A palette of tool buttons that displays 

tools appropriate for the drawing type selected. 

  

When opening an existing file, in the Open dialog that is displayed, select the file desired.  Click ―OK‖ and 

the screen with a drawing grid appears with the existing file displayed. 

  

The File menu offers the following commands: 

  

  

New Creates a new document.  Select the type of new file you want to create in the File New 

dialog box. 

Open Pop-up menu options open an existing system configuration or top level layout data 

set. 

Save Saves the current system data set using the same data set name. 

Save As Saves the current system data set to a specified data set name. 

Print Prints a system data set. 

Print Preview Displays the data set on the screen as it would appear printed. 

Print Setup Selects a printer and printer connection. 

File Properties Opens dialog box that displays information on the file, its designer and file name and 

last change information. 

Exit Exits FSD Designer. 

  

The Edit menu offers the following commands: 

Undo Undoes the last change to the file. 

Cut Cuts the selected item to the clipboard. 

Copy Copies the selected item to the clipboard. 

Paste Pastes the item in the clipboard to the selected location. 

Select All Selects all objects in the drawing. 

  

  

The View menu offers the following commands: 

  

Tools For a new drawing, shows the drawing tools palette with tools appropriate 

to the type drawing.  For existing drawings, an Options palette is shown 

with appropriate options listed. 

Floor Check to display normal floor view. 

Room Use this command to display a dialog box to assign room number and 

names and to assign a space in the floor layout that corresponds to the 

room number.  Click the ―Add‖ button to display a dialog box that assigns 

room number and name.  Enter values for number and name.  Click ―OK‖.  

The newly entered name and room number is displayed in the table.  To 

designate the room that corresponds to the selected room in the list, 

choose the ―Hot Spot Assignment‖ radio button. 

Small Icon Use this command to display the small icon version of devices in the normal view. 

Large Icon Use this command to display the large icon version of devices in the normal view. 

Toolbar Use this command to display and hide the toolbar, which includes buttons for some of 



the most common commands in Designer, such as File Open. A checkmark appears 

next to the menu item when the Toolbar is displayed.  To hide or display the toolbar, 

click Toolbar from the View menu. 

  

New icon       Creates a new document. 
  

Folder icon    Open an existing document.  FSD Designer displays the Open dialog box, in 

which you can locate and open the desired file. 

  

Disk icon   Saves the active document or template with its current name.  Use this command 

to save the active system data set to its current name and directory.  When saving 

a data set for the first time, FSD Designer displays the Save As dialog box so you 

can name your data set.  To change the name and directory of an existing data set 

before saving it, choose the Save As command. 

  

Scissors icon Cuts the selected item to the clipboard. 

  

Double sheet icon Copies the selected item to the clipboard. 

  

Clipboard icon Pastes the item in the clipboard to the selected 

  

Printer icon    Print the active document. 

  

Question icon Displays the copyright notice and version number of Designer. 

  

Question/Arrow icon Displays the context-sensitive help. 

  

Status Bar 

The status bar is displayed at the bottom of the FSD Designer window.  To display or hide the status bar, 

use the Status Bar command in the View menu. 

  

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate 

through menus.  This area similarly shows messages that describe the actions of toolbar buttons as you 

depress them, before releasing them.  If after viewing the description of the toolbar button command you 

wish not to execute the command, then release the mouse button while the pointer is off the toolbar 

button. 

  

The right areas of the status bar indicate which of the following keys are latched down: 

  

  

Indicator Description 

  

CAP The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

  

  

  

  

The Tool menu offers the following commands, which are also 

displayed on a Tools palette.: 

  

Pointer Select the pointer tool to reposition objects in 

the drawing by holding down the left mouse 

button while selecting, then positions or 

resizes the object. Release the mouse button 

when edit is completed. 

  

Wall Select the Wall tool to draw lines 

representing building walls by holding down 

the left mouse button while drawing. Release 

the mouse button when the wall is 



completed.  Walls can be drawn only in the vertical and horizontal orientation. 

  

Window Select the Window tool to draw lines representing windows by holding down the left 

mouse button while drawing. Release the mouse button when the window is 

completed. 

  

Door Select the Door tool to draw lines representing doors by holding down the left mouse 

button while drawing. Release the mouse button when the door is completed.  Draws 

an outlined thin rectangle the width of a wall and filled with a shade of the wall color 

to represent a door. 

  

Line Draws lines by holding down the left mouse button while drawing. Release the 

mouse button when the line is completed. 

  

Rectangle Select the Rectangle tool to draw rectangles by holding down the left mouse button 

while drawing. Release the mouse button when the rectangle is completed. 

  

Rounded Rectangle Select the Rounded Rectangle tool to draw rectangles with rounded corners by 

holding down the left mouse button while drawing. Release the mouse button when 

the rectangle is completed. 

Circle Draw circles by holding down the left mouse button while drawing. Release the 

mouse button when the circle is completed. 

Ellipse Draw ellipses by holding down the left mouse button while drawing. Release the 

mouse button when the ellipse is completed. 

Text Select the Text tool to enter text in the drawing.  Holding down the left mouse button 

while outlining the area for the text. Release the mouse button when the area is 

completed.  Type the text in the outlined box. 

  

Hot Spot Use this command to select the Hot Spot tool to draw rectangles representing hot 

spots by holding down the left mouse button while drawing. Release the mouse 

button when the door is completed.  To activate this selection, select ―Hot Spot 

Assignment‖ in the Room Assignment dialog box.  Left-click and hold the mouse 

button at one corner of the area selected, and drag mouse to include the area desired.  

Ensure to include the walls of the designated area.  Release button when area is 

selected.  The selected area is pastel red and the walls of the area red. 

  

The Options menu offers the following commands, are also present in 

Options palette: 

  

These commands are present in building layout. 

Add Floor Layout When i n the composite drawing building 

layout utility, use this command to add a 

floor layout.  A dialog box appears to open 

the floor layout to be included in the 

building. 

  

Add Device Layout When in the composite drawing device 

layout utility, use this command to add a 

device.  A dialog box appears to open the 

device to be included in the device layout. 
  

These commands are present in floor layout. 

Select Floor Plan When in a composite drawing floor layout 

utility, use this command to add a floor plan.  

A dialog box appears to open the floor plan 

to be inclu ded in the floor layout. 

  

Add Furniture When in a floor layout, use this command to 

add furniture.  A dialog box appears to open 

the furniture piece to be included in the floor 

layout. 

  



Add Appliance When in a floor layout, use this command to add appliances.  A dialog box appears 

to open the device to be included in the floor layout. 

  

Add Device When in a floor layout, use this command to add devices.  A dialog box appears to 

open the device to be included in the floor layout. 

  

Room Assignment Use this command to display a dialog box to assign room number and names and to 

assign a space in the floor layout that corresponds to the room number.  Click the 

―Add‖ button to display a dialog box that assigns room number and name.  Enter 

values for number and name.  Click ―OK‖.  The newly entered name and room 

number is displayed in the table.  To designate the room that corresponds to the 

selected room in the list, choose the ―Hot Spot Assignment‖ radio button.  . 
  

  

  

The Help menu offers the following commands, which provide you assistance with this application: 

  

Help Topics Use this command to display the opening screen of Help. From the opening screen, 

you can jump to step-by-step instructions for using Designer and various types of 

reference information. 

  

After Help opens, click the Contents button to return to the opening screen. 

  

About FSD Designer  Displays copyright notice and the version number of this application. 

  

  

For detailed instructions on using FSD Designer to create a floor plan and layout, view the tutorial.  From the 

Help menu in FSD Automator, choose View Tutorials to initiate a slide show tutorial. 

  

  

FSD Operator 
  

FSD Operator Overview 
The FSD Operator configures the various operations of the devices on the system.  Dialog boxes are displayed for 

the user to assign the device‘s element operation, to set operations, to enable or disable the elements, and to set 

operational parameters for the elements.  Other dialog boxes are available for the operator to compare operations, to 

set logical operations, to set feedback control operations, and to scale operations, when these operations are 

appropriate. 

  

  

FSD Operator Menu Layout 
The FSD Operator configures the various operations of the devices on the system.  Dialog boxes are displayed for 

the user to assign the device‘s element operation, to set operations, to enable or disable the elements, and to set 

operational parameters for the elements.  Other dialog boxes are available for the operator to compare operations, to 

set logical operations, to set feedback control operations, and to scale operations, when these operations are 

appropriate. 

  

  

FSD Operator  
  

Selecting a device family from the operations menu displays a dialog box to select 

a device name from a droplist.  If one selects a particular device type from the 

Device Type droplist, a refined list of devices is displayed.   

  

  

Clicking ―OK‖ displays an indexed property page dialog box for the device.  For 

each index page the Element Type information for the device is listed, including 

Device Name, Element Name, Plus status, and Operation. 



  

Button Actions: 

Load – Loads the updated configuration to the controller.  
OK – Saves the configuration and closes dialog. 

Add – Displays Operation dialog to add a new operation. 

Delete – Deletes the selected operation. 

Cancel – Closes the dialog without saving changes. 

  

Double-clicking on a listing in the table will display the 

Device Element Operation dialog. 

  

  

  

  

  

  

  



Device Element Operation 

  

Dialog box displays the Device Mode.  The user can 

select an operation from the droplist by clicking on the 

list.  Select a radio button to designate whether the 

operation is for all operating modes, any mode selected, 

multi-modes, or none.  Couple the operation to a device 

by assigning the device family, device type, device 

name, and device element from droplist (middle portion 

of dialog box).   

  

In the table listing box for operating modes, selecting 

and double-clicking on the operation will toggle 

enabling and disabling of the operation. 

  

In Input Options the user can invert the input value by 

checking the box.  Thus, a TRUE input will be read as 

a FALSE value, and conversely.  The same can be 

selected for Output Options.  Additionally, the user can 

specify that the output occurs if TRUE or if the output 

value is FALSE.  Using the radio buttons, choose 

whether these Output Options never apply, applies on 

input change, applies on output change, or always 

applies. 

  

Choose ―OK‖ to accept changes or ―Cancel‖ to close 

dialog without saving changes. 

  

  

  

  

  

  

  

Compare Operation 

  

This dialog is identical the Device Element Operation dialog with the addition of an edit box to enter a value to 

compare and removal of the Invert Input checkbox.  Choose ―OK‖ to accept changes or ―Cancel‖ to close dialog 

without saving changes. 

  

  

Logical Operation 

  

This dialog is identical the Device Element Operation dialog with the addition of a second set of droplists for device 

family, device type, device name, and device element.  There is an additional checkbox to specify ―Invert Input2‖.  

Choose ―OK‖ to accept changes or ―Cancel‖ to close dialog without saving changes. 

  

  

Feedback Control Operation 

  

When the operation is feedback_control, this operation edit box appears.  This dialog is identical the Logical 

Operation dialog with the addition of edit boxes to enter a Feedback Scale value and a Feedback Offset value; and 

the deletion of the ―Invert Input‖ checkbox.  Choose ―OK‖ to accept values or ―Cancel‖ to close dialog without 

saving changes. 

  

  

Scale Operation  
  

When the operation is scale_value, this operation edit box appears.  This 

dialog is identical the Device Element Operation dialog with the addition 

of edit boxes to enter values for Scale, Offset, Upper Bound and Lower 

Bound.  Choose ―OK‖ to accept values or ―Cancel‖ to close dialog 



without saving changes. 

  

  

Operation dialog 

  

When the ―Add‖ button is clicked, the Operation Dialog appears.  This dialog allows the user to click in the droplist 

to assign an operation for the Device Mode listed. 

  

Choose ―OK‖ to accept changes or ―Cancel‖ to close dialog without saving changes. 

  

  

Variable Operation 

  

Displays a dialog to choose a variable type for the operation 

  

Choose ―OK‖ to accept changes and display a tabbed index property display for the device operations; or ―Cancel‖ 

to close dialog without saving changes. 

  

  

  



FSD Builder 
  

FSD Builder Overview 
FSD Builder builds the image of the data set for loading into the controller. 

  

  

FSD Builder Menu 
FSD Builder builds the image of the data set for loading into the controller. 

  

The File menu commands are: 

Open – calls the Open dialog to select the image file (.fmp) to build. 

Build Image Now – builds the image for use by the controller 

Recent file – opens most recent image file 

Exit – closes the application. 

  

The View menu commands are: 

Toolbar 

Folder icon   Open an existing document.  FSD Builder displays the Open dialog box, in which you can locate 

and open the desired file. 

  

―B‖ button – clicking this button builds the image for use by the controller. 

  

Status Bar 

The status bar is displayed at the bottom of the FSD Builder window.  To display or hide the status bar, use the 

Status Bar command in the View menu. 

  

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through 

menus.  This area similarly shows messages that describe the actions of toolbar buttons as you depress them, 

before releasing them.  If after viewing the description of the toolbar button command you wish not to execute 

the command, then release the mouse button while the pointer is off the toolbar button. 

  

The right areas of the status bar indicate which of the following keys are latched down: 

  

  

Indicator Description 

  

CAP The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

  

The Help menu offers the following commands, which provide assistance with this application: 

  

Help Topics Use this command to display the opening screen of Help. From the opening screen, you can jump 

to step-by-step instructions for using Builder and various types of reference information. 

  

After Help opens, click the Contents button to return to the opening screen. 

  

About FSD Builder Displays copyright notice and the version number of this application. 

  

  

  



FSD Loader 

FSD Loader Overview  
FSD Loader loads a FSD formatted file to the FSD Controller or other FSD devices attached to the system. 

FSD Loader Menu Layout 

File Menu 
Use either the Exit command or the Close command on the application Control menu to end the FSD Loader 

session.  FSD Loader prompts you to save documents with unsaved changes. 

  

View Menu 
The toolbar is displayed across the top of the application window, below the menu bar.  The toolbar provides 

quick mouse access to many tools used in FSD Loader. 

  

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T). 

  

Click To 
―L‖ button Loads a FSD formatted file to the controller or attached FSD device. 

  

―O‖ button Offloads log data from a device, clearing the device data log. 

  

―A‖ button Attaches a J1708 device and switches to FSD packet mode. 

  

―D‖ button Detaches a previously attached device and switches to native mode. 

  

  

The status bar is displayed at the bottom of the FSD Loader window.  To display or hide the status bar, use the 

Status Bar command in the View menu. 

  

The left area of the status bar describes how menu items act, as one uses the arrow keys to navigate through 

menus.  This area also shows messages that describe the actions of toolbar buttons they are depressed, before 

releasing them.  If you decide not to execute the command, release the mouse button when not pointing to the 

toolbar button. 

  

The right areas of the status bar indicate which of the following keys are latched down: 

  

Indicator Description 
CAP The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

  

  
Load menu 
Load FSD File -- loads an FSD formatted file to the controller or attached FSD device.  
  

Offload Device Data -- offloads device data from the controller or attached FSD 

device to the computer. 

  

Attach Device -- sends a J1708 command to attach a J1708 device using the FSD 

packet communication mode. 

  

Detach Device -- detaches a previously attached 

device and sends the device a command  to revert 

to its native communications mode. 

  

Load to Boot – The Load Boot command loads a 

binary controller boot file to the controller. 

  

Load to App – The Load Application command 

loads a binary controller application file to the 

controller. 

  Options Menu 
Set Loader Options 



  

Use this dialog box to select TCP/IP 

socket options and debug options. 

  

Controller Name ID:  displays the unique 

ID assigned to the controller.   

  

TCP/IP address -- choose the appropriate radio button that corresponds to your situation: 

 Local Machine only 

 Use Address From Directory to identify computer hosting the FSD Router application. 

 Use LAN IP Address—enter the IP address of computer hosting the FSD Router application. 

 Use Internet IP Address—enter the address of the machine hosting the FSD Router application.  If using FSD 

Loader on the same machine as FSD Router, set the TCP/IP address to its default local host value, 127.0.0.1. 

  

Router IP Port – use this port to connect to and communicate with FSD Router and its connected serial port 

devices.  Note that the specified port must match the port selected in the FSD Router application.  For access 

via a firewall protected link, the specified port must be given access permission. 

  

FSD Loader Watch Level -- selects the quantity of debug information presented on the FSD Loader view window.  

Watch Level 0 displays the least amount of information, with increasing levels showing more detailed debugging 

information. 

  

FSD Controller Watch Level -- selects the quantity of debug information to be sent from a connected FSD 

Controller.  The FSD Controller debug information is presented on the FSD Loader view window.  Watch Level 0 

disables most output, with increasing levels used to show more detailed debugging information. 

  

Debug Options—select the options desired: 

Enable Debug File -- All view window test and other information are logged in DEBUG.TXT, found in the 

computer‘s TEMP directory.  These directories are set in the computer‘s environment variables. 

  

Enable Debug Crash -- Flushes the debug output to the file after each write.  This action ensures completed writes 

while debugging application crash conditions. 

  

Create New Debug File -- Starts a new file upon FSD Loader startup (otherwise debug information is appended to 

the previous file). 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set Product Configuration Info  
This dialog box displays information about the FSD Controller attached to the system.  From the droplist ensure  



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

that the correct HW (hardware) Product Name.  In the same column hardware information about the particular 

device is displayed.  In the adjacent column is displayed the SW (software) application associated with the 

hardware product.  Included in the information displayed is the supported controller and information on the device 

family types that can be controlled by the hardware. 

 

 

 

 

 

 

 

 

 

 

Help Menu 
The Help menu offers the following commands, which provide you assistance with this application: 

  

Help Topics Use this command to display the opening screen of Help. From the opening screen, you can jump 

to step-by-step instructions for using Loader and various types of reference information. 

  

Once you open help, you can click the Contents button whenever you want to return to the opening screen. 

  

About FSD Loader Displays copyright notice and the version number of this application. 

  

 

  

  

 FSD X10 Logger 
  

FSD X10 Logger Overview 
  

FSD X10 Logger records conversation between controller and X10 devices into a text file.  Under the Options menu 

the user can set the path for the log file and also whether to create a new file or append to existing file. 

  



This tool is useful for debugging problems during the configuration of the system.  The commands sent between 

FSD Controller and X10 devices are displayed in the FSD X10 Logger window.  The date and time are displayed 

along with the direction (<= to the controller; => from the controller), along with the unit and house code. 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

FSD X10 Logger Menu 
The File menu offers the following commands: 

  

Exit Exits FSD X10 Logger. 

  

  

The View menu offers the following commands: 

  

Clear Display Clears the X10 activity history log display. 

Toolbar Shows or hides the toolbar. 

―C‖ button Clears the logger display 

―L‖ button Toggles the enable file logger function 

―O‖ button The Set X10 Logger Options command invokes a dialog box, which allows setting the path name 

and file creation or appending options used when logging X10 command activity. 

  

Status Bar Shows or hides the status bar. 

  

  

The Log menu offers the following command: 

  

Log File Enable/Disable Enables / Disables logging of the received X10 commands. 

  

  

The Options menu offers the following commands: 

  

  

Set X10 Logger Options Selects X10 Logger options to set path for the logger file and to select creation 

of a new file or appending to existing file. 

  

  

The Help menu offers the following commands, which provides assistance with this application: 

  

Help Topics Offers you an index to topics on which you can obtain help. 

About FSD X10 Logger Displays the version number of this application. 

  

  



FSD X10 Mapper  
  

FSD X10 Mapper Overview 
X10 Mapper is a utility that displays defined and detected X10 devices on the system.  X10 devices defined in the 

FSD Controller are depicted as fuschia colored boxes.  Detected devices (e.g. when a signal is sent with an unit and 

house code) are depicted as lavender colored boxes.   

  

FSD X10 Mapper  
X10 devices defined in the FSD Controller are depicted as fuschia colored boxes.  Detected X10 devices are 

depicted by the lavender colored boxes.  The Show button displays all defined and detected devices (Fig A).  The 

Hide button changes the display to only show those devices that are detected (Fig B).  Devices that are both defined 

and detected are indicated with half fuschia and half lavender colored boxes.  The Clear button clears the display of 

detected devices.  By choosing the ―Group‖ radio button, defined and detected groups are displayed instead of 

individual units (Units radio button).  Clearing of detected devices or groups and Hiding of defined devices or 

groups can also be implemented by right-clicking on the title bar and choosing the desired action from the menu.  

Use the Start button to initiate a search on the system to detect X10 devices that are capable of answering to a query 

(2-way communication, this process may take several minutes).   

  

  

 

  

 

 

 

 

 

 

 

 

 

  



FSD X10 Tester 
  

  

FSD X10 Tester Overview 
The FSD X10 Tester utility sends various commands to a specified X10 device.  These commands enabled the user 

to test a device with a group of commands to determine if the device responds to commands properly. 

  

  

FSD X10 Tester 
The FSD X10 Tester utility sends various commands to a specified X10 device.  Set the house and unit codes for the 

target device.  Listed are a variety of commands.  Click the Send button adjacent to the command to send.  A sent 

command is noted in the box adjacent to the command.  Buttons are present to send ON/OFF commands 

continuously and also to clear received commands. 

  

  

  

  

  



FSD UPB Logger 
  

FSD UPB Logger Overview 
  

FSD UPB Logger records conversation between controller and UPB devices into a text file.  Under the Options 

menu the user can set the path for the log file and also whether to create a new file or append to existing file. 

  

This tool is useful for debugging problems during the configuration of the system.  The commands sent between 

FSD Controller and UPB devices are displayed in the FSD UPB Logger window.  The date and time are displayed 

along with the direction (<= to the controller; => from the controller), along with the network and unit id. 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

FSD UPB Logger Menu 
The File menu offers the following commands: 

  

Exit Exits FSD UPB Logger. 

  

  

The View menu offers the following commands: 

  

Clear Display Clears the UPB activity history log display. 

Toolbar Shows or hides the toolbar. 

―C‖ button Clears the logger display 

―L‖ button Toggles the enable file logger function 

―O‖ button The Set UPB Logger Options command invokes a dialog box, which allows setting the path name 

and file creation or appending options used when logging UPB command activity. 

  

Status Bar Shows or hides the status bar. 

  

  

The Log menu offers the following command: 

  

Log File Enable/Disable Enables / Disables logging of the received UPB commands. 

  

  

The Options menu offers the following commands: 

  

  

Set UPB Logger Options Selects UPB Logger options to set path for the logger file and to select creation 

of a new file or appending to existing file. 

  



  

The Help menu offers the following commands, which provides assistance with this application: 

  

Help Topics Offers you an index to topics on which you can obtain help. 

About FSD UPB Logger Displays the version number of this application. 

  

  



FSD UPB Mapper  
  

FSD UPB Mapper Overview 
UPB Mapper is a utility that displays defined and detected UPB devices on the system.  UPB devices defined in the 

FSD Controller are depicted as fuschia colored boxes.  Detected devices (e.g. when a signal is sent with an unit and 

house code) are depicted as lavender colored boxes.   

  

FSD UPB Mapper  
UPB devices defined in the FSD Controller are depicted as fuschia colored boxes.  Detected UPB devices are 

depicted by the lavender colored boxes.  The display grid shows the unit number.  Each row has 15 boxes.  To 

determine the unit number add the number of the column to the number of the row (e.g column 15 and row 240 

results in unit number 255).  The Show button displays all defined and detected devices.  The Hide button changes 

the display to only show those devices that are detected (shown).  Devices that are both defined and detected are 

indicated with half fuschia and half lavender colored boxes.  The Clear button clears the display of detected devices.  

By choosing the ―Network‖ or ―Link‖ radio button, defined and detected networks or links are displayed instead of 

individual units (Units radio button).  Clearing of detected devices, links, or networks and Hiding of defined devices, 

links, or networks can also be implemented by right-clicking on the title bar and choosing the desired action from 

the menu.  Use the Start button to initiate a search on the system to detect UPB devices that are capable of answering 

to a query (2-way communication, this process may take several minutes).   

  

  

  



FSD UPB Tester 
  

  

FSD UPB Tester Overview 
The FSD UPB Tester utility sends various commands to a specified UPB device.  These commands enabled the user 

to test a device with a group of commands to determine if the device responds to commands properly. 

  

  

FSD UPB Tester 
The FSD UPB Tester utility sends various commands to a specified UPB device.  Set the network, destination, and 

source ids from the droplists for the target device.  Choose whether the test is direct or to a link and the repeat 

transmission rate.  Check the appropriate box for requesting an acknowledgement pulse, acknowledgement message, 

or ID pulse.  Select the transmit count and sequence number from the droplists.  Listed are a variety of commands.  

Click the Send button adjacent to the command to send.  A sent command is noted in the box adjacent to the 

command.  Buttons are present to send ON/OFF commands continuously and also to clear received commands. 

  

 

  

 

 

 

  



 FSD Controller Example Scenarios  

 
Select the scenario example below to display a quick guide to accomplish the procedure using an 

FSD Controller.  

 

Configure Switch-Lamp Connection – Step-by-step instructions to configure a switch to control a 

lamp module.  

 

Configure Event Timer – Step-by-step instructions to configure a Time of Day Event to control a 

lamp module.  

 

Configure X10-UPB Bridge – Step-by-step instructions to configure an FSD X10-UPB Bridge 

Controller to link X10 Devices with UPB Devices.  

 

Configure X10-UPB-FGI Bridge – Step-by-step instructions to configure an FSD X10-UPB-FGI 

Bridge Controller to link X10 Devices, UPB, and FGI Devices.  

 

Configure X10-UPB-FGI Bridge Plus – Step-by-step instructions to configure an FSD X10-UPB-

FGI Bridge Controller Plus to link X10 Devices, UPB, and FGI Devices, and also to configure for 

time of day events.  

 

Configure Alarm Clock – Step-by-step instructions to configure an Alarm Clock device that control 

up to three devices. The first device is triggered similar to a time of day event (alarm), and the next 

two are triggered based on a programmed delay of the preceding device‘s start time.  

 

Configure Fade Timer – Step-by-step instructions to configure a Fade Timer to control a lamp 

module. When programmed a fade timer dims or brightens a lamp to a hold level, held for a specified 

time before proceeding to the next programmed level.  

 

Configure Retriggerable Timer – Step-by-step instructions to configure a Retriggerable Timer. This 

timer can be programmed, to respond to a trigger by delaying onset, turned on for a specified time, 

and rendered inactive for a stated time. If desired, subsequent triggers during the active period can 

result in a lengthened active period.  

 

Configure Delay Timer – Step-by-step instructions to configure a Delay Timer to control a lamp 

module. This timer allows the user to trigger up to eight output events, each a specified step level 

delay time apart.  

 

Configure Button Control – Step-by-step instructions to configure a Button Control non-time based 

Timer device to control a lamp module.  

 

Configure Multi-Switch Device – Step-by-step instructions to configure a device with multiple 

switches 

 

Configure Sensor Device to Control Another Device – Step-by-step instructions to configure a 

Sensor Device (e.g. temperature/humidity sensor) to control another device.  

 

Configure Bridging of UPB Link Commands to X10 – Step-by-step instructions to configure an FSD 

Bridge Controller to use UPB Link Commands to control X10 Devices.  

 

FSD Multiple Controller Configuration Guide – Describes steps to configure multiple FSD 

controllers on the same computer.  

 



Multiple FSD Bridges to Send Common UPB Signals on Independent Power Lines Configuration 

Guide – Describes steps to configure multiple FSD Bridge controllers to transmit common UPB 

signals onto different power line sources within the same building.  

Configure FSD Logger -- Describes steps to configure program to create log file of FSD device state 

activities. 

Configure Operating Modes – Describes steps to configure multiple operating modes.  



Simple Example to Configure a Switch to Lamp Module 

  

The example illustrates how to configure an X10 System to enable a switch to control a lamp 

module.  The same procedure applies to other device families. 

  

  

Initial system set-up - add FSD Controller, power line interface, lamp module, and switch to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

6. Click the Insert button.  In the next dialog box, from the droplist choose X10 Switch.  

Enter a Device Name, set the house and unit code (e.g. A and 1).  Click ―OK‖. 

7. In the X10 Device List window, click the Insert button again.  From the droplist choose 

X10 Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  

Click ―OK‖. 

8. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Link Devices by Setting Operations - configure devices and link device elements using 

operations 

  

1. From FSD Automator, choose X10 Devices from the Operations menu.  Choose the X10 

switch you‘ve entered.   

2. A tabbed index dialog appears.  On the tabs are the different element types on the switch.  



Click on ―From Momentary On‖.  This ―From‖ element sends a momentary on signal 

and connects to a ―To‖ element on another device (e.g. lamp module).  Click ―Add‖, to 

add an operation that connects the From and To elements.  From the droplist select 

SET_MONENTARY_PAIR.   

3. In the resulting dialog, select the device family to connect with the ―To‖ element, the 

device type, and device name.  Choose X10, X10 lamp module, and the name you‘ve 

entered, respectively.  The Device element is Momentary On.  Click ―OK‖. 

4. In the tabbed index dialog, click ―Load‖ to Load Configuration.   

5. When loading finishes, choose X10 Devices from the Operations menu.  Choose the lamp 

module you‘ve entered.  Click the ―To Momentary On‖ element.  Listed is the operation 

that links to the switch you‘ve entered.  You have configured the system to have a 

switch of one address control the lamp module with a different address. 

6. From the Display menu, choose X10 Devices and the x10 switch you entered.  If there is a 

lamp device on the system with the address B-2, clicking on the ―ON‖ and ―OFF‖ button 

controls the lamp device. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Configuring other device family systems is similar to the X10 system described above.  For 

example, with an UPB system, substitute X10 component with its UPB counterpart (i.e. 

powerline interface, network and unit code).   

  
  

  



Simple Example to Configure a Timer Event 

  

The following example shows how a Time of Day Event Timer can control a lamp module.  X10 

devices are used in the example, but apply similarly to other device families. 

  

  

Initial system set-up - add FSD Controller, power line interface, and lamp module to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert 

button.  From the droplist choose X10 

Appliance Module.  Enter a Device Name, 

set the house and unit code (e.g. H and 8).  

Click ―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If 

queried by a dialog box, choose to load 

configuration later. 

  

 Configure Timer and Set Operations - configure 

timer device and link device elements 

  

1. In FSD Automator‘s View menu, choose FSD 

Namer to assign a Timer, Etc. device.  In the 

Timer List dialog, click the Insert button.  In 

the Edit Timer dialog, choose Time of Day 

Event from the Timer Type droplist.  Enter a 

name for the timer.  Click ―OK‖. 

2. From FSD Automator, choose Timers, Etc. 

from the Display menu.  Select the Time of 

Day Event device type and the device name 

you‘ve entered.  Click ―OK‖.  In the Time of 

Day Event dialog (the device dialog) with 

the device name in the title bar, right-click 

on the title bar and select Configure Event 

Times from the menu list. 

3. In the Configure <device name> dialog, set the 

Start and Stop times desired.  In the lower 

third of the dialog box, select the days the 

timer is enabled and the date range.  Click 

―OK‖. 

4. Either right-click the title bar in the device 

dialog and select Configure Operations from 

the menu or from FSD Automator, choose 

Timers, Etc. from the Operations menu.  

Choose the timer you‘ve entered.   

5. A tabbed index dialog appears.  On the tabs are the different element types on the Time of 



Day Event device.  Click on ―From Event State‖.  This ―From‖ element sends a signal 

and connects to a ―To‖ element on another device (e.g. lamp module).  Click ―Add‖, to 

add an operation that connects the From and To elements.  From the droplist select 

SET_MONENTARY_PAIR.   

6. In the resulting dialog, select the device family to connect with the ―To‖ element, the 

device type, and device name.  Choose X10, X10 appliance module, and the name 

you‘ve entered, respectively.  The Device element is Momentary On.  Click ―OK‖. 

7. In the tabbed index dialog, 

click ―Load‖ to load the 

configuration.   

8. When loading finishes, choose 

X10 Devices from the 

Operations menu.  Choose 

the appliance module 

you‘ve entered.  Click the 

―To Momentary On‖ 

element.  Listed is the 

operation that links to the 

timer you‘ve entered.  You 

have configured the system 

for an event timer to control 

an appliance module. 

9. From the device dialog of the 

time of day event, click on 

the Event State button 

(button should change from 

False to True.  If there is a 

appliance device on the 

system with the address H-

8, changing the event state 

should turn on and off the 

appliance module. 

  

 

 

 

 

 

 

The preceding example uses X10 family devices.  However, devices from a different device 

family can be substituted (e.g. UPB devices).  Link elements using operations as described 

above.   

 Simple Example to Configure an FSD X10-UPB Compact Bridge Controller 

  

The FSD X10-UPB Compact Bridge Controller allows the user to construct a system mixed with 

X10 and UPB devices to work with one another.  To accomplish this, configure the controller so 

it knows which X10 addresses are coupled to corresponding UPB unit ids.  The following 

example describes how to use the FSD X10-UPB Compact Bridge Controller.  The first and 

second examples demonstrate how to use FSD virtual devices, Super Bridge and Super Fine 

Bridge, to link UPB devices with X10 devices.  The third example illustrates connecting an UPB 

switch to an X10 lamp module using a one-on-one connection.   

  



Initial system set-up for configuration  
If you have already added the controller, X10 and UPB powerline interfaces, X10 devices and 

UPB devices to the system configuration, skip this section.  If you have not installed the FSD 

Bridge Controller Software, you can install from the CD provided with the FSD Bridge 

Controller.  Instructions are found under the Help menu  ->View Installation Guides, and choose 

FSD X10-UPB Bridge Controller from the list.  Add FSD Controller and power line interfaces 

using FSD Namer. 

  

1. Connect the power supply to the controller and a NULL MODEM cable (also called 

twisted cable, do not use a straight serial cable) from the serial port of your computer to 

the serial port on the controller. 

2. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

3. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device), an UPB Power Line interface (e.g. PIM, an RS485/232 device), and an X10 

Power Line Interface to the system (e.g. TW523, a Timer Etc. device). 

   

If you already have a list of addresses to couple X10 to their respective UPB unit ids, you do not 

need to enter each X10 and UPB device into the system‘s configuration.  To finish configuration, 

couple the X10 with UPB devices using either Super Bridges or Super Fine Bridges (skip to 

subsequent sections). 

  

If you wish to bridge devices using a one-on-one connection, use the following example to enter 

devices into the system.   

1. From the FSD 

Automator 

application, select 

FSD Namer-> X10 

Devices from the 

View menu. 

 

2. Select FSD Namer-> 

UPB Devices 

from the View 

menu.  Click the 

Insert button.  In 

the next dialog 

box, from the 

droplist choose 

UPB Switch.  

Enter a Device 

Name, set the 

network and unit 

code assigned to 

the device.  Click 

―OK‖.  Click 

―OK‖.  If queried 

by a dialog box, 

choose to load configuration later. 

3. Select FSD Namer-> X10 Devices from the View menu.  In the X10 Device List window, 

click the Insert button again.  From the droplist choose X10 Lamp Module.  Enter a 

Device Name, set the house and unit code (e.g. B and 2).  Click ―OK‖. 

4. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 



configuration later. 

  

  

FSD Super Bridge 

  

The FSD Super Bridge is a virtual device in the Timers, Etc. device family.  As mentioned in the 

last section, it is possible to link one-by-one an X10 address with an UPB address.  However, 

linking device elements with operations for multiple devices can be a tedious task assigning a 

number of switches to corresponding modules.  To simplify this task, use an FSD Super Bridge if 

you have a minimum of four sequentially numbered X10 addresses linked to four sequentially 

numbered UPB units.  [If you don‘t have sequentially numbered devices, use the FSD Super Fine 

Bridge (see next section).]   Super Bridges come in 8 or 16 links sizes.  Thus, for example if you 

planned C1 through C4 X10 addresses to signal UPB unit ids 006 through 009, do the following: 

  

1. Select FSD Namer-> Timers, Etc. from the View menu.  In the Timers, Etc. List window, 

click the Insert button.  From the droplist choose Super Bridge 8.  Enter a Device Name 

and click ―OK‖.  If asked, load configuration later. 

2. Select Timers, Etc. from the Configure menu, and choose the Super Bridge 8 you just 

entered.  In the Configure dialog box, double-click on the first entry line (1-4).   

3. In the Edit Bridge Group dialog choose X10 for the Input Settings.  Enter ―C‖ for the 

house code and ―1‖ for the unit code.  Choose UPB for the Output Settings and enter the 

network id and unit id 006.  Click ―OK‖.  Click ―OK‖.  Choose Load Configuration 

under the File menu. 

4. Thus activating X10 

addresses C1 through 

C4, controls UPB 

devices with unit ids 006 

through 009 respectively. 

  

Assigning the other four 

addresses is easy.  In Step 2 

choose the entry line 5-8 and 

select the ―Inherit Settings‖ 

check box if the UPB devices 

are the next numbers in 

sequence.  Otherwise assign the 

beginning sequence unit id you 

wish to use for X10 addresses 

(e.g. H5 through H8) to control 

the UPB devices (e.g. 145 

through 148). 

  

If your planned addresses are not 

sequentially numbered, use a 

Super Fine Bridge (next section) 

  

  

  

Configuring FSD Super Fine Bridge 

  

The FSD Super Fine Bridge is a virtual device akin to the Super Bridge.  The Super Bridge is a 

convenient tool used to configure sequential numbered X10 devices with sequentially numbered 



UPB devices (minimum of four devices must be sequential).  However, if your devices are not 

sequentially numbered, use the FSD Super Fine Bridge. 

  

1. As with other devices, insert an instance of a 

FSD Super Fine Bridge (a Timers, Etc. type 

device) using FSD Namer.  Select FSD 

Namer-> Timers, Etc. from the View menu.  

In the Timers, Etc. List window, click the 

Insert button.  From the droplist choose 

Super Fine Bridge 16.  Enter a Device 

Name and click ―OK‖.  If asked, load 

configuration now. 

2. From the Configure menu choose the 

Timers, Etc. super fine bridge that you 

inserted.  Note:  Settings are grouped in sets 

of four UPB or X10 devices.  The device 

family settings for switches 1, 5, 9, and 13 

apply to the subsequent three switches.  In 

the figure below, the dialog box in the 

background shows that the first set of 

switches bridges input from the UPB device 

family and outputs to the X10 device 

family.  As seen in the listbox neither the 

UPB nor the X10 devices are in sequential 

order.  The second set of four are X10 input with UPB output.   

3. The dialog box in the foreground edits the settings for switch 9.  Checking the ―Inherit 

Settings‖ box sets the input and output settings to the previous switches device settings.  

If ―Inherit Settings‖ is not selected, the device family droplist boxes become active for 

selection.  Check the ―Enable Bridge Operation‖ box to enable bridging of this switch 

and the ―Enable Dimmer Operation‖ box if the device bridged has dimming capability.   

4. Enter the X10 address and UPB address that you wish to bridge. 

5. Add the input and output device addresses and in the upper right corner, indicate the 

bridging direction: input to output (normal), output to input, or bidirectional.   

  

  

Link X10 and UPB Device with Operations 

  

For more complicated operations other than switching on and off with dimming than can be 

accomplished with Super Bridges or 

Super Fine Bridges, use operations to 

link devices.  Each device type has 

specific types of elements associated 

with them.  Elements are the 

interfaces between devices.  

Operations are used to connect the 

elements with one another.  Each 

element has specific operations 

associated with them.  The following 

example shows the steps to link a 

UPB switch to an X10 lamp module.  

1. From FSD Automator, choose 

UPB Devices from the 



Operations menu.  Choose the UPB switch you‘ve entered in the one-on-one 

connection section on page 1.   

2. A tabbed index dialog appears.  On the tabs are the different element types associated with 

the switch.  Click on ―From Momentary On‖.  This ―From‖ element sends a momentary 

on signal and connects to a ―To‖ element on another device (e.g. lamp module).  Click 

―Add‖, to choose an appropriate operation that 

connects the From and To elements.  From the 

droplist select SET_MONENTARY_PAIR.   

 

3. In the resulting dialog, from the droplists (a) select 

the device family to connect with the  ―To‖ 

element, (b) the device type, and (c) device name.  

Choose X10, X10 Lamp Module, and the name 

you‘ve entered, respectively.  The Device element 

is Momentary On.  Click ―OK‖. 

4. In the tabbed index dialog, click ―Load‖ to Load 

Configuration.   

5. When loading finishes, choose X10 Devices from the 

Operations menu.  Choose the lamp module 

you‘ve entered.  Click the ―To Momentary On‖ 

element.  Listed is the operation that links to the 

UPB switch you‘ve entered.   

  

You have configured the system to enable an UPB 

switch to control the X10 Lamp Module. 

  

  

  

  

  

  

  

  

Connecting FSD X10-UPB Bridge to your system 

  

1. After configuring the controller, disconnect the power supply and the NULL MODEM 

cable from the controller.   

2. Connect the serial cable connected to the UPB Power Line interface to the serial port of 

the FSD X10-UPB Bridge Controller. 

3. Connect the RJ11 data cable (not telephone cable) from the X10 Power Line interface to 

the X10 Out port of the controller. 

4. Connect the power supply.  The FSD X10-UPB Bridge Controller is set to bridge UPB and 

X10 protocols in a mixed X10/UPB installation.  
  

  



Simple Example to Configure an FSD X10-UPB-FGI Bridge Controller 

  

The FSD X10-UPB-FGI Bridge Controller allows the user to construct a system mixed with 

X10, UPB, and FGI devices to work with one another.  To accomplish this, configure the 

controller so it knows which X10 addresses are coupled to corresponding UPB unit ids.  The 

following example describes how to use the FSD X10-UPB-FGI Bridge Controller.  The first 

and second examples demonstrate how to use FSD virtual devices, Super Bridge and Super Fine 

Bridge, to link UPB devices with X10 devices.  The third example illustrates connecting an UPB 

switch to an X10 lamp module using a one-on-one connection.  In a similar fashion one can 

bridge an FGI device with either X10 or UPB device. 

  

Initial system set-up for configuration  
If you have already added the controller, X10 and UPB powerline interfaces, X10 devices and 

UPB devices to the system configuration, skip this section.  If you have not installed the FSD 

Bridge Controller Software, you can install from the CD provided with the FSD Bridge 

Controller.  Instructions are found under the Help menu  ->View Installation Guides, and choose 

FSD X10-UPB Bridge Controller from the list.  Add FSD Controller and power line interfaces 

using FSD Namer. 

  

1. Connect the power supply to the controller and either an USB cable from the computer or 

a NULL MODEM cable (also called twisted cable, do not use a straight serial cable) 

from the serial port of your computer to the serial port on the controller. 

2. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

3. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device), an UPB Power Line interface (e.g. PIM, an RS485/232 device), and an X10 

Power Line Interface to the system (e.g. TW523, a Timer Etc. device). 

  

If you already have a list of addresses to couple X10 to their respective UPB unit ids, you do not 

need to enter each X10 and UPB device into the system‘s configuration.  To finish configuration, 

couple the X10 with UPB devices using either Super Bridges or Super Fine Bridges (skip to 

subsequent sections). 

  

  



If you wish to bridge devices using a one-on-one connection, use the following example to enter 

devices into the system.   

1. From the FSD 

Automator 

application, select 

FSD Namer-> 

X10 Devices from 

the View menu. 

2. Select FSD Namer-> 

UPB Devices 

from the View 

menu.  Click the 

Insert button.  In 

the next dialog 

box, from the 

droplist choose 

UPB Switch.  

Enter a Device 

Name, set the 

network and unit 

code assigned to 

the device.  Click 

―OK‖.  Click 

―OK‖.  If queried 

by a dialog box, 

choose to load configuration later. 

3. Select FSD Namer-> X10 Devices from the View menu.  In the X10 Device List window, 

click the Insert button again.  From the droplist choose X10 Lamp Module.  Enter a 

Device Name, set the house and unit code (e.g. B and 2).  Click ―OK‖. 

4. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

FSD Super Bridge 

  

The FSD Super Bridge is a virtual device in the Timers, Etc. device family.  As mentioned in the 

last section, it is possible to link one-by-one an X10 address with an UPB address.  However, 

linking device elements with operations for multiple devices can be a tedious task assigning a 

number of switches to corresponding modules.  To simplify this task, use an FSD Super Bridge if 

you have a minimum of four sequentially numbered X10 addresses linked to four sequentially 

numbered UPB units.  [If you don‘t have sequentially numbered devices, use the FSD Super Fine 

Bridge (see next section).]   Super Bridges come in 8 or 16 links sizes.  Thus, for example if you 

planned C1 through C4 X10 addresses to signal UPB unit ids 006 through 009, do the following: 

  

1. Select FSD Namer-> Timers, Etc. from the View menu.  In the Timers, Etc. List window, 

click the Insert button.  From the droplist choose Super Bridge 8.  Enter a Device Name 

and click ―OK‖.  If asked, load configuration later.  



2. Select Timers, Etc. 

from the Configure 

menu, and choose the 

Super Bridge 8 you 

just entered.  In the 

Configure dialog box, 

double-click on the 

first entry line (1-4).   

3. In the Edit Bridge 

Group dialog choose 

X10 for the Input 

Settings.  Enter ―C‖ 

for the house code 

and ―1‖ for the unit 

code.  Choose UPB 

for the Output 

Settings and enter the 

network id and unit id 

006.  Click ―OK‖.  

Click ―OK‖.  Choose 

Load Configuration 

under the File menu. 

4. Thus activating X10 

addresses C1 through C4, controls UPB devices with unit ids 006 through 009 

respectively. 

  

Assigning the other four addresses is easy.  In Step 2 choose the entry line 5-8 and select the 

―Inherit Settings‖ check box if the UPB devices are the next numbers in sequence.  Otherwise 

assign the beginning sequence unit id you wish to use for X10 addresses (e.g. H5 through H8) to 

control the UPB devices (e.g. 145 through 148).  Check ―Enable Dimmer Operation‖ if the 

devices have dimmer capabilities. 

  

If your planned addresses are not sequentially numbered, use a Super Fine Bridge (next section) 

  

Configuring FSD Super Fine Bridge 

  

The FSD Super Fine Bridge is a virtual device akin to the Super Bridge.  The Super Bridge is a 

convenient tool used to configure sequential numbered X10 devices with sequentially numbered 

UPB devices (minimum of four devices must be sequential).  However, if your devices are not 

sequentially numbered, use the FSD Super Fine Bridge. 

  

1. As with other devices, insert an instance of a FSD Super Fine Bridge (a Timers, Etc. type 

device) using FSD Namer.  Select FSD Namer-> Timers, Etc. from the View menu.  In 

the Timers, Etc. List window, click the Insert button.  From the droplist choose Super 

Fine Bridge 16.  Enter a Device Name and click ―OK‖.  If asked, load configuration now.  



2. From the Configure menu choose the 

Timers, Etc. super fine bridge that 

you inserted.  Note:  Settings are 

grouped in sets of four UPB or X10 

devices.  The device family settings 

for switches 1, 5, 9, and 13 apply to 

the subsequent three switches.  In the 

figure below, the dialog box in the 

background shows that the first set of 

switches bridges input from the UPB 

device family and outputs to the X10 

device family.  As seen in the listbox 

neither the UPB nor the X10 devices 

are in sequential order.  The second 

set of four are X10 input with UPB 

output.   

3. The dialog box in the foreground edits 

the settings for switch 9.  Checking 

the ―Inherit Settings‖ box sets the 

input and output settings to the 

previous switches device settings.  If 

―Inherit Settings‖ is not selected, the device family droplist boxes become active for 

selection.  Check the ―Enable Bridge Operation‖ box to enable bridging of this switch 

and the ―Enable Dimmer Operation‖ box if the device bridged has dimming capability.   

4. Enter the X10 address and UPB address that you wish to bridge. 

5. Add the input and output device addresses and in the upper right corner, indicate the 

bridging direction: input to output (normal), output to input, or bidirectional.   

  

  

Link X10 and UPB Device with Operations 

  

For more complicated operations other than switching on and off with dimming than can be 

accomplished with Super Bridges or Super Fine Bridges, use operations to link devices.  Each 

device type has specific types of elements associated with them.  Elements are the interfaces 

between devices.  Operations are used to connect the elements with one another.  Each element 

has specific operations associated with them.  The following example shows the steps to link a 

UPB switch to an X10 lamp module.  

1. From FSD Automator, choose UPB Devices from the Operations menu.  Choose the UPB 

switch you‘ve entered in the one-on-one connection section on page 1.   

2. A tabbed index dialog appears.  On the tabs are the different element types associated with 

the switch.  Click on ―From Momentary On‖.  This ―From‖ element sends a momentary 

on signal and connects to a ―To‖ element on another device (e.g. lamp module).  Click 

―Add‖, to choose an appropriate operation that connects the From and To elements.  

From the droplist select SET_MONENTARY_PAIR.   

3. In the resulting dialog, from the droplists (a) select the device family to connect with the 

―To‖ element, (b) the device type, and (c) device name.  Choose X10, X10 Lamp 

Module, and the name you‘ve entered, respectively.  The Device element is Momentary 

On.  Click ―OK‖. 



4. In the tabbed index dialog, click 

―Load‖ to Load 

Configuration.   

5. When loading finishes, choose 

X10 Devices from the 

Operations menu.  Choose the 

lamp module you‘ve entered.  

Click the ―To Momentary On‖ 

element.  Listed is the 

operation that links to the 

UPB switch you‘ve entered.   

  

You have configured the system to 

enable an UPB switch to control the 

X10 Lamp Module. 

  

In a fashion use operations to 

connect an element on a FGI device with either a X10 

or UPB device to bridge these devices. 

  

  

  

Connecting FSD X10-UPB Bridge to your system 

The FSD X10-UPB-FGI Bridge Controller is ready for 

use, UNLESS the serial port on the FSD X10-UPB-FGI 

Bridge Controller is used for configuring the controller.  If 

it is, do the following: 

  

1. After configuring the controller, disconnect the 

power supply and the NULL MODEM cable 

from the controller.   

2. Connect the power supply.   

3. Connect the serial cable from the UPB Power Line interface to the serial port of the FSD 

X10-UPB Bridge Controller.  
  

 

  

  



Simple Example to Configure an FSD X10-UPB-FGI Bridge Plus Controller 

  

The FSD X10-UPB-FGI Bridge Plus Controller allows the user to construct a system mixed with 

X10, UPB, and FGI devices to work with one another.  To accomplish this, configure the 

controller so it knows which X10 addresses are coupled to corresponding UPB unit ids.  The 

following example describes how to use the FSD X10-UPB-FGI Bridge Plus Controller.  The 

first and second examples demonstrate how to use FSD virtual devices, Super Bridge and Super 

Fine Bridge, to link UPB devices with X10 devices.  The third example illustrates connecting an 

UPB switch to an X10 lamp module using a one-on-one connection.  In a similar fashion one can 

bridge an FGI device with either X10 or UPB device. 

  

Initial system set-up for configuration  
If you have already added the controller, X10 and UPB powerline interfaces, X10 devices and 

UPB devices to the system configuration, skip this section.  If you have not installed the FSD 

Bridge Controller Software, you can install from the CD provided with the FSD Bridge 

Controller.  Instructions are found under the Help menu  ->View Installation Guides, and choose 

FSD X10-UPB Bridge Plus Controller from the list.  Add FSD Controller and power line 

interfaces using FSD Namer. 

  

1. Connect the power supply to the controller and either an USB cable from the computer or 

a NULL MODEM cable (also called twisted cable, do not use a straight serial cable) 

from the serial port of your computer to the serial port on the controller. 

2. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

3. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device), an UPB Power Line interface (e.g. PIM, an RS485/232 device), and an X10 

Power Line Interface to the system (e.g. TW523, a Timer Etc. device). 

  

If you already have a list of addresses to couple X10 to their respective UPB unit ids, you do not 

need to enter each X10 and UPB device into the system‘s configuration.  To finish configuration, 

couple the X10 with UPB 

devices using either Super 

Bridges or Super Fine 

Bridges (skip to these 

subsequent sections). 

  

If you wish to bridge devices 

using a one-on-one 

connection, use the following 

example to enter devices into 

the system.   

1. From the FSD 

Automator 

application, select 

FSD Namer-> X10 

Devices from the 

View menu. 

2. Select FSD Namer-> 

UPB Devices from 

the View menu.  

Click the Insert 

button.  In the next 

dialog box, from the 



droplist choose UPB Switch.  Enter a Device Name, set the network and unit code 

assigned to the device.  Click ―OK‖.  Click ―OK‖.  If queried by a dialog box, choose to 

load configuration later. 

3. Select FSD Namer-> X10 Devices from the View menu.  In the X10 Device List window, 

click the Insert button again.  From the droplist choose X10 Lamp Module.  Enter a 

Device Name, set the house and unit code (e.g. B and 2).  Click ―OK‖. 

4. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

FSD Super Bridge 

  

The FSD Super Bridge is a virtual device in the Timers, Etc. device family.  As mentioned in the 

last section, it is possible to link one-by-one an X10 address with an UPB address.  However, 

linking device elements with operations for multiple devices can be a tedious task assigning a 

number of switches to corresponding modules.  To simplify this task, use an FSD Super Bridge if 

you have a minimum of four sequentially numbered X10 addresses linked to four sequentially 

numbered UPB units.  [If you don‘t have sequentially numbered devices, use the FSD Super Fine 

Bridge (see next section).]  Super Bridges come in 8 or 16 links sizes.  Thus, for example if you 

planned C1 through C4 X10 addresses to signal UPB unit ids 006 through 009, do the following: 

  

1. Select FSD Namer-> Timers, Etc. from the View menu.  In the Timers, Etc. List window, 

click the Insert button.  From the droplist choose Super Bridge 8.  Enter a Device Name 

and click ―OK‖.  If 

asked, load 

configuration later.  

2. Select Timers, Etc. 

from the Configure 

menu, and choose 

the Super Bridge 8 

you just entered.  In 

the Configure 

dialog box, double-

click on the first 

entry line (1-4).   

3. In the Edit Bridge 

Group dialog 

choose X10 for the 

Input Settings.  

Enter ―C‖ for the 

house code and ―1‖ 

for the unit code.  

Choose UPB for the 

Output Settings and 

enter the network id 

and unit id 006.  

Click ―OK‖.  Click 

―OK‖.  Choose Load Configuration under the File menu. 

4. Thus activating X10 addresses C1 through C4, controls UPB devices with unit ids 006 

through 009 respectively. 

  

Assigning the other four addresses is easy.  In Step 2 choose the entry line 5-8 and select the 



―Inherit Settings‖ check box if the UPB devices are the next numbers in sequence.  Otherwise 

assign the beginning sequence unit id you wish to use for X10 addresses (e.g. H5 through H8) to 

control the UPB devices (e.g. 145 through 148).  Check ―Enable Dimmer Operation‖ if the 

devices have dimmer capabilities. 

  

If your planned addresses are not sequentially numbered, use a Super Fine Bridge (next section) 

  

Configuring FSD Super Fine Bridge 

  

The FSD Super Fine Bridge is a virtual device akin to the Super Bridge.  The Super Bridge is a 

convenient tool used to configure sequential numbered X10 devices with sequentially numbered 

UPB devices (minimum of four devices must be sequential).  However, if your devices are not 

sequentially numbered, use the FSD Super Fine Bridge. 

  

1. As with other devices, insert an instance of a FSD Super Fine Bridge (a Timers, Etc. type 

device) using FSD Namer.  Select FSD Namer-> Timers, Etc. from the View menu.  In 

the Timers, Etc. List window, click the Insert button.  From the droplist choose Super 

Fine Bridge 16.  Enter a Device Name 

and click ―OK‖.  If asked, load 

configuration now. 

2. From the Configure menu choose the 

Timers, Etc. super fine bridge that you 

inserted.  Note:  Settings are grouped in 

sets of four UPB or X10 devices.  The 

device family settings for switches 1, 5, 

9, and 13 apply to the subsequent three 

switches.  In the figure below, the 

dialog box in the background shows 

that the first set of switches bridges 

input from the UPB device family and 

outputs to the X10 device family.  As 

seen in the listbox neither the UPB nor 

the X10 devices are in sequential order.  

The second set of four are X10 input 

with UPB output.   

3. The dialog box in the foreground edits 

the settings for switch 9.  Checking the 

―Inherit Settings‖ box sets the input and 

output settings to the previous switches 

device settings.  If ―Inherit Settings‖ is 

not selected, the device family droplist boxes become active for selection.  Check the 

―Enable Bridge Operation‖ box to enable bridging of this switch and the ―Enable 

Dimmer Operation‖ box if the device bridged has dimming capability.   

4. Enter the X10 address and UPB address that you wish to bridge. 

5. Add the input and output device addresses and in the upper right corner, indicate the 

bridging direction: input to output (normal), output to input, or bidirectional.   

  

  

Link X10 and UPB Device with Operations 

  



For more complicated operations other than switching on and off with dimming than can be 

accomplished with Super Bridges or Super Fine Bridges, use operations to link devices.  Each 

device type has specific types of elements associated with them.  Elements are the interfaces 

between devices.  Operations are used to connect the elements with one another.  Each element 

has specific operations associated with 

them.  The following example shows 

the steps to link a UPB switch to an 

X10 lamp module.  

1. From FSD Automator, choose 

UPB Devices from the 

Operations menu.  Choose 

the UPB switch you‘ve 

entered in the one-on-one 

connection section on page 1.   

2. A tabbed index dialog appears.  

On the tabs are the different 

element types associated with 

the switch.  Click on ―From 

Momentary On‖.  This 

―From‖ element sends a 

momentary on signal and 

connects to a ―To‖ element 

on another device (e.g. lamp 

module).  Click ―Add‖, to 

choose an appropriate operation that 

connects the From and To elements.  

From the droplist select 

SET_MONENTARY_PAIR.   

3. In the resulting dialog, from the droplists (a) 

select the device family to connect with 

the ―To‖ element, (b) the device type, 

and (c) device name.  Choose X10, X10 

Lamp Module, and the name you‘ve 

entered, respectively.  The Device 

element is Momentary On.  Click ―OK‖. 

4. In the tabbed index dialog, click ―Load‖ to 

Load Configuration.   

5. When loading finishes, choose X10 Devices 

from the Operations menu.  Choose the 

lamp module you‘ve entered.  Click the 

―To Momentary On‖ element.  Listed is 

the operation that links to the UPB switch 

you‘ve entered.   

  

You have configured the system to enable an UPB switch to control the X10 Lamp Module. 

  

In a fashion use operations to connect an element on a FGI device with either a X10 or UPB 

device to bridge these devices. 

  

  

Configuring FSD X10-UPB-FGI Bridge Plus Controller with Timed Events 
  



Instructions to use the timed event capabilities of the Bridge Plus Controller, read the following 

example scenarios from the Help menu: 

 Configuring Event Timer 

 Configuring Alarm Clock 

  

Connecting FSD X10-UPB Bridge Plus to your system 

The FSD X10-UPB-FGI Bridge Plus Controller is ready for use, UNLESS the serial port on the 

FSD X10-UPB-FGI Bridge Plus Controller is used for configuring the controller.  If it is, do the 

following: 

  

1. After configuring the controller, disconnect the power supply and the NULL MODEM 

cable from the controller.   

2. Connect the power supply.   

3. Connect the serial cable from the UPB Power Line interface to the serial port of the FSD 

X10-UPB Bridge Plus Controller.  
  

 
  

  



Simple Example to Configure an Alarm Clock Timer 

  

The following example shows how to configure an Alarm Clock Timer.  This timer can trigger 

the same device or up to three separate devices, in a sequential manner.  In the Alarm Clock 

Timer one can set the ―alarm‖ time for the first device to start.  The start time for the second 

device is based on the start time of the first device; the third device based on the start time of the 

second device.  For instance, the Alarm Clock Timer might be configured to wake you-up 

(alarm), trigger a second device to start the coffee maker, then trigger a third device to turn on 

lights needed in the morning; or simply set off three timed alarms for the same device.  X10 

devices are used in the example, but apply similarly to other device families. 

  

  

Initial system set-up - add FSD Controller, power line interface, and lamp module to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

Configure Timer and Set Operations - configure 

timer device and link device elements 

  

1. In FSD Automator‘s View menu, choose FSD 

Namer to assign a Timer, Etc. device.  In 

the Timer List dialog, click the Insert 

button.  In the Edit Timer dialog, choose 

Alarm Clock from the Timer Type list.  

Enter a name for the timer.  Click ―OK‖. 

2. From FSD Automator, choose Timers, Etc. 

from the Configure menu.  Select the Alarm 

Clock device type and the device name 

you‘ve entered.  Click ―OK‖.   

3. In the Configure <device name> dialog, set 

the Alarm Time desired.  The following can 

be set for seconds or minutes:  (1) Alarm 

Duration (length of time the device is on), 

(2) Second Alarm Delay (length of time 

between the start of the first device to when 

to start the second device), (3) Third Alarm 

Delay (length of time between the start of 

the second device to when to start the third 

device), and (4) the amount of time the 

alarm is in Snooze mode.   



4. In the middle third of the dialog box, select the days the timer is enabled.  Also Assign 

whether or not to use alarm on a holiday or special day schedule (see Holiday Schedule 

reference manual).  Click ―OK‖.   

5. Either right-click the title bar in the device dialog and select Configure Operations from 

the menu or from FSD Automator, choose Timers, Etc. from the Operations menu.  

Choose the alarm clock you‘ve entered.   

6. A tabbed index dialog appears.  On the tabs are the different element types on the Alarm 

Clock device.  Click on ―From Alarm State‖.  This ―From‖ element sends a signal and 

connects to a ―To‖ element on another device (e.g. lamp module).  Click ―Add‖, to add 

an operation that connects the From and To elements.  From the droplist select 

SET_MONENTARY_PAIR.   

7. In the resulting 

dialog, select the 

device family to 

connect with the 

―To‖ element, the 

device type, and 

device name.  

Choose X10, 

X10 lamp 

module, and the 

name you‘ve 

entered, 

respectively.  The 

Device element 

is Momentary 

On.  Click ―OK‖.  

8. Repeat step 7 to 

configure a second and third device, if desired.  Shown in the figure is ―From Second 

Alarm State‖ set to trigger an appliance module. 

9. In the tabbed index dialog, click ―Load‖ to load the configuration.   

10. When loading finishes, choose X10 Devices from the Operations menu.  Choose the lamp 

module you‘ve entered.  Click the ―To Momentary On‖ element.  Listed is the operation 

that links to the alarm clock you‘ve entered.  You have configured the system for an 

alarm clock device to control a lamp module. 

11. In the Configure alarm clock dialog there is a pair of radio buttons:  ―Automatic Arming 

on Mode Activation‖ and ―Manual Arming Required‖.  Selecting the former arms the 

alarm every day it is enabled.  Selecting the latter radio button, the alarm must be 

manually armed or enabled.  From the device dialog of the alarm clock, click on the 

Alarm Enable button (button should change from False to True).  This enables the 

alarm‘s functions.  Alarm enabled can be configured to a switch to enable or disable the 

alarm.  Link the ―To Trigger Element‖ element type on the alarm clock timer to the 

―On/Off State‖ element on the switch with a SET_TO_VALUE operation.  The same 

can be done for configuring the deactivate button and snooze button to a switch. 

  

The preceding example uses X10 family devices.  However, devices from a different device 

family can be substituted (e.g. UPB devices).  Link elements using operations as described 

above.   

  

  

  



Simple Example to Configure a Fade Timer 

  

Use a Fade Timer to control the length of time an event is on, to dim or brighten a light on a 

specific schedule and, if desired, to program an inactive period before the event can be 

retriggered.   

  

The example illustrates how to configure a switch to activate a Fade Timer that controls a lamp 

module on an X10 system.  X10 devices are used in the example, but apply similarly to other 

device families. 

  

  

Initial system set-up - add FSD Controller, power line interface, lamp module, and switch to the 

system. 
  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device)). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

6. Click the Insert button.  In the next dialog box, from the droplist choose X10 Switch.  

Enter a Device Name, set the house and unit code (e.g. A and 1).  Click ―OK‖. 

7. In the X10 Device List window, click the Insert button again.  From the droplist choose 

X10 Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  

Click ―OK‖. 

8. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

Creating and Configuring a Fade Timer - set 

parameters of the fade timer, a virtual device 
  

1. From the FSD Automator application, select 

FSD Namer-> Timers, Etc. from the View 

menu.  From the Timers list, click 

―Insert‖.  In the Edit Timers dialog, 

choose Fade Timer from the droplist and 

enter a name.  Click ―OK‖ and Click 

―OK‖ in the next dialog box displayed.  If 

needed you can choose Load 

Configuration later. 

2. Under the Configure menu in FSD 

Automator, choose Timers, Etc.  In the 

Select box choose the fade timer you 

entered. 

3. In the Configure dialog select 1) the ―Edge 

Triggered Input‖ (triggered when there is 

a change in event state), 2) ―Retriggerable 

While Active‖ (allows the timer to be 



reset to extend the active period), 3) Accumulate time, and 4) Always Enabled. 

4. Set the Start Fade Level to 80 and time 5 seconds; set the Hold Level to 50 and time to 15 

seconds , and End Fade Level to 0 and Time for 10 seconds.  In this configuration the 

fade timer begins at 80 and takes 5 seconds to reach the Hold Level and is held for 15 

seconds; then takes 10 seconds to reach the End Fade Level of zero.   

  

Link Devices by Setting Operations - configure devices and link device elements using 

operations 

  

1. From FSD Automator, choose Timers, Etc from the Operations menu.  Choose the fade 

timer you‘ve entered.   

2. A tabbed index dialog appears.  On the tabs are the different element types on the switch.  

Click on ―From Event State‖.  This ―From‖ element sends a momentary on signal and 

connects to a ―To‖ element on another device (e.g. lamp module).  Click ―Add‖, to add 

an operation that connects the From and To elements.  From the droplist select 

SET_MOMENTARY_PAIR.   

3. In the resulting dialog, select the device family to connect with the ―To‖ element, the 

device type, and device name.  Choose X10, X10 lamp module, and the device name 

you‘ve entered, respectively.  The Device element is Momentary On.  Click ―OK‖.   

4. In the tabbed index page, choose ―To Trigger State‖.  Click the Add button and choose 

SET_TO_VALUE.  Choose the Device Family, Device Type, Device Name, and Device 

Element (Momentary On) for the X10 switch selected.  Click ―OK‖.   

5. In the tabbed index page, choose ―From Output Level‖.  Click the Add button and choose 

CONVERT_VALUE.  (CONVERT_VALUE is used because the two connecting 

elements on each device are different data types, but can be typecast for compatibility.)  

Choose the Device Family, Device Type, Device Name, and Device Element (Dimmer 

Setting) for the X10 switch selected.  Click ―OK‖.  
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 the tabbed index dialog, click ―Load‖ to Load Configuration.   

  

Toggling the X10 switch sends a trigger to the fade timer.  The fade timer turns on and fades the 

light as specified.   



  

One can configure the fade timer to receive an input to enable the fade timer.  Unselect the 

―Always Enabled‖ checkbox in the configure device dialog.  Follow the above steps in ―Link 

Devices by Setting Operations‖ with the following changes:  step 2, choose ―To Trigger 

Enabled‖ and add from the droplist SET_TO_VALUE.  In step 3 choose the switch input with 

the device element selected as ―On/Off State‖. 

  

Some other options to select during configuration:  With the ―Retriggerable While Active‖ 

option selected, when the timer is active, pushing the on button of the switch causes the active 

period to reset to the beginning of the active period.  If the ―Accumulate Time‖ is selected, the 

amount of time defined in the active period setting is added to the remaining active period.  The 

amount of time accumulated can be limited by specifying a time. 

  

Configuring other device family systems is similar to the X10 system described above.  For 

example, with an UPB system, substitute X10 component with its UPB counterpart (i.e. 

powerline interface, network and unit code).   

  

  

  

  
  

 
  

 

  



Simple Example to Configure a Retriggerable Timer 

  

Use a Retriggerable Timer to control the length of time an event is on and, if desired, an inactive 

period before the event can be retriggered.   

  

The example illustrates how to configure a switch to activate a Retriggerable Timer that controls 

a lamp module on an X10 system.  X10 devices are used in the example, but the example applies 

similarly to other device families.  

  

Initial system set-up - add FSD Controller, power line interface, lamp module, and switch to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

6. Click the Insert button.  In the next dialog box, from the droplist choose X10 Switch.  

Enter a Device Name, set the house and unit code (e.g. A and 1).  Click ―OK‖. 

7. In the X10 Device List window, click the Insert 

button again.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the 

house and unit code (e.g. B and 2).  Click 

―OK‖. 

8. In the X10 Device List window, click ―OK‖.  If 

queried by a dialog box, choose to load 

configuration later. 

  

Creating and Configuring a Retriggerable Timer - 

set parameters of the retriggerable timer, a virtual device 

  

1. From the FSD Automator application, select FSD 

Namer-> Timers, Etc. from the View menu.  

From the Timers list, click ―Insert‖.  In the Edit 

Timers dialog, choose Retriggerable Timer 

from the droplist and enter a name.  Click 

―OK‖. and Click ―OK‖ in the dialog that is 

displayed.  If needed, you can choose Load 

Configuration later. 

2. Under the Configure menu in FSD Automator, 

choose Timers, Etc.  In the Select box choose 

the retriggerable timer you entered. 

3. In the Configure dialog select 1) the ―Edge 

Triggered Input‖ (triggered when there is a 

change in event state), 2) ―Retriggerable While Active‖ (allows the timer to be reset to 

extend the active period), 3) Accumulate time, and 4) Always Enabled. 



4. Set the Delay Time After Trigger to 5 seconds, the Output Active Time to 1 Minute, and 

Minimum Inactive Time to 20 seconds.  In this configuration the timer waits 5 seconds 

after the trigger impulse to turn on the light for 1 minute, and prohibits triggering 

another event for 20 seconds. 

  

Link Devices by Setting Operations - 

configure devices and link device elements 

using operations 

  

1. From FSD Automator, choose 

Timers, Etc from the Operations 

menu.  Choose the retriggerable 

timer you‘ve entered.   

2. A tabbed index dialog appears.  On 

the tabs are the different element 

types on the switch.  Click on 

―From Event State‖.  This ―From‖ 

element sends a momentary on signal and connects 

to a ―To‖ element on another device (e.g. lamp 

module).  Click ―Add‖, to add an operation that 

connects the From and To elements.  From the 

droplist select SET_MOMENTARY_PAIR.   

3. In the resulting dialog, select the device family to 

connect with the ―To‖ element, the device type, and 

device name.  Choose X10, X10 lamp module, and 

the device name you‘ve entered, respectively.  The 

Device element is Momentary On.  Click ―OK‖.   

4. In the tabbed index page, choose ―To Trigger State‖.  

Click the Add button and choose SET_TO_VALUE.  

Choose the Device Family, Device Type, Device 

Name, and set the Device Element to ―On/Off State‖ 

for the X10 switch selected.  Click ―OK‖. 

5. In the tabbed index dialog, click ―Load‖ to Load 

Configuration.   

  

Toggling the X10 switch sends a trigger to the retriggerable 

timer.  The retriggerable timer delays, then turns on the lamp 

module as specified.  If ―Always Enabled‖ is not selected in 

the Configure dialog, the user can configure another switch 

to toggle the enable switch (―To Trigger Enable‖ element, 

similar to step 4 above). 

  

Some other options to select during configuration:  With the ―Retriggerable While Active‖ 

option selected, when the timer is active, pushing the on button of the switch causes the active 

period to reset to the beginning of the active period.  If the ―Accumulate Time‖ is selected, the 

amount of time defined in the active period setting is added to the remaining active period.  The 

amount of time accumulated can be limited by specifying a time. 

  

Configuring other device family systems is similar to the X10 system described above.  For 

example, with an UPB system, substitute X10 component with its UPB counterpart (i.e. 

powerline interface, network and unit code).   

  



  

  



Simple Example to Configure a Delay Timer 

  

The Delay Timer is an FSD virtual device in the Timers, Etc. device family.  The user can 

program the delay timer to postpone the triggering of an event.  If using the Boolean delay timer, 

the user can specify a number of thresholds to be achieved before a trigger is sent.  The 

following example shows how to configure a Delay Timer.  This Timers, Etc. device comes as 

either Boolean or a Byte version.   

  

  

Initial system set-up - add FSD Controller, power line interface, and lamp module to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523, a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

Configure Delay Timer and Set Operations - configure button control device and link device 

elements 

  

The following example applies to a Boolean type Delay Timer. 

  

1. In FSD Automator‘s View menu, choose 

FSD Namer to assign a Timer, Etc. 

device.  In the Timer List dialog, click 

the Insert button.  In the Edit Timer 

dialog, choose Delay Timer (Boolean) 

from the Timer Type droplist.  Enter a 

name for the timer.  Click ―OK‖. 

2. From FSD Automator, choose Timers, Etc. 

from the Display menu.  Select the 

Delay Timer (Boolean) device type and 

the device name you‘ve entered.  Click 

―OK‖.  In the Configure Device dialog, 

enter the Delay Time Per Step in 

Milliseconds or Seconds.  For example, 

if the delay time (Boolean model) per 

step is one second, each output can be 

delayed between 0 to 63 seconds (max. 

of 63 steps) from the triggering signal.  

For the byte model there are only 8 

stages.  If you want the output signal to 

send a false instead of true, click the 

―Invert‖ checkbox( not active for byte 



model).  To change the input signal from true to 

false, select ―Invert Input‖. 

3. Use the Combo Output Settings section to use 

selected triggered outputs to signal triggering of 

another output.  In the Combo Output Settings 

section (not active for byte model), the user can 

select outputs (1 through 8) to be monitored.  In 

the ―Threshold TRUE‖ edit box, enter the 

number of signals that must be true for a True 

signal to the sent.  For example, if five of eight 

outputs are selected and threshold is three, then 

three of the five outputs selected must turn true 

before an ―On‖ signal is sent from the ―From 

Combo Output‖ element.  Similarly, if threshold 

FALSE is set at two, when two of the outputs are 

false, an ―Off‖ output signal is sent.  Click 

―OK‖.  Click ―OK‖ in the Configure Device 

dialog.   

4. To configure the device elements, either right-click 

the title bar in the device dialog and select 

Configure Operations from the menu or from 

FSD Automator, choose Timers, Etc. from the 

Operations menu.  Choose the delay timer 

you‘ve entered.   

5. A tabbed index dialog appears.  On the tabs are the 

different element types on the Delay Timer 

device.  Click on ―From Output <number>‖ to configure the output step.  This ―From‖ 

element sends a signal and connects to a ―To‖ element on another device (e.g. lamp 

module).  Click ―Add‖, to add an operation that connects the From and To elements.  

From the droplist select SET_MONENTARY_PAIR.   

6. In the resulting dialog, select the device family to connect with the ―To‖ element, the 

device type, and device name.  Choose X10, X10 lamp module, and the name you‘ve 

entered, respectively.  The Device element is Momentary On.  Click ―OK‖. 

7. If a Combo Output Setting is configured, select the ―From Combo Output‖ element. 

8. In the tabbed index dialog, click ―Load‖ to load the configuration.   

9. When loading finishes, choose X10 Devices from the Operations menu.  Choose the lamp 

module you‘ve entered.  Click the ―To Momentary On‖ element.  Listed is the operation 

that links to the device timer you‘ve entered.  You have configured the system for an 

delay timer device to control a lamp module. 

  

The preceding example uses X10 family devices.  However, devices from a different device 

family can be substituted (e.g. UPB devices).  Link elements using operations as described 

above.   

 Simple Example to Configure a Button Control (non-time-based Timer device) 

  

FSD Button Control devices are virtual devices that resemble, on first glance, multiple address 

control pad devices.  This Timers, Etc. device comes with either 8 or 16 buttons.  Each button 

can be configured to control either customized scenes or macros, or FGI, X10, and UPB devices 

(depending on the model of controller).   

  

The following example shows how to configure a Button Control for an X10 system. 

  



Initial system set-up - add FSD Controller, power line interface, and lamp module to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. P and 1).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

Configure Button Controls and Set Operations - configure button 

control device and link device elements 

  

1. In FSD Automator‘s View menu, choose FSD Namer to assign 

a Timer, Etc. device.  In the Timer List dialog, click the Insert 

button.  In the Edit Timer dialog, choose 8 Button Control 

from the Timer Type droplist.  Enter a name for the timer.  

Click ―OK‖.  Load the configuration. 

2. In the Configure Display that appears, click on the number that 

corresponds to the button number you wish to configure.  

Click ―Enabled‖ to enable the button and choose either 

―On/Off Pair‖ to configure a pair of buttons, each controlling 

either the on or off state, or ―Push On/Push Off‖, in which the 

same button controls the on and off state.  Enter a label for 

the button, if desired.  If you want a different label displayed 

during the ―Off‖ state, check the ―Use OFF State label‖ and 

enter the label in the activated edit 

box.  In the ―On‖ state, the label 

entered in the upper box is 

displayed.  Click ―OK‖.  Click 

―OK‖ in the Configure Display 

dialog.   

3. A button control dialog (the device 

dialog) with Configure <device 

name> in the title bar appears.  (If 

not, from the Configure menu, 

choose Timers, Etc. and the 8 button 

control you‘ve defined.)  Double-

click a button that you‘ve labeled.  

In the Edit Button Info dialog that 

appears, choose the button type 

(FGI, X10, UPB, Macro, or Scene; 

what is listed depends on controller 

type).  Select X10. 

4. In the Edit X10 Button Info dialog that 

appears, in the Primary grouping 



box enter the house and unit code of the device you want this button to control.  Enter P-

1.  For the ON Command, choose ―ON‖ from the droplist.  If the button is Push On/Push 

Off, in the Secondary grouping enter 1 as the unit and choose ―Off‖ from the OFF 

Command droplist.  Click ―OK‖.  The button you‘ve programmed now controls the 

lamp module device. 

  

The preceding example uses X10 family devices.  However, devices from a different device 

family can be substituted (e.g. UPB devices).     

  





Simple Example to Configure a Multi Switch Device 

  

The following example shows how to configure a Multi Switch.  While there are many different 

types of devices in the multi switch category, this example deals with the multi button type multi 

switch.  The following example is for an X10 system. 

  

  

Initial system set-up - add FSD Controller, power line interface, and lamp module to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 

Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

Configure Multi Switch and Set Operations - configure multi switch device and link device 

elements 

  

1. In FSD Automator‘s View menu, 

choose FSD Namer to assign an 

X10 device.  In the X10 List 

dialog, click the Insert button.  In 

the Edit X10 Device dialog, 

choose X10 8 Address Switch 

from the X10 Device Type 

droplist.  Enter a name for the 

address switch.  Select a starting 

House Code and Unit Code for 

the addresses.  Click ―OK‖.  

Load the configuration. 

2. From the Configure menu choose 

X10 Device and choose the 

address switch you entered.  In 

the configure dialog, check all 

switches you wish controlled by 

the All Lights ON and All Units Off button on the device.  NOTE:  Purchased X10 multi 

address switch pads are programmed automatically turn on all lamp modules for the 

programmed house code, but not appliance modules.  With the FSD multi switch you 

can choose to include appliance modules or exclude lamp modes from activation with 

the ALL Lights On button and deactivation with the All Units OFF button.  Click ―OK‖. 

3. From the Operation menu choose X10 Device and select the multi address switch you 

entered.  A tabbed index dialog appears.  On the tabs are the different element types on 

the Multi Switch device.  For the switch desired click on its ―From Momentary On‖ tab.  

This ―From‖ element sends a signal and connects to a ―To‖ element on another device 



(e.g. lamp module).  Click ―Add‖, to add an operation that connects the From and To 

elements.  From the droplist select SET_MONENTARY_PAIR.   

4. In the resulting dialog, select the device family to connect with the ―To‖ element, the 

device type, and device name.  Choose X10, X10 lamp module, and the name you‘ve 

entered, respectively.  The Device element is Momentary On.  Click ―OK‖. 

5. In the tabbed index dialog, click ―Load‖ to load the configuration.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. When loading finishes, choose X10 

Devices from the Operations menu.  

Choose the lamp module you‘ve 

entered.  Click the ―To Momentary 

On‖ element.  Listed is the operation 

that links to the multi switch you‘ve 

entered.  You have configured the 

system for an multi switch to control 

a lamp module. 

  

 The preceding example uses X10 family 

devices.  However, devices from a different 

device family can be substituted (e.g. UPB 

devices).  Link elements using operations as described above.   

  

  
  

 

Simple Example to Configure a Sensor Device to Control another Device 

  

The following example describes how to use an FSD Controller equipped with a FGI port (RS-

485) to take input from a FGI Sensor and control another device.  Specifically, we will configure 

the system to take readings from a FGI Temperature/Humidity Sensor to trigger an UPB 

Appliance Module. 

  



Initial system set-up for configuration  
In this example we use the FSD Bridge Controller equipped with an FGI port.  If you have not 

installed the FSD Bridge Controller Software, you can install from the CD provided with the 

FSD Bridge Controller.  Instructions are found under the Help menu->View Installation Guides, 

and choose FSD X10-UPB-FGI Bridge Controller from the list.  Add FSD Controller, power line 

interfaces, and appliance module to the system. 

  

1. Connect the power supply to the controller and an USB cable from computer to controller 

(or a NULL MODEM cable (also called twisted cable, do not use a straight serial cable) 

from the serial port of your computer to the serial port on the controller). 

2. Plug the FGI RS-485 cable with FGI Temperature/Humidity Sensor attached into the FGI 

port. 

3. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

4. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device), name the temperature/humidity sensor, and an UPB Power Line interface (e.g. 

PIM, an RS485/232 device). 

5. Select FSD Namer-> UPB Devices from the View menu.  Click the Insert button.  In the 

next dialog box, from the droplist choose UPB Appliance Module.  Enter a Device 

Name, set the network and unit code assigned to the device.  Click ―OK‖.  Click ―OK‖.  

If queried by a dialog box, choose to load configuration later. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Configuring the Sensor Device and 

Slave Device 

1. Under Operations menu bring up 

the operations dialog for the 

temp/humidity FGI device.  

Select the From temperature 

element tab (from meaning that 

the signal is sent ―from‖ this 

element type).  Click Add. 

2. In the Operation dialog box notice 

that the From type is 

SHORT_HUNDRETHS (more 

on this later).  Select the 



COMPARE_VALUE operation.  Click ―OK‖. 

3. Displayed is the Compare Operation dialog.  

Select the device that you are sending the 

signal ―To‖.  In this case the UPB appliance 

module with device element ―On/Off 

Setting‖.  

4. In the compare value box enter the temperature 

threshold value * 100 (type is 

SHORT_HUNDRETHS, thus if threshold is 

77, enter 7700). 

5. Click ―OK‖, and click ―Load‖ to load 

configuration.  When temperature reaches 

77 F, the appliance (fan) should turn on, 

below 77 F, it turns off. 

   

Enable Hysteresis and Compare Range Options 

  

Enable Hysteresis 

  

If your value hovers around the threshold, your 

device might be cycling on and off.  To remedy 

this use Enable Hysteresis.  Set the Compare High 

Value as the threshold and the Compare Low 

Value as the shut off point.  Thus, in our example 

the fan will turn on at 77 F and shuts off at 74 F. 

  

 Compare Range 

  

Use this feature to switch on the device between 

the low and high values.  Thus the fan works over  

a specified range, turns on at the Low value and shuts 

off at High value. 

Example to Configure Bridging of UPB Link 

Commands to X10 Devices 

  

The following example describes how to use an FSD Bridge Controller to receive UPB link 

commands from an UPB controller generating UPB link commands and bridge them to X10 

devices.    

  

Initial system set-up for configuration  
Please refer to the example scenario or manual that corresponds to your bridge controller model 

for initial configuration of your controller.  When the UPB Controller generates UPB link 

commands to control a device, these commands go to ―virtual‖ devices.  For the FSD Bridge to 

bridge the UPB commands to control X10 devices, the FSD Bridge needs to know the addresses 

of these ―virtual‖ devices.  The FSD Bridge can recognize the UPB address and associate it with 

the proper X10 address. 

  

1. Select FSD Namer-> UPB Devices from the View menu.  In the UPB Device List window, 

click the Insert button again.  From the droplist choose UPB Switch.  Enter a Device 

Name, choose the Link ID radio button, set the Network and Link ID (e.g. 001 and 

011L).  Click ―OK‖.  Continue adding UPB devices as needed.  For this example add 

eight switches. 



2. In the UPB Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

3. Select FSD Namer-> X10 Devices from the View menu.  In the X10 Device List window, 

click the Insert button again.  From the droplist choose X10 Appliance Module.  Enter a 

Device Name, set the house and unit code (e.g. M and 1).  Click ―OK‖.  Continue 

adding X10 devices as needed.  For this example add eight appliance modules. 

4. In the X10 Device List window, click ―OK‖.  If queried, choose to load configuration later. 

  

  

  



Link UPB and X10 Device with Operations 

Each device type has specific types of elements associated with them.  Elements are the 

interfaces between devices.  Operations are used to connect the elements with one another.  Each 

element has specific operations 

associated with them.   

  

1. From FSD Automator, choose 

UPB Devices from the 

Operations menu.  Choose 

the UPB switch you‘ve 

entered.   

2. A tabbed index dialog appears.  

On the tabs are the different 

element types on the switch.  

Click on ―From Momentary 

On‖.  This ―From‖ element 

sends a momentary on signal 

and connects to a ―To‖ 

element on another device 

(e.g. lamp module).  Click 

―Add‖, to choose an 

appropriate operation that 

connects the From and To 

elements.  From the droplist select 

SET_MONENTARY_PAIR.   

3. In the resulting dialog, from the droplists (a) select 

the device family to connect with the ―To‖ 

element, (b) the device type, and (c) device 

name.  Choose X10, X10 Lamp Module, and the 

name you‘ve entered, respectively.  The Device 

element is Momentary On.  Click ―OK‖. 

4. In the tabbed index dialog, click ―Load‖ to Load 

Configuration.   

5. When loading finishes, choose X10 Devices from 

the Operations menu.  Choose the lamp module 

you‘ve entered.  Click the ―To Momentary On‖ 

element.  Listed is the operation that links to the 

UPB switch you‘ve entered.   

  

You have configured the system to enable an UPB 

switch control a X10 Lamp Module.  Configure the 

remaining switches and modules using the same 

procedures or use an FSD Super Bridge (see below). 

  

  

  

  

  

FSD Super Bridge 

  

The FSD Super Bridge is a virtual device in the Timers, Etc. device family.  In the previous 

example, linking device elements with operations for multiple devices can be a tedious task 



assigning a number of switches to corresponding modules.  To simplify this task, use an FSD 

Super Bridge. 

  

In the following example the sequential UPB link Switches (011L through 018L) are assigned to 

X10 modules with sequential 

unit codes (M-1 through M-8). 

  

1. Select FSD Namer-> 

Timers, Etc. from the 

View menu.  In the 

Timers, Etc. List 

window, click the Insert 

button.  From the droplist 

choose Super Bridge 8.  

Enter a Device Name and 

click ―OK‖.  If asked, 

load configuration later. 

2. Select Timers, Etc. from 

the Configure menu, and 

choose the Super Bridge 

8 you just entered.  In the 

Configure dialog box, 

double-click on the first 

entry line (Switches 1-4).   

3. In the Edit Bridge Group 

dialog choose UPB for 

the Input Settings.  

Choose Link ID.  Enter 

―01‖ for the Network ID 

and ―011‖ for the Link ID.  Choose X10 for the Output Settings and enter the ―M‖ for the 

House Code and ―1‖ for the Unit code entered in step 2.  Click ―OK‖.  Click ―OK‖ in the 

Configure dialog.  Choose Load Configuration under the File menu. 

4. Assigning the another four addresses is easy.  Repeat Step 2, but choose the entry line 5-8 

and select the ―Inherit Settings‖ checkbox. 

5. UPB Switches 011 through 018 are now associated with X10 devices M-1 through M-8, 

respectively (i.e. UPB switch 011 operates X10 device at M-1).   

  

  

Configuring the UPB Controller with Links (scenes) 

  

1. Define the UPB Link names in UPSTART.  Open the UPSTART application and under the 

Network menu option choose ―Link Names‖.  Click the ―New‖ button, add a new link, 

and assign the Link ID of 011.  Repeat for the number of UPB Switches defined in FSD 

Namer. 

2. Configure your UPB Controller (e.g. Home Control Assistant) to send commands to the 

UPSTART defined UPB Link names (defined as "Scenes‖ in Home Control Assistant). 

  

  

  

  



Simple Example to Configure Two FSD Bridge Controllers to Transmit UPB Commands 

Across a Building with Multiple Powerline Supplies 

  

In a large building, different sections might be supplied with separate power lines.  In this case 

UPB commands from a single controller cannot be signaled throughout the entire building.  

Employing two FSD Bridge Controllers allows the user to connect one section of a building to 

another section of a building supplied with an independent power line, in order to send UPB 

signals to all areas.  

  

Initial set-up of Equipment 

1. Install shielded 4-wire cable from one section of the building to the section of the 

building with a different power source.  Attach RJ-11 connectors to both ends so that the 

cable is straight wired. 

2. At one FSD Bridge Controller end plug the RJ-11 connector into the X10 in port; at the 

other FSD Bridge Controller plug the RJ-11 connector into the X10 out port. 

  

  

Perform the following steps for each FSD Bridge Controller: 

  

Initial system configuration set-up 

If you have already added the controller and UPB powerline interfaces to the system 

configuration, skip this section.  If you have not installed the FSD Bridge Controller Software, 

you can install from the CD provided with the FSD Bridge Controller.  Instructions are found 

under the Help menu  ->View Installation Guides, and choose the appropriate FSD Bridge 

Controller (e.g. FSD X10-UPB Bridge Plus Controller) from the list.  Add FSD Controller and 

power line interfaces (both UPB and X10[, even if no X10 interface is installed) using FSD 

Namer. 
  

1. Connect the power supply to the controller and either an USB cable from the computer or 

a NULL MODEM cable (also called twisted cable, do not use a straight serial cable) from 

the serial port of your computer to the serial port on the controller. 

2. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

3. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) , X10 interface (TW523, an Timer etc. device), and an UPB Power Line interface 

(e.g. PIM, an RS485/232 device). 

  

Theory of operation:  FSD Bridge Controllers were designed to bridge different home control 

product technologies so they could operate with one another using a single controller.  In this 

example we use a bridge that allows both UPB and X10 protocols to be operated by the same 

controller.  This ability is adapted for use in this situation.  UPB commands from the UPM PIM 

with be converted to X10 signals by one FSD Bridge, X10 commands transmitted through the 

X10 ports to the other FSD Bridge, the other bridge will convert the X10 commands to UPB 

commands and sent to the UPB PIM attached to the other power line source.  These command 

conversion are done by setting up Super Bridges or Super Fine Bridges, in which you configure 

what UPB address corresponds to what X10 address (details follow). 

  

  

  

FSD Super Bridge 

  

The FSD Super Bridge is a virtual device in the Timers, Etc. device family.  It is possible to link 

one-by-one an X10 address with an UPB address.  However, linking device elements with 



operations for multiple devices can be a tedious task assigning a number of switches to 

corresponding modules.  To simplify this task, use an FSD Super Bridge if you have a minimum 

of four sequentially numbered X10 addresses linked to four sequentially numbered UPB units.  

Super Bridges come in 8 or 16 links sizes.  Thus, for example if you planned C1 through C4 X10 

addresses to signal UPB unit ids 006 through 009, do the following:  

  

1. Select FSD Namer-> 

Timers, Etc. from the 

View menu.  In the 

Timers, Etc. List 

window, click the 

Insert button.  From the 

droplist choose Super 

Bridge 8 (or if needed 

Super Bridge 16).  

Enter a Device Name 

and click ―OK‖.  If 

asked, load 

configuration later. 

2. Select Timers, Etc. from 

the Configure menu, 

and choose the Super 

Bridge 8 you just 

entered.  In the 

Configure dialog box, 

double-click on the 

first entry line (1-4).   

3. In the Edit Bridge Group 

dialog choose X10 for the Input Settings.  Enter ―C‖ for the house code and ―1‖ for the 

unit code.  Choose UPB for the Output Settings and enter the network id and unit id 006.  

Click ―OK‖.  Click ―OK‖.  Choose Load Configuration under the File menu. 

4. Thus activating X10 addresses C1 through C4, controls UPB devices with unit ids 006 

through 009 respectively. 

5. Check the Bridge to be bidirectional. 

  

Assigning the other four addresses is easy.  In Step 2 choose the entry line 5-8 and select the 

―Inherit Settings‖ check box if the UPB devices are the next numbers in sequence.  Otherwise 

assign the beginning sequence unit id you wish to use for X10 addresses (e.g. H5 through H8) to 

control the UPB devices (e.g. 145 through 148).  Check ―Enable Dimmer Operation‖ if the 

devices have dimmer capabilities.  (For Super Bridge 16, just use the same procedures to extent 

the number of addresses from 8 to 16.) 

  

If your planned addresses are not sequentially numbered, use a Super Fine Bridge (next section) 

  

Configuring FSD Super Fine Bridge 

  

The FSD Super Fine Bridge is a virtual device akin to the Super Bridge.  The Super Bridge is a 

convenient tool used to configure sequential numbered X10 devices with sequentially numbered 

UPB devices (minimum of four devices must be sequential).  However, if your devices are not 

sequentially numbered, use the FSD Super Fine Bridge.  



  

1. As with other devices, insert an instance of 

a FSD Super Fine Bridge (a Timers, Etc. 

type device) using FSD Namer.  Select 

FSD Namer-> Timers, Etc. from the 

View menu.  In the Timers, Etc. List 

window, click the Insert button.  From 

the droplist choose Super Fine Bridge 16.  

Enter a Device Name and click ―OK‖.  If 

asked, load configuration now. 

2. From the Configure menu choose the 

Timers, Etc. super fine bridge that you 

inserted.  Note:  Settings are grouped in 

sets of four UPB or X10 devices.  The 

device family settings for switches 1, 5, 

9, and 13 apply to the subsequent three 

switches.  In the figure below, the dialog 

box in the background shows that the 

first set of switches bridges input from 

the UPB device family and outputs to the 

X10 device family.  As seen in the 

listbox neither the UPB nor the X10 

devices are in sequential order.  The second set of four are X10 input with UPB output.   

3. The dialog box in the foreground edits the settings for switch 9.  Checking the ―Inherit 

Settings‖ box sets the input and output settings to the previous switches device settings.  

If ―Inherit Settings‖ is not selected, the device family droplist boxes become active for 

selection.  Check the ―Enable Bridge Operation‖ box to enable bridging of this switch 

and the ―Enable Dimmer Operation‖ box if the device bridged has dimming capability.   

4. Enter the X10 address and UPB address that you wish to bridge. 

5. Add the input and output device addresses and in the upper right corner, indicate the 

bridging direction: input to output (normal), output to input, or bidirectional.   

  

  

  

  

  

Configuring FSD X10-UPB-FGI Bridge Plus Controller with Timed Events 
  

Instructions to use the timed event capabilities of the Bridge Plus Controller, read the following 

example scenarios from the Help menu: 

 Configuring Event Timer 

 Configuring Alarm Clock 

  

Connecting FSD X10-UPB Bridge Plus to your system 

The FSD X10-UPB-FGI Bridge Plus Controller is ready for use, UNLESS the serial port on the 

FSD X10-UPB-FGI Bridge Plus Controller is used for configuring the controller.  If it is, do the 

following: 

  

1. After configuring the controller, disconnect the power supply and the NULL MODEM 

cable from the controller.   

2. Connect the power supply.   

3. Connect the serial cable from the UPB Power Line interface to the serial port of the FSD 



X10-UPB Bridge Plus Controller.  
  

 

  

  
  

  

  



Simple Example to Configure FSD Logger 

  

FSD Logger is used to log changes in the state of device elements.  For example, the temperature 

and humidity readings from various sensors around a museum can be logged over time.  Separate 

log files can be created to record data from each sensor. 

  

Initial system set-up for configuration  
In this example we use the FSD Bridge Controller Plus equipped with temperature/humidity 

sensor attached through an FGI port.  If you have not installed the FSD Bridge Controller Plus 

Software, you can install from the CD provided with the FSD Bridge Controller Plus.  

Instructions are found under the Help menu->View Installation Guides, and choose FSD X10-

UPB-FGI Bridge Controller Plus from the list.  Add FSD Controller, power line interfaces, and 

temperature/humidity sensors to the system. 

  

1. Connect the power supply to the controller and an USB cable from computer to controller 

or a NULL MODEM cable (also called twisted cable, do not use a straight serial cable) 

from the serial port of your computer to the serial port on the controller. 

2. Plug the FGI RS-485 cable with FGI Temperature/Humidity Sensors attached to the FGI 

port. 

3. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

4. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device), name the temperature/humidity sensors, and an UPB Power Line interface 

(e.g. PIM, an RS485/232 device). 

5. Load configuration (under the File menu choose ―Load Configuration‖). 

  

Configure the Temperature Humidity Sensors to report data  
  

For data logging, one must enable both a log 

file and at least one filter.   

1. To create a log file, choose Log Menu-> 

Define Log Properties.  In the dialog 

box displayed, click the ―Add Log 

File Definition‖.   

2. In the Log File Definition dialog, enable 

the log file, add a Log File Name, a 

description, and click the boxes with 

ellipsis to enter a destination for the 

log file and the backup log file.  

Ensure that the directories are 

defined.   

3. Choose the duration of logging, daily, 

weekly (named with the date of the 

Sunday of the current week), or 

monthly, (named with the 1st day of 

the current month.   

4. Choose maximum file size. 

5. Choose data format either binary (file 

compactness and processing efficiency) or 

comma delimited (for importing). 

6. Click ―Add Filter Definition‖ to add filtering 

elements. 

  



Configure FSD Logger to Log Elements 

  

1. In the Edit Filter Options dialog, enter a name for the filter. 

2. Specify which device families, device types, and/or devices to log.  If a single device type 

or specific device is selected, also enable which elements to log by clicking on the 

element in the list. 

3. Under Set Log Interval, specify whether to log element state values under the following 

conditions: (1) every report that occurs, (2) at set intervals (periodically, seconds or 

minutes), and/or (3) only when changes occur. 

  

  

  

  

  

  

  

To enable logs to collect data, either click the ―A‖ on the logger toolbar or select from the Log 

menu->―Enable All Logs‖.   

  

To view the log saved in binary form, select from the Log menu->―Extract Binary Log File‖.  

Select the log file to extract and in the subsequent dialog, specify the name and location of the 

extracted file.  The data in the extracted file are comma delimited. 

  

NOTE:  This example logs both temperature and humidity in the same log file.  One can easily 

configure FSD Logger to create separate files to log temperature and humidity.  Just specify 

which element to log. 

  

  

  
  

 

  
  

 

  

  
  

 

  
  

Simple Example to Configure Operating Modes 

  

The following example shows how use Operating Modes to configure the system.  Although X10 

devices are used in the example, the instructions apply similarly to other device families. 

  

  

Initial system set-up - add FSD Controller, power line interface, and lamp module to the 

system. 

  

1. Open the FSD Autostart application, which starts FSD Router and FSD Automator. 

2. In FSD Automator‘s View menu, choose FSD Namer to assign an FSD Controller (FGI 

Device) and an X10 Power Line Interface (X10 Device) to the system (e.g. TW523 (a 



Timer Etc. family device). 

3. From the FSD Automator application, select FSD Namer-> X10 Devices from the View 

menu. 

4. In the X10 Device List window, click the Insert button.  From the droplist choose X10 

Lamp Module.  Enter a Device Name, set the house and unit code (e.g. B and 2).  Click 

―OK‖. 

5. In the X10 Device List window, click ―OK‖.  If queried by a dialog box, choose to load 

configuration later. 

  

  

Configure Operating Modes and Set Operations - configure operating modes and link device 

elements 

  

1. In FSD Automator‘s View menu, 

choose FSD Namer.  Double-click 

on an Operating Mode Group.  

Check its enabled checkbox and 

choose an Operating Mode Group 

Style:  Radio button (only one 

item selected in the group), 

Independent (choice not 

influenced by other choices), all 

TRUE, or all FALSE. 

2. Select an operating mode by double-

clicking on an entry, set to 

enabled, and name operating 

modes (lower portion of dialog 

box).  Enter ―Away‖, ―At home—

awake‖, ―At home—asleep‖, and 

―On Vacation‖ as names for 

operating modes.  Click ―OK‖.   

  



 

3. In FSD Automator‘s View 

menu, choose FSD Namer 

to assign a Timer, Etc. 

device.  In the Timer List 

dialog, click the Insert 

button.  In the Edit Timer 

dialog, choose Time of Day 

Event from the Timer Type 

droplist.  Enter a name for 

the timer.  Click ―OK‖.  

From FSD Automator, 

choose Timers, Etc. from 

the Configure menu.  Select 

the Time of Day Event 

device type and the device 

name you‘ve entered.  Click 

―OK‖. 

4. In the Configure <device 

name> dialog, set the Start 

and Stop times desired.  In 

the lower third of the dialog 

box, select the days the 

timer is enabled and the 

date range. 

5. In the bottom third choose 

―Enabled in All Operating 

Modes‖, if there are no 

restrictions on whether or 

not operation of the device 

depends on certain 

circumstances.   

6. If there are specific circumstances for operating the device, select ―Enabled in Selected 

Operating Modes‖.  If you choose ―At home—awake‖ and ―School‘s in session‖, the 

timer works only when these modes are operating.  Likewise, choosing ―On Vacation‖, 

the timer would work only 

when that operating mode is 

activated.  Click ―OK‖. 

7. Under the Options Menu 

choose Set Operating 

Modes.  Double-clicking on 

an operating mode on the list 

activates the operating 

mode.  Under the enabled 

column the operating mode 

will be marked with an ―R‖, 

―I‖, ―T‖, or ―F‖, which 

indicates the operating mode 

group‘s style (Radio button 

(only one item selected in 

the group), Independent (choice not influenced by other choices), all TRUE, or all 

FALSE, respectively).  Close dialog box to set changes. 



8. Either (a) right-click the title bar in the device dialog and select Configure Operations from 

the menu or (b) from FSD Automator, choose Timers, Etc. from the Operations menu.  

Choose the timer you‘ve entered.   

9. A tabbed index dialog appears.  On the tabs are the different element types on the Time of 

Day Event device.  Click on ―From Event State‖.  This ―From‖ element sends a signal 

and connects to a ―To‖ element on another device (e.g. lamp module).  Click ―Add‖, to 

add an operation that connects the From and To elements.  From the droplist select 

SET_MONENTARY_PAIR.   

10. In the resulting dialog, select the device family to connect with the ―To‖ element, the 

device type, and device name.  Choose X10, X10 lamp module, and the name you‘ve 

entered, respectively.  The Device element is Momentary On.  Click ―OK‖. 

11. In the tabbed index dialog, click ―Load‖ to load the configuration.   

12. When loading finishes, choose X10 Devices from the Operations menu.  Choose the lamp 

module you‘ve entered.  Click the ―To Momentary On‖ element.  Listed is the operation 

that links to the timer you‘ve entered.  You have configured the system for an event 

timer to control a lamp module. 

13. From the device dialog of the time of day event, click on the Event State button (button 

should change from False to True.  If there is a lamp device on the system with the 

address B-2, changing the event state should turn on and off the lamp module. 

  

For more complex combinations of operating modes to allow an event to be triggered, use 

―Multi-Mode Operation Enabled‖.  Choose the operating modes among the different operating 

mode groups from the list that meet the conditions required.  The operating modes selected are 

compared to the operating modes enabled in Set Operating Modes.  If the operating mode is 

activated, the event occurs when triggered.    

  

The preceding example uses X10 family devices.  However, devices from a different device 

family can be substituted (e.g. UPB devices).  Link elements using operations as described 

above.   
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FSD X10 / UPB / FGI Bridge Controller 

  

The FSD X10/UPB/FGI Bridge Controller provides a flexible and 

highly capable means to support a multi-protocol HA installation.  

It supports  X10 (with extended command capability, including 

variations from different manufacturers), UPB, and hard-wired 

devices via the FGI interface.  The bridge controller can be used 

stand-alone to integrate devices in a mixed X10 and UPB 

installation, or with a legacy X10 controller.   

  

Input and output commands to/from the X10, UPB, and FGI 

devices can be mapped across to the other protocols; for example, an X10 switch or a low-voltage hardwired switch 

could be mapped to send a UPB link command to control UPB devices, and a UPB command could be used to 

control an X10 device, X10 scene, or hardwired relay device.  If used with a legacy X10 controller, input and output 

commands to/from the UPB and FGI devices can be mapped to X10 commands to the legacy X10 controller, via the 

legacy controller TW523 or PL513 X10 interface. 

  

The Bridge Controller also includes a flexible macro programming capability, and interval timer support.  

  

Provided software is used on a Windows XP or Windows 2000 computer 

to configure the bridge controller operation  The computer does not need 

to remain connected during operation. 

If the computer does remain connected to the bridge, the software can be 

used for run-time monitoring and/or control of system devices, using a 

graphical floor-plan oriented user interface.  The provided FSD Automator 

software suite includes a built-in graphical editor for creating layout 

graphics.  Data logging software is provided to log device state data to 

disk; for example, the bridge controller could be used to implement a 

temperature and humidity data logging system.  Run-time X10 and UPB 

commands can also be logged, as can timer and macro states. 

  

Remote monitoring, control, and configuration 

over a LAN, wireless LAN, or the Internet is 

supported in native mode. 

  

Third party application interfacing is supported 

with an easy-to-use interface application, and also 

with a documented packet based monitoring and 

control interface via a serial port USB driver, and 

via TCP/IP using an included PC hosted TCP/IP to 

serial packet router.  The packet based interface is 

consistent across HA protocols, so the same 

interface approach can be used to control X10, 

UPB, and hardwired devices. 

  



The FSD X10/UPB/FGI Bridge Controller can support up to 336 1-way associated device mappings (168 2-way 

device mappings).  The total number of device associations depends on the type of device configured.   

  

  

  

Included With Bridge: 

FSD  X10 / UPB / FGI Bridge 

FSD Automator Software Suite 

Power Transformer, 14VAC 

USB Cable 

X10 Interface Cable 

Use This Bridge With: 

X10 Interface – TW523, PSC05, or equivalent 

Serial UPB Powerline Interface Module 

X10 Devices 

UPB Devices 

FSD Bridge Compatible FGI Hard-Wired Devices 

Wiring Example: 

View example bridge configuration set-up online.  View full documentation online. 

http://www.foardsystems.com/manuals/Example_Scenarios/Configure%20X10-UPB-FGI%20Bridge.pdf
http://www.foardsystems.com/manuals/FSD%20Controller%20Tutorials%20and%20Guides.pdf


  

 

 

 

 

FSD X10 / UPB Compact Bridge 

  

The FSD X10 /UPB Compact Bridge provides a flexible and 

inexpensive means to support a two-protocol HA installation.  It 

supports  X10 (with extended command capability, including 

variations from different manufacturers) and UPB devices.  The 

compact bridge controller can be used stand-alone to integrate devices 

in a mixed X10 and UPB installation, or with a legacy X10 controller.   

  

Input and output commands to/from the X10, UPB, and FGI devices 

can be mapped across to the other protocols; for example, an X10 

switch or a low-voltage hardwired switch could be mapped to send a 

UPB link command to control UPB devices, and a UPB command 

could be used to control an X10 device, X10 scene, or hardwired relay 

device.  If used with a legacy X10 controller, input and output commands to/from the UPB and FGI devices can be 

mapped to X10 commands to the legacy X10 controller, via the legacy controller TW523 or PL513 X10 interface. 

  

The Compact Controller also includes a flexible macro programming capability, and interval timer support.  

  

Provided software is used on a Windows XP or Windows 2000 computer to configure the compact bridge operation  

The computer loads the bridge via the UPB serial port, and does not remain connected during operation. 

  

Device and operation configuration of the FSD X10 / UPB Compact Bridge uses the same methodology as larger 

bridges and controllers in the FSD product line.  Upward compatibility within the family allows data configured for 

the compact bridge to be loaded into an FSD X10 / UPB / FGI Bridge if at some point greater capacity, additional 

software features,  and / or hardware device support is desired. 

  

The FSD Compact Bridge Controller can support up to 176 1-way associated device mappings (88 2-way device 

mappings).  The total number of device associations depends on the type of device configured.  

  

 

 

  

Specifications 

Inputs:     

    Host computer loads through RS-232 UPB port 

    RJ-11 input from legacy HA controller 

            Emulates TW523 or PL513 X10 Interface 

    9 VAC, 100ma 

Outputs:   

    RJ-11 connection to TW523, 

         PSC05, or PL513 X10 Interface 

    RS-232 connection to Serial 

         UPB Powerline Interface Module 

Dimensions: 

    Bridge:  5‖ x 3‖ x 1‖ 

  

FSD X10 / UPB Compact Bridge



 

  

Included With Bridge: 

FSD X10 / UPB Compact Bridge 

FSD Automator Software Suite 

Power Transformer, 9VAC 

X10 Interface Cable 

Use This Bridge With: 

X10 Interface – TW523, PSC05, or equivalent 

Serial UPB Powerline Interface Module 

X10 Devices 

UPB Devices 

Wiring Example: 

View example bridge configuration set-up online.  View full documentation online. 

http://www.foardsystems.com/manuals/Example_Scenarios/Configure%20X10-UPB%20Bridge.pdf
http://www.foardsystems.com/manuals/FSD%20Controller%20Tutorials%20and%20Guides.pdf


 

 

 

 

 

FSD X10 / UPB / FGI Bridge Controller Plus 

  

The FSD X10/UPB/FGI Bridge Controller Plus provides a flexible 

and highly capable means to support a multi-protocol HA 

installation.  It supports X10 (with extended command capability, 

including variations from different manufacturers), UPB, and 

hard-wired devices via the FGI interface.  The bridge controller 

can be used stand-alone to integrate devices in a mixed X10 and 

UPB installation, or with a legacy X10 controller.   

  

Input and output commands to/from the X10, UPB, and FGI devices can be mapped across to the other protocols.  

For example, an X10 switch or a low-voltage hardwired switch could be mapped to send a UPB link command to 

control UPB devices, and a UPB command could be used to control an X10 device, X10 scene, or hardwired relay 

device.  If used with a legacy X10 controller, input and output commands to/from the UPB and FGI devices can be 

mapped to X10 commands to the legacy X10 controller, via the legacy controller 

TW523 or PL513 X10 interface. 

  

The FSD X10/UPB/FGI Bridge Controller Plus also includes a flexible macro 

programming capability, interval timer, and time-of-day timer support.  

  

Provided software is used on a Windows XP or Windows 2000 computer to 

configure the bridge controller operation  The computer does not need to remain 

connected during operation.  If the computer does remain connected to the 

bridge, the software can be used for run-time monitoring and/or control of 

system devices, using a graphical floor-plan oriented user interface.  The 

provided FSD Automator software suite includes a built-in graphical editor for 

creating layout graphics.  Data logging software is provided to log device state 

data to disk; for example, the bridge controller could be used to implement a temperature and humidity data logging 

system.  Run-time X10 and UPB commands can 

also be logged, as well as timer and macro states. 

  

Remote monitoring, control, and configuration over 

a LAN, wireless LAN, or the Internet is supported 

in native mode. 

  

Third party application interfacing is supported 

with (1) an easy-to-use interface application, and 

(2) also with a documented packet based 

monitoring and control interface via a serial port 

USB driver, and via TCP/IP using an included PC 

hosted TCP/IP to serial packet router.  The packet 

based interface is consistent across HA protocols, 

so the same interface approach can be used to 

control X10, UPB, and hardwired devices. 

  

The FSD X10/UPB/FGI Bridge Controller Plus can support up to 672 1-way associated device mappings (336 2-

way device mappings).  The total number of device associations depends on the type of device configured.    

  

FSD X10 / UPB / FGI Bridge Controller Plus



 

  

 

 

 

 

FSD X10 Compact Controller 

  

The FSD X10 Compact Controller is a highly capable yet low-cost 

single-protocol X10 home automation controller.  It supports X10 

devices, including those with extended commands for groups and scenes, 

and X10 protocol variations from different manufacturers.  The compact 

controller can be used stand-alone after initial configuration.   

  

Input and output commands to/from the X10 devices can be mapped 

across to others; for example, an X10 switch could be mapped to send a 

commands to control other X10 devices with different House and Unit 

code addresses, and also configured to operate with timer and macro 

devices.   

  

The FSD X10 Compact Controller also includes a flexible macro programming capability, interval timer, and time-

of-day timer support.  

  

Provided software is used on a Windows XP or Windows 2000 computer to 

configure the compact controller operation  The computer does not need to 

remain connected during operation.  If the computer does remain connected to 

the controller, the software can be used for run-time monitoring and/or control of 

system devices, using a graphical floor-plan oriented user interface.  The 

provided FSD Automator software suite includes a built-in graphical editor for 

creating layout graphics.  Data logging software is provided to log device state 

data to disk.  Run-time X10 commands can also be logged, as can timer and 

macro states. 

  

Remote monitoring, control, and configuration over a LAN, wireless LAN, or the Internet is supported in native 

mode. 

  

Third party application interfacing is supported with an 

easy-to-use interface application, and also with a 

documented packet based monitoring and control 

interface via a serial port USB driver, and via TCP/IP 

using an included PC hosted TCP/IP to serial packet 

router.  The packet based interface is consistent across 

HA protocols, so the same interface approach can be 

used to control X10, UPB, and hardwired devices, 

using other controller and bridge products in FSD‘s 

automation product line. 

  

The FSD X10 Compact Controller can support up to 

64 devices.  The total number of device depends on the 

type of device configured.  

  

FSD X10 Compact Controller



  

  

 

  

Wiring Example: 

Included With Controller: 

FSD X10 Compact Controller 

FSD Automator Software Suite 

Power Transformer, 9VAC 

USB Cable 

X10 Interface Cable 

Use This Controller With: 

X10 Interface – TW523, PSC05, or equivalent 

X10 Devices 

View documentation online. 



  

 

 

 

 

FSD UPB Compact Controller 

  

The FSD UPB Compact Controller is a highly capable yet low-cost single-

protocol UPB home automation controller.  It supports UPB devices, 

including UPB link commands for groups and scenes.  The compact 

controller can be used stand-alone after initial configuration.   

  

Input and output commands to/from the UPB devices can be mapped 

across to others; for example, a UPB switch could be mapped to send a 

commands to control other UPB devices with different addresses mapped 

through the controller, and also configured to operate with timer and macro 

devices.   

  

The FSD UPB Compact Controller also includes a flexible macro 

programming capability, interval timer, and time-of-day timer support.  

  

Provided software is used on a Windows XP or Windows 2000 computer 

to configure the compact controller operation  The computer does not 

need to remain connected during operation.  If the computer does remain 

connected to the controller, the software can be used for run-time 

monitoring and/or control of system devices, using a graphical floor-plan 

oriented user interface.  The provided FSD Automator software suite 

includes a built-in graphical editor for creating layout graphics.  Data logging software is provided to log device 

state data to disk.  Run-time UPB commands can also be logged, as can timer and macro states. 

  

Remote monitoring, control, and configuration over a LAN, wireless LAN, or the Internet is supported in native 

mode. 

  

Third party application interfacing is supported with an easy-to-use interface application, and also with a 

documented packet based monitoring and control interface via a serial port USB driver, and via TCP/IP using an 

included PC hosted TCP/IP to serial packet router.  The packet based interface is consistent across HA protocols, so 

the same interface approach can be used to control X10, UPB, and hardwired devices, using other controller and 

bridge products in FSD‘s automation product line. 

  

The FSD UPB Compact Controller can support up to 64 devices.  The total number of device depends on the type of 

device configured.  

  

  

  

  

  

  

  

  

  

  

FSD UPB Compact Controller



 

Wiring Example: 

Included With Controller: 

FSD UPB Compact Controller 

FSD Automator Software Suite 

Power Transformer, 9VAC 

USB Cable 

  

Use This Controller With: 

Serial UPB Powerline Interface Module 

UPB Devices 

View documentation online. 

http://www.foardsystems.com/manuals/FSD%20Controller%20Tutorials%20and%20Guides.pdf

